Technisat SkyStar S2

  • Wenn man für sein älteres Bord eine PCI-Karte für DVB-S2 sucht, ist man im Moment schnell rund 50 Euro los - auch wenn man "nur" Free to air haben will-


    Die Technisat SkyStar2 bekommt man zur Zeit so billig, dass ich mich mal zugeschlagen habe und Warentester spiele. Skepsis herrscht vor, ich habe eine alte Technisat DVB-S Karte, die jetzt kein SAT.1, Pro7 & Co mehr schafft ... (nennt sich leider auch Skystar 2 // Rev 2.6D)


    Bei mir meldet sich die Karte mit

    Code
    1. 03:06.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)


    und wie hier (easy-vdr-wiki) und hier (linuxtv.org) beschrieben, läuft die Karte mit aktuellem Kernel tatsächlich out of the box - wenn man davon absieht, dass man noch eine Firmware runterladen muss (vgl. genannte Links).


    Meine ersten Erfahrungen:
    Dort, wo das Signal stimmt, klappt alles bisher wie gewünscht. Wenn der Empfang dünn wird (meine Schüssel versucht sich an den UK-Sendern auf 28.2E), kommt die erste Ernüchterung bei mir:
    Sowohl mein Fernseher als auch eine schon Jahre im Betrieb befindliche TT-1600 schaffen ITVHD, die Skystar liefert am gleichen Kabel und gleichem PC bestenfalls grüne Kästchen und Gepiepse. Komisch finde ich, dass die anderen FTA-HD Sender (BBC, Channel 4) empfangen werden, auch wenn das Tuning etwas länger braucht.


    Soweit meine ersten Eindrücke. Wie gesagt, vielleicht gibt es ja hier noch andere mit dieser Karte und oder Tipps und Tricks?

    Hauppauge WinTV-dualHD auf Desktop mit archlinux ...


    The post was edited 2 times, last by berndb ().

  • die Skystar2 ist eine DVB-S1 Karte und kann nur MPEG2 darstellen.
    99% der HD Sender senden aber in DVB-S2 und damit in MPEG4.
    Ich meine die Engländer senden ihre Sender auch nur noch in MPEG4.


    Es gibt auch immer mehr SD Sender die man nur in DVB-S2 reinbekommt (z.B. Sky und evtl auch die Pro7/Sat1 Gruppe.

    -- wird überarbeitet -- VDR- Server: Gigabyte Brix 3150 - (2x Hauppauge DualHD DVB-C Sticks mit 4 Tunern) - Ubuntu 18.04 - Aufnahme und Streaming-Server
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi + openelec

  • Hi,



    Bei mir meldet sich die Karte mit

    Code
    1. 03:06.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)


    hab die Skystar S2 schon 1 Jahr im Test-VDR ..bei mir ist die Ausgabe aber nee andere!

    Code
    1. b2c2-flexcop: initialization of 'Sky2PC/SkyStar S2 DVB-S/S2 rev 3.3' at the 'PCI' bus controlled by a 'FlexCopIIb' complete


    Das ist die Karte die in den Links angeben ist.


    Gruss
    Wolfgang

  • Die SD-Variante habe ich in meinem Initialpost erwähnt. Das die PRO7-Sat.1 Gruppe ihre SD-Programme nicht mehr in DVB-S, sondern DVB-S2 sendet, ist mir neu .... Gerade mal reingetuned - mein VDR sagt, die sind DVB-S. Das ist also wohl nicht der Grund für meine Empfangsprobleme mit meiner alten(!) DVB-S-Technisat-Karte bei diesen Sendern.


    Die beiden Links in meinem Post verweisen auf eine DVB-S2-Karte. Das erklärt, warum ich mit Ihr ARD, arte und ZDF usf. in HD empfange.


    Ja, die Engländer senden auch mit DVB-S2, deshalb empfange ich mit der Karte ja auch BBC und Channel 4 in HD. Nur (!) bei ITV HD klemmt es bei mir.


  • Hier mal das komplette lspci von dem PC, in dem ich das Ding im Moment drin habe. Die alte DVB-S Technisat liegt neben mir auf dem Tisch.

  • Gut,


    die gleiche Ausgabe wie bei wolfi.m erhalte ich mit:

    Code
    1. dmesg | grep flex
    2. [ 8.933808] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
    3. [ 9.035092] flexcop-pci: will use the HW PID filter.
    4. [ 9.035100] flexcop-pci: card revision 2
    5. [ 9.048657] b2c2-flexcop: MAC address = 00:08:c9:e0:bc:d1
    6. [ 9.710606] b2c2-flexcop: ISL6421 successfully attached.
    7. [ 9.710613] b2c2-flexcop: found 'Conexant CX24120/CX24118' .
    8. [ 9.710621] b2c2_flexcop_pci 0000:03:06.0: DVB: registering adapter 0 frontend 0 (Conexant CX24120/CX24118)...
    9. [ 9.711729] b2c2-flexcop: initialization of 'Sky2PC/SkyStar S2 DVB-S/S2 rev 3.3' at the 'PCI' bus controlled by a 'FlexCopIIb' complete


    Also bei lspci heißt sie Skystar2, was blöd ist, weil es die gleiche Bezeichnung ist, die auch die DVB-S Variante trägt. Beim booten meldet der Kernel offenbar den Namen Skystar S2. Ich ändere das mal in der Thread-Überschrift.

  • Hallo,


    ich habe mir auch zwei Skystar S2 geholt, da mein Board noch so viele PCI-Slots übrig hat. Unter Arch laufen sie nach installieren der Firmware schon mal, kann mit w_scan suchen. Soweit so gut.


    Wie läuft die Karte denn auf Astra 19.2E? Das Erste HD, ZDF HD, NDR HD, arte HD funktionieren bei mir, RTL als z.B. nicht. Ein Suchlauf mit w_scan findet mit beiden Karten nur ca. 300 Sender. Kann natürlich sein, dass das Signal zu schlecht ist. Kann jemand bestätigen, dass sie eigentlich alle Sender von Astra reinbekommt? Die bisherige TBS-6981 hat keine Probleme am gleichen Anschluss. Andere Sat-Positionen sind später erst geplant und müssen nicht zwingend mit der Skystar S2 laufen.


    Außerdem wird die zweite Karte direkt nach dem Start des VDR nur als DVB-S-Karte erkannt. dmesg stimmt aber mit wolfi.m überein und nach einigem Zappen wird auch ein DVB-S2-Device draus. Einzeln funktionieren die Karten mit genanntem Tuning-Problem. Ist das "DVB-S vs. DVB-S2" Phänomen im VDR bekannt? Ich kann mich erinnern, dass ich ähnliche Probleme mit DVB-C/T schonmal hatte, aber damals dank Ausweichhardware nicht weiter verfolgt habe.


    EDIT: Der zweite Tuner der TBS wird anfänglich auch nur als DVB-S erkannt, nach umschalten auf S2 Kanäle aber korrekt angezeigt.


    Grüße

    VDR1: ASRock P67 Pro3, Core i3-2100T, 2*4GB DDR3, ASUS GT630 2GB, TBS-6981 Dual DVB-S2, 128GB SSD, 2TB HDD, vdr4arch
    VDR2: FSC Esprimo E5720, Celeron 440, 2*1GB DDR2, ASUS GT520 1GB, L4M-Twin CT v6.1, 2TB HDD, X10 FB, yaVDR 0.5

    The post was edited 1 time, last by einsteinchen: siehe EDIT ().

  • Auf S28.2E gibt es mehrere ITV-HD-Kanäle, und zwar mindestens sechs regionale Varianten auf drei Transpondern. Die Transponder sind wohl möglicherweise auch von unterschiedlichen Satelliten oder mit unterschiedlichen Ausleuchtzonen ausgestrahlt. Ich hatte mit den meisten Kanälen davon Empfangsprobleme. Glücklicherweise lassen sich die beiden Kanäle auf 11052 H von meinem Standort und mit meiner Empfangsanlage recht gut reinkriegen. Es hat aber Zeit gebraucht, genau diese Kanäle aufzuspüren, zumal ITV mit all ihren Sendern andauernd die Frequenzen wechselt auf S28.2E und man alle drei Monate nachpflegen darf.


    Auf 11052 H:

    Code
    1. ITV Wales HD;BSkyB:11052:HC34M5O25P0S1:S28.2E:23000:2320=27:2322=NAR@4;2321=eng@106:2323;2324=eng:0:20730:2:2063:0
    2. ITV HD;BSkyB:11052:HC34M5O25P0S1:S28.2E:23000:2330=27:2332=NAR@4;2331=eng@106:2333;2334=eng:0:20740:2:2063:0


    Auf 11097 V:

    Code
    1. ITV HD;BSkyB:11097:VC34M5O25P0S1:S28.2E:23000:2305=27:2307=NAR@4;2306=eng@106:2308;2309=eng:0:21000:2:2066:0
    2. ITV HD;BSkyB:11097:VC34M5O25P0S1:S28.2E:23000:2315=27:2316=NAR@4;2317=eng@106:2318;2319=eng:0:21020:2:2066:0
    3. ITV HD;BSkyB:11097:VC34M5O25P0S1:S28.2E:23000:2320=27:2321=NAR@4;2322=eng@106:2323;2324=eng:0:21030:2:2066:0


    Auf 11067 V:

    Code
    1. STV HD;BSkyB:11067:VC23M5O25P0S1:S28.2E:23000:2305=27:2307=NAR@4;2306=eng@106:2308;2309=eng:0:20800:2:2064:0


    Gruß
    hepi

  • Wie läuft die Karte denn auf Astra 19.2E?


    Also auf Astra hatte ich bisher keine Probleme.

    ...funktionieren bei mir, RTL als z.B. nicht


    Gerade mal auf RTL geschaltet - Bild sofort da.


    Auf Amazon hat jemand in einem Kommentar geschrieben, dass die Karte manchmal nach dem Booten nicht sofort erkannt wird. Dann hilft nur ein Reboot und hoffen, dass es diesmal klappt.


    Ich hatte das heute auch schon zum dritten Mal. Dmesg zeigt:


    Statt zu rebooten habe ich mal vesucht, alle Treibe zu entladen. Das beste, was mir bisher einfiel war:

    Code
    1. modprobe -r -a cx24120 b2c2_flexcop_pci b2c2_flexcop cx24123 stv0299 lgdt330x b2c2_flexcop dvb_core
    2. [modprobe -a cx24120 b2c2_flexcop_pci b2c2_flexcop cx24123 stv0299 lgdt330x b2c2_flexcop dvb_core


    Das soll der Versuch sein, alle Treiber, die irgendwie was mit der Karte zu tun hat zu entfernen und wieder zu laden.


    Tatsächlich meldet dmesg:


    "CX24123: wrong demod revision: e9" und

    Code
    1. nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121)
    2. [ 243.427775] nxt200x: Unknown/Unsupported NXT chip: 00 00 00 00 00


    klingen nun in meine unwissenden Ohren nicht so dolle. Aber immerhin ist so ohne Reboot Bild und Ton da. Wenn das so zuverlässig klappt, wäre das ja ein work around für zeitgesteuert hochfahrende Systeme ...

    Hauppauge WinTV-dualHD auf Desktop mit archlinux ...


    The post was edited 1 time, last by berndb ().

  • So, nun auch mal alle Channels von Hepi durchprobiert:


    Mit meiner Technotrend TT 1600 habe ich bei allen Kanälen Empfang, mit der Skystar S2 gibt es immerhin beim letzten ("STV HD") ein Bild. So ganz ohne Klötzchen scheint mir es auch hier nicht zu gehen, der Ton ist aber soweit sauber.


    Sieht für mich immer noch so aus, als sei die Skystar doch etwas wählerischer, was das SAT-Signal betrifft. Ich mach nochmal eine Probeaufnahme, um auszuschließen, das xineliboutput die Klötzchenquelle ist.

  • Hi,


    ...noch ein paar Eigenheiten der SkyStar S2.
    Hin und wieder kann es zu einem Frequenzdrift bei diesen Karten kommen. Einige bei uns im Forum(easyVDR) hatten das Problem.
    Bei mir waren/sind HD-Sender(nicht alle) davon betroffen, mit +3 Mhz sind die Sender dann hell.
    Karte ist eine "Sky2PC/SkyStar S2 DVB-S/S2 rev 3.3" ob das an der Version/Tuner der Karte liegt oder am LNB, keine Ahnung.
    Die Möglichkeit, dass das LNB der Schuldige ist glaube ich aber nicht.


    Beispiel:
    ...kein Bild

    Quote

    Fox HD;SKY:11332:HC34M5O35P0S1:S19.2E:22000:1023=27:0;1027=deu@106,1028=eng@106:32:9C4,98C:124:133:10:0


    ...Bild Ok

    Quote

    Fox HD;SKY:11335:HC34M5O35P0S1:S19.2E:22000:1023=27:0;1027=deu@106,1028=eng@106:32:9C4,98C:124:133:10:0


    Was man auch noch beachten sollte!

    Quote

    "No support for 8PSK 3/4. To support the need to replace the crystal oscillator of 45 MHz to 66,667 MHz"


    Bis jetzt konnte ich noch keinen Thread finden in dem geschildert wurde das nach tausch des Oscillators die betroffenen
    Frequenzen auch funktionierten.


    Bei mir funktionieren z.B diese Sender überhaupt nicht!

    Quote

    E! Entertainm. HD,E! HD;SKY
    Pro7 FUN HD;SKY
    TNT Glitz HD;SKY
    Universal HD;SKY


    Spielt aber keine Rolle, da die Karte nur im Testsystem eingesetzt wird.


    Gruss
    Wolfgang

  • Der Tipp von wolfi war gut bzgl. 8PSK FEC 3/4: Das bedeutet, die Karte kann alle Kanäle, wo im Kanalstring ein C34M5 drinsteht, nicht tunen. Das gilt auch genau für die ITV HD-Kanäle.


    Oszillatortausch heißt wohl Lötkolben vorwärmen, oder?


    Gruß
    hepi

  • Das bedeutet, die Karte kann alle Kanäle, wo im Kanalstring ein C34M5 drinsteht, nicht tunen


    Mit dem Frequenzdrifttrick kann wolfi.m aber offenbar FOXHD tunen, und da steht auch "C34M5" im Kanalstring.


    Ich habe jetzt noch mehr Zeit an die Karte verschwendet :rolleyes:?(:rolleyes: und auf einer alten Platte Windows draufgeknallt und in meinen Rechner gehängt. Also gleiche Karte, gleicher Rechner, gleiches Kabel zur Sat-Schüssel.


    Mit ProgDVB einen Suchlauf gemacht und siehe da, er findet nicht nur diverse ITVHD Sender, der Empfang läuft offenbar problemos?!


    Hier die Daten, die ich aus ProgDVB abgeschrieben habe:

    Code
    1. Frequenz Pol Symbrate Modulation SID TID NID PMT PCR Video Teletext ECM
    2. Name 11.097.000 V 23.000 NBC_8PSI 21030 2066 2 261 2320 2320 2323 0
    3. ITV HD 11.097.000 V 23.000 NBC_8PSI 21000 2066 2 258 2305 2305 2308 0
    4. ITV HD 11.097.000 V 23.000 NBC_8PSI 21020 2066 2 260 2315 2315 2318 0
    5. ITV HD 11.053.000 H 23.000 NBC_8PSI 20740 2063 2 260 2330 2330 2333 0
    6. ITV HD Wales 11.053.000 H 23.000 NBC_8PSI 20730 2063 2 256 2320 2320 2323 0
    7. STV HD 11.068.000 V 23.000 NBC_8PSI 20800 2064 2 261 2305 2305 2308 0


    Ist was mit dem Treiber im Kernel nicht in Ornung? Würde es Eurer Meinung eine Chance geben, mit "Vorversionen" wie dieser hier andere Ergebnisse zu erzielen?

    Hauppauge WinTV-dualHD auf Desktop mit archlinux ...


    The post was edited 1 time, last by berndb ().

  • Hi,



    Ist was mit dem Treiber im Kernel nicht in Ornung? Würde es Eurer Meinung eine Chance geben, mit "Vorversionen" wie dieser hier andere Ergebnisse zu erzielen?


    hab den angepassten Patch schon seit über einem Jahr in unserm(easyVDR) media-build-experimental-dkms includiert. Dieses Paket ist auch auf meinem Test-Rechner installiert, da der Kernel-Trieber mit einem Plugin(hust,hust) nicht funktioniert.
    Wenn du yaVDR(trusty) verwendest, kannst du das Paket installieren, build gegen Kernel-3.19/4.2.0/4.2.3 ist Ok.


    Gruss
    Wolfgang

  • Heißt "angepasster Patch", dass Du den nochmal für neuere Kernel verändert hast? Hättest Du einen Link zu diesem Patch - ich denke, da ich diesen Test wohl auf einen 32bit-Rechner machen werde, dass ich einen Kernel zum Vergleich bauen werde(n muss).
    Wenn nicht nehme ich einfach den Patch aus dem Link oben und baue halt einen passenden 3.x-Kernel.

  • So, konnte jetzt immerhin jeweils eine 32bit und eine 64bit Version von Kernel 3.18.29 erstellen.


    Auf der 32bit Maschine empfange ich nun wie unter Windows alle aufgeführten ITV-HD-Kanäle, auf der 64 bit Maschine immerhin alle außer den beiden auf 11.052 (oder 11.053?).


    Also scheint der Treiber nicht ganz unschuldig zu sein, wenn ich das Ergebnis auch nicht ganz schlüssig finde: Auf dem gleichen PC, auf dem mit Windows alle Kanäle gehen, klappt es mit dem aktuellem Kernel aus dem ARCH-REPO nur mit einem ITV-HD-Kanal - allerdings mit kleinen Bildstörungen-, mit dem gepatchten Kernel 3.18.29 dann mit fünf ITV-Kanälen, mit dem gleichen Kernel auf dem 32-bit-PC dann alle ...

  • Hi,


    habe mir bei Pollin 2 Skystar S2 mitgekauft, aber in meinem Asus M2N-VM funktioniert immer nur eine gleichzeitig?
    Also beide in die zwei PCI-Slots gesteckt und erkannt wurden zwar beide aber funktioniert hat immer nur eine...
    Habe dann einzeln nur eine ausprobiert und in sowohl den linken und auch mal in den rechten PCI-Slot gesteckt.
    Hat alleine auch immer funktioniert.


    Irgendwo habe ich gelesen die Stromaufnahme soll recht groß sein. Die DVB-Karten hängen bei mir an einem Multiswitch.
    Mein Netzteil hat 430W, kann das zuwenig sein? Oder doch zuwenig Saft vom PCI-Slot?


    Bislang habe ich jetzt wieder zurückgebaut auf meine zwei TT S-1401.


    Für Infos Dankbar


    Gruß


    Joe_D

  • Ich habe inzwischen Mauro's neuen Treiber probiert:
    https://www.linuxtv.org/wiki/index.php/TechniSat_SkyStar_S2


    Leider knallt er hier raus bei schwachem Signal mit einem Divide (by 0) Error, kann das jemand bestätigen?



    Dann bitte das Problem und die anderen auf der linux-media Liste melden, der Kernel Bugzilla ist wohl immer noch der beste Weg nen Bug zu "begraben" :D

    VDR1: yavdr ppa VDR 2.0.6 auf iBase Industrial Mini-ITX MB896IL +DVI- Modul +Gb Ethernet Mini-PCI Motherboard, Pentium M 740, 1GB RAM, mit 3x KNC1 C+/MK3 PCI auf LSI Logic 3x PCI-64 Rev. 2.3 Intel 21154 aktive Riser Card 2135-5V mit abgesägtem 64Bit- Steckerteil im PCI- Slot auf upriser,
    HDTV xineliboutput mit xine-plugin-crystalhd für Broadcom CrystalHD BCM970015 auf 15cm PCI-E 1x Flachbandriser im PCI-E 1x v.1.0a Slot.
    IPTV vdr-plugin-iptv und ffmpeg als rtsp/rtmp/hls "tuner frontend", stream sanitizer und mpegts wrapper.

    The post was edited 1 time, last by woprr ().