Help please VDR/KODI VNSI or XVDR

  • Hatte zum letzten Mal, VDR mit XBMC ende 2013 prima zum laufen gebracht (VDR 2.1.3, vdr-vnsiserver of jan 2014, XBMC 12.2, xbmc-addon-pvr same time - from FernetMenta).


    Jetzt probiere ich das gentoo aufzuruesten, und ich kriegs nicht zusammen. Waere prima, wenn mir jemand empfehlen koennte, genau welche VNSIserver komponent (im VDR) und komponente im KODI ich ausprobieren sollte.


    media-plugins/vdr-vnsiserver-1.3.1 seems to be fine in VDR.
    Das problem ist das sich KODI 16.0 ueber inkompatibles API beschwert: media-plugins/xbmc-addon-pvr (from https://github.com/opdenkamp/xbmc-pvr-addons):


    PVR - Add-on 'VDR VNSI Client' is using an incompatible API version. XBMC minimum API version = '4.1.0', add-on API version '1.9.4'


    Ideen, Vorschlaege bitte!

  • Nimm https://github.com/kodi-pvr/pvr.vdr.vnsi statt der veralteten Sammlung der PVR-Addons für KODI.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vermutlich fehlt dir das: https://github.com/xbmc/kodi-platform


    Warum nimmt man dann überhaupt Gentoo, wenn man nicht selber Software kompilieren und Knietief in den Interna stecken will?
    Das ist doch der ganze Spaß dabei, sonst könnte man ja einfach eine Distribution nehmen, für die es fertige Pakete gibt... :versteck

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Warum nimmt man dann überhaupt Gentoo, wenn man nicht selber Software kompilieren und Knietief in den Interna stecken will?
    Das ist doch der ganze Spaß dabei, sonst könnte man ja einfach eine Distribution nehmen, für die es fertige Pakete gibt... :versteck


    Die kurze Antwort ? Mir hat 2008 jemand einen VDR PC zusammengebastelt mit Gentoo und da bin ich dran haengen geblieben.


    Keine Ahnung, ob man mit den Binaersystem genau so flexibel ist und besser Pakete bekommt. Gibt es alle aktuellen VDR und KODI pakete binaer fuer debian/ubuntu ? Mit allen plugins und so ?


    Ist vor allem Gewoehnungssache, kenne halt inzwischen hinreichend viele tricks um mit Gentoo klarzukommen. Bei Ubuntu stehe ich immer im Wald wenn da halt dann ein Paket nicht so da ist wie man es braucht. Und wenn man dann quelle patchen muss oder so...


    Immerhin habe ich das gentoo seit 2008 immer nur aufgeruestet, also nie neu installiert. Mach das mal mit einem Ubuntu/Debian nach. Ok. der Upgrade auf 64 bit wird witzig ;-)

  • Ach ja. VDR/XBM geht jetzt.


    Das Hauptproblem war das libplatform auf libp8-platform umbenannt wurde, und da halt auch alle include-namen geaendert wurden. Und das vnsi plugin verwendet noch die libplatform syntax und kodi >= 16 halt libp8-platform. Soweit waere es kein problem, bloss hat jemand in den dependencies mehrerer pakete reindefiniert das libplaform inkompatibel mit libp8-platform ist. Was nicht stimmt. Habe mir halt gefixte ebuilds fuer kodi, libplatform/llibp8platform usw in /usr/local/portage gelegt, so dass ich da eine stabil funktionierente build-option habe.


    Bei binaersystemen (Ubuntu) habe ich das nie geschafft solche Abhaengigkeitsprobleme zu loesen. Willste neues system dann kannste halt nicht altes modul (vnsi) nehmen. Muddu erst warten bis das mal jemand an die neuen APIs angepasst hat.


    Ich nenne das jetzt API-Aenderunsfaschismus.


    Am schlimmsten ist ja Perl. Habe einen Sack schoener squeezeboxes im Haus, und nach Aufruestung hat das system jetzt perl 20.2 (und irgendwelche neuen Teile MUESSEN das haben), und dann kann man halt nicht mehr eine schicke aber uralte Software wie Logitechmediaserver verwenden. Die ist naemlich ganz nett mit Abhaengigkeiten nach gefuehlt 50 perl modulen geschrieben, und bei denen muessen immer wieder viele auf neue Perl Versionen angepasst werden.


    Naja gut. jetzt laeuft logitechmediaserver in einem docker container und damit hat sich das fuer immer. Nix mehr mit unsinnigem Upgraden. Ueber kurz oder lang mache ich das mit allen Anwendungen die stabil laeufen und nicht aufgeruestet werden muessen.