Plötzlich kein ZDF HD mehr[gelöst]

  • ich versuche ruhig zu bleiben, tief Luft holen, nicht aufregen.................................................
    So wie es aussieht, funzt die FB doch, und auch das ImonLCD zeigt zumindest Menüpunkte an.
    Einzig und allein die DVB-Karte wird wohl nicht erkannt.
    Folgendes habe ich lt Anleitung gemacht:
    Das treiberpaket tt_s2_4100_drv_lnx.tar ins rootverzeichnis kopiert.

    Code
    1. tar xjvf tt_s2_4100_drv_lnx.tar.bz2
    2. cd tt_s2_4100_drv_lnx
    3. ./tt_install_lnx3x_x64.sh
    4. make
    5. make install
    6. shutdown -r now


    Das ganze lief ohne Fehlermeldung durch, nur dauerte es verdächtig lange. Nach dem Neustart heissts dann:

    Quote

    Wenn alle Schritte von „Punkt 2“ ohne Fehler ausgeführt wurden, kann der letzte
    Schritt durchgeführt werden:
    # dmesg | grep frontend


    Gebe ich das ins Terminal ein erhalte ich folgende Meldung:

    Code
    1. yavdr@htpc:~$ dmesg | grep frontend
    2. [ 15.984875] init: wait-for-job-state (vdr-frontendvdr) main process (1081) killed by TERM signal


    Versuche ich über vdr-live einen wirbelscan, meldetz er nur: No devices found.
    Heisst also er findet die DVB-Karte nicht, resp. keinen Treiber?
    Terminal:

    Code
    1. dmesg | grep DVB


    ergibt keine Ausgabe

    Code
    1. yavdr@htpc:~$ lspci -v
    2. 03:00.0 Multimedia video controller: Spin Master Ltd. Device 3038 (rev 01)
    3. Subsystem: Technotrend Systemtechnik GmbH Device 3016
    4. Flags: bus master, fast devsel, latency 0, IRQ 11
    5. Memory at f9000000 (32-bit, non-prefetchable) [size=4K]
    6. Capabilities: <access denied>


    jedenfalls wird sie wohl erkannt.
    Wie könnte ich weiter vorgehen?

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

    The post was edited 1 time, last by pierre2000 ().

  • hab die alte Karte wieder eingebaut, auf die schnelle komm ich nicht weiter,
    Da ich vermutlich erst Donnerstagabend wieder dazu komme, würde ich mich über ein paar Ideen zur Technotrend sehr freuen,
    Meine Vermutung:
    Entweder falscher Treiber (Kernelabhängig?, der Treiber ist angeblich bis Kernel 4.x getestet)
    Oder Treiber nicht geladen, nur, warum?


    Danke und Gruss,

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

    The post was edited 1 time, last by pierre2000 ().

  • Hab heute morgen noch den Verkäufer kontaktiert:

    Quote

    Sie haben hier wohl das Paket für die TechnoTrend 4100 installiert (= Singletunerkarte), haben aber wohl die 4200er erworben (=Dual Tunerkarte).
    Die 4200 basiert auf der DVBSky S952 Karte, hier finden Sie die entsprechende Firmware und Treiber:


    Da muss man auch erstmal draufkommen :§$%
    Von Technotrend habe ich folgende Info erhalten:

    Quote

    Die Treiber der S2-4200Twin sind bereits unter Linux verfügbar, wir arbeiten gerade daran, dass alles im Linux Treiber für unsere Karte vorbereitet wird. In ein paar Tagen sollte das fertig sein.


    Wir werden sehen..............


    ähem, such schon wieder ewig erfolglos rum, aber wie krieg ich den Treiber wieder deinstalliert? apt-get purge geht logischerweise nicht, mit rm komm ich auch nicht weiter ?(?(

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

    The post was edited 1 time, last by pierre2000 ().

  • Krieg die blöde Karte nicht ans laufen, wobei das Problem, wie bei mir leider üblich, eher zwischen den Daumen zu suchen ist ;(;(
    Habs mit der Anleitung versucht:
    git
    dann noch damit:
    DVBSky S952 bekomme nicht zum laufen
    Kompilieren lief in beiden Fällen ohne Fehler durch, hab jedenfalls keine gesehen, keine Unterbrechung
    Ich hab zwar Kernel 3.2.0.99, habs aber mit 3.2.0.80 versucht, hatte einfach Angst, dass ich nicht mehr zurück kann, wenn das alles kernelabhängig installiert ist


    In beiden Fällen wird die Karte erkannt, aber keine Treiber geladen, allerdings gibts auch keinerlei Ausgabe zum TV. Menüeinträge sehe ich nur auf dem ImonLCD, der TV bleibt dunkel. Sieht also so aus, als würde auch die GraKa nicht geladen. Ich sehe noch das YAVDR Logo mit blinkendem grünen Schalter, und wenn der VDR startet (TV zeigt Eingangssignaländerung) bleibt der TV dunkel, resp. "Kein Signal". Irgendwie hängt das wohl zusammen ?(

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • mein Beileid ... das ist mir auch einmal passiert - neue Software baut das gesamte System um und nix geht mehr ... man war ich geladen ...


    Sit dem erstelle ich vor jedem Basteln am System ein dd Backup der 15 GB Root Partition ;) ( hilft fir jetzt wohl leider nicht mehr ) und bevor ich Software auf mein Produktiv NAS/VDR/Fileserver installiere teste ich Diese ausgiebig in einer VM Spiegelung des Serversystems ( könnte dir vllt noch helfen ).


    Ich habe die Vorgängerkarte der TBS 6982 Treiber is im Kernel implementiert lediglich die Firmware muss nach /var/firmware kopiert werden.


    Nach meinem Umzug habe ich allerdings kein ZDFinfo HD und 3sat HD mehr, dafür laufen jetzt NDR HD und WDR HD sauber, an allen anderen Geräten laufen die Sender super, in der alten Wohnung auch. Interferenzen durch WLan Telefone, lange Kabel etc kann ich ausschließen, da der vdr auf den dem Dachboden 2m vom Multiswitch steht. Kann die Verschiebung der Sendefrequenzen von Sat Anlage zu Sat Anlage variieren ?


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Lenovo T430
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • Kann die Verschiebung der Sendefrequenzen von Sat Anlage zu Sat Anlage variieren ?


    Nein, die Sendefrequenzen sind immer gleich, da diese ja unabhängig von Deiner Empfangsanlage im Satellit erzeugt werden. :D
    Was unterschiedlich sein kann, sind die umgesetzten Satsignale durch den LNB, denn der ist ja bei jeder Satanlage ein anderer. :]


    Im LNB werden ja die eigentlichen Sendefrequenz des Satelliten von 11 ... 12 GHz auf eine tiefere Frequenz von 0,950 ... 2,0 GHz umgesetzt.
    Diese Umsetzung über eine Zwischenfrequenz kann nun schon in gewissen Grenzen differieren. Dies wird allerdings im Normalfall durch eine Regelschleife wieder nachgesteuert.
    Ein Fehler hier würde dann allerdings nicht nur ein paar Sender betreffen, sondern das gesamte Low- oder High-Band des LNB.


    Paulaner

  • Dann frage ich mich grad woran das liegen könnte, denn es sind nur die 2 Sender alles Andere läuft super. "Meine" Sendefrequenz bezog sich auf das Eingangssignal am DVB Tuner - das der Sat Transponder variable Sendefrequenzen hat wäre mir auch neu :)


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 18 (deb.multimedia Quellen) on | Lenovo T430
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • Tja, genau so gehts mir auch.


    Aber an der TT-Front gibts neues:

    Quote

    Hallo,
    so, der Treiber für die S2-4200 ist jetzt verfügbar.
    Hier ist der Link zum derzeit benötigten Patch: https://patchwork.linuxtv.org/patch/33419/
    Später wird alles im Kernel (4.6 bzw. 4.7) verfügbar sein.


    Darauf meine Frage:

    Quote

    Hallo,
    danke für die Info.
    Leider bin ich dann in Linux doch nicht ganz soooo bewandt um das in Ihrem Link umsetzen zu können. Könnten Sie mir hierzu vllt etwas mehr Info/Anleitun zukommen lassen?
    Danke und Gruss,


    Bekam ich folgende Antwort:

    Quote

    Sorry,
    das können wir leider selbst nicht, aber die Hilfe macht die Linux Community ……
    Grüße,


    Da fällt mir jetzt echt nix mehr zu ein............................

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • speefak :
    Das schon probiert?

    Software: yaVDR0.6.1 mit VDR 2.2.0-13yavdr0~trusty, Kernel 4.4.0-187-generic, nvidia 384.130, dddvb 0.9.37.1easyVDR0
    Hardware: ASRock B75 Pro3-M, Intel G2030, RAM 4GB, SSD 64GB, HDD 4TB, Zotac GT630 ZONE Edition 1024MB GK208 (SKU:ZT-60408-20L), DD Cine C2/T2 V7
    Fernseher: SONY KDL-32D3000


  • Könnte mir eventuell jemand erklären, wie ich/oder was ich mit dem Link für den neuesten Treiber anfangen soll?
    https://patchwork.linuxtv.org/patch/33419/
    Mit der Seite komm ich überhaupt nicht klar, geschweige denn habe ich noch nicht einmal ne ungefähre Ahnung wie ich das installieren soll :rolleyes::rolleyes::(:(


    gruss,

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Da ist nur der Patch verlinkt der ins Media Build integriert werden müsste, heisst media build patchen und bauen, wird aber etwas Zeit in Anspruch nehmen:

    Code
    1. sudo apt-get install build-essential libdigest-sha-perl patchutils libproc-processtable-perl git-core linux-headers-$(uname -r) linux-firmware-nonfree
    2. cd /tmp/
    3. git clone --depth=1 git://linuxtv.org/media_build.git
    4. cd media_build
    5. wget https://patchwork.linuxtv.org/patch/33419/raw/ -O backports/s2_4200.patch
    6. sed -i '27aadd s2_4200.patch' backports/backports.txt
    7. sudo wget http://palosaari.fi/linux/v4l-dvb/firmware/M88RS6000/4.1/dvb-demod-m88rs6000.fw -O /lib/firmware/dvb-demod-m88rs6000.fw
    8. ./build
    9. sudo make install


    Viel Spaß :D

    VDR
  • Danke für die Erklärung, hab das ganze durchlaufen lassen, wieder ohne Fehler, aber alles unverändert.
    Kein Bild auffem TV, also auch kein Menü oder sonstiges, kann auch nicht über remote rechner aufs WFE zugreifen
    Hatte das Ganze wieder mit Kernel 3.2.0.80 gemacht. Reboot gemacht und nicht aufgepasst, Kernel 3.2.0.99 wurde gestartet, Bild (Menü) wieder auffem TV, Zugriff übers WFE mit remote Rechner wieder möglich.
    Der Technotrend Geschichte zerschiesst mir offensichtlich jedesmal das komplette System. :(:(

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

    The post was edited 1 time, last by pierre2000 ().

  • Sodele, wieder ein ganzes Stück weiter, um nicht zu sagen: GELÖST
    Zuerst meine tiefste Verbeugung vor 3PO, er hatte von Anfang an Recht :rolleyes::rolleyes:
    Erklärung:
    Letzten Sonntag fielen noch mehr Sender auffem YAVDR aus, damit war für mich klar: jetzt ist die Karte endgültig hinüber.
    Die Wende kam gestern Abend, als plötzlich andere Sat-Receiver ebenfalls massivste Emfangsprobleme hatten. Damit war dann klar, am YAVDR, resp. mit der Digital Services kanns nichts zu tun haben.
    Tatsächlich wurde die erst letztes Jahr neu eingestellte und justierte Sat-Schüssel erneut justiert, und siehe da, ALLES geht, auch ZDF!!!! Die extremen Böen bei uns die letzten Tage haben es ans Licht gebracht, es war nur ne verstellte Sat-Schüssel. Als Fazit bleibt eigentlich nur eines, ausgerechnet die teuerste Satempfangsanlage, nämlich die DD-Cine ist gleichzeitig die empfindlichste, wo die ganzen "billigeren" und Baumarkt Receiver keine Probleme machten, war die bereits am "spinnen"

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Als Fazit bleibt eigentlich nur eines, ausgerechnet die teuerste Satempfangsanlage, nämlich die DD-Cine ist gleichzeitig die empfindlichste, wo die ganzen "billigeren" und Baumarkt Receiver keine Probleme machten, war die bereits am "spinnen"


    Komischer Vergleich: n Ferrari tut sich auch schwer wenn du mit dem ins Gelände fährst, ist halt dafür gebaut perfekt auf normalen Straßen zu funktionieren und dort höchstleistung zu bringen...


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5

  • [...] Als Fazit bleibt eigentlich nur eines, ausgerechnet die teuerste Satempfangsanlage, nämlich die DD-Cine ist gleichzeitig die empfindlichste, wo die ganzen "billigeren" und Baumarkt Receiver keine Probleme machten, war die bereits am "spinnen"


    Grundsätzlich ist leider so, dass ALLE(!) DVB Devices für PCs, egal ob Karte oder USB, keine "Empfangswunder" sind.

  • Ich habe wegen baulicher Gründe keinen guten Sat-Empfang und habe in den letzten Jahren auf der Suche nach 1-2% mehr Signalqualität viel ausprobiert (diverse Sat-Schüsseln, LNBs, Switches, Receiver, Sat Karten). Ich bin immer auf der Suche nach etwas besserem das mir doch noch den störungsfreien Empfang eines Transponders erlaubt. Insofern war die Werbung eines empfindlichen Eingangs wie bei der 952 für mich Grund genug, diese unter yaVDR 0.5 auszuprobieren. In Kombination mit einem guten Inverto Black Ultra LNB erreiche ich hier damit die besten Ergebnisse, auch wenn es für für ein paar Transponder immer noch nicht so ganz reicht. Ja, viele Sat-Karten hier waren wirlich deutlich schlechter als die meisten guten Receiver... die 952 aber nicht. Auch der LNB ist nach meiner Erfahrung eine sehr günstige Möglichkeit viel an Qualität zu gewinnen. Bei vielen LNBs wird bei mir im Low-Band alles dunkel.


    Irgendeinen Tip, was noch besser ist? Wenn es mich nicht in den Ruin treibt, probiere ich es gerne aus. Immer noch besser als auf Kabel mit Abzockgebühr zu wechseln. Wirklich halbwegs brauchbare Vergleichsdaten findet man ja leider nur selten.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE


  • Komischer Vergleich: n Ferrari tut sich auch schwer wenn du mit dem ins Gelände fährst, ist halt dafür gebaut perfekt auf normalen Straßen zu funktionieren und dort höchstleistung zu bringen...


    Christian

    Naja, ist aber trotzdem verwunderdlich das ein 08/15 China Tuner in einem Billig Reciever besser funkioniert als ein Tuner auf einer "relativ" teuren DVB Karte...
    Mir ist klar das hier einiges an Entwicklung drinsteckt für die Anbindung PC Bussysteme (PCIe o.ä.) und an der Entwicklung der zugehörigen Treiber, aber warum muss man dann unbedingt am Tuner sparen?


    Das Ding ist doch geschrimt und was weiß ich alles, kann doch auch kein EMV Problem sein...

  • Quote

    Naja, ist aber trotzdem verwunderdlich das ein 08/15 China Tuner in einem Billig Reciever besser funkioniert als ein Tuner auf einer "relativ" teuren DVB Karte...
    Mir ist klar das hier einiges an Entwicklung drinsteckt für die Anbindung PC Bussysteme (PCIe o.ä.) und an der Entwicklung der zugehörigen Treiber, aber warum muss man dann unbedingt am Tuner sparen?


    100% Zustimmung! Um den Ferrarivergleich weiterzuspinnen: Der kann ja nicht mal schnell geradeausfahren :wand :wand, von "offroad" ganz zu schweigen :rolleyes::rolleyes:

    Quote

    Grundsätzlich ist leider so, dass ALLE(!) DVB Devices für PCs, egal ob Karte oder USB, keine "Empfangswunder" sind.


    Klasse! Teurer geht kaum, und keine Leistung fürs Geld X(X(X( Aber DANKE für die Info, werd ich mir merken. Heisst ja im Umkehrschluss leider nix anderes wie:
    Wenn alle anderen Receiver noch gehen, kanns trotzdem sein, das die Sat-Anlage nen Schuss/verstellt/odersonstwas hat, und die PC-Karten auf KEINEN Fall als Referenz herhalten sollten egal wie teuer :§$%:§$%
    Danke und LG,

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.6.2
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Wenn alle anderen Receiver noch gehen, kanns trotzdem sein, das die Sat-Anlage nen Schuss/verstellt/odersonstwas hat, und die PC-Karten auf KEINEN Fall als Referenz herhalten sollten egal wie teuer

    Das ist halt das Frühwarnsystem für Empfangsstörungen ;)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ein PC ist halt nicht designt, um nativ DVB zu empfangen, ein 08/15 Baumarkt Receiver aus China dagegen schon.


    Wenn Du eine "Referenz" willst, dann must Du Dir einen Messempfänger zulegen.


    Ich selber, habe DIESEN. Es gib das sicherlich noch bessere (und teurere), aber für mich ist der völlig ausreichend und mir alles an, was ich wissen will. ;)