VDR 2.2 runvdr.pid start script

  • Hallo,


    ich habe meinen Rechner neu Installiert Linux Mint 17.3, und jetzt habe ich das Problem das VDR 2.2 startet wenn ich
    /etc/default/vdr
    # Change to 1 to enable vdr's init-script
    ENABLED=1
    enable


    wenn ich dann aber
    sudo /etc/init.d/vdr status <<< eingebe dann
    sagt der befehl das vdr nicht gestartet ist


    ==================================
    Jetzt wenn ich in der /etc/default/vdr >>> ENABLED=0 setze
    neu starte --> startet VDR nicht (erstmal gut :-)
    dann muss ich es wieder ENABLED=1 setzen
    und dann sudo /etc/init.d/vdr start eingebe --> passt alles ich habe eine runvdr.pid
    ich kann den status abrufen!
    Jedesmal in der default auf 0 stellen neustarten und dann auf 1


    Wo ist das Problem? wie bekomme ich das in den Griff....
    Hat jemand eine Idee?

  • Wo ist das Problem?

    Sicher, dass der VDR nicht durch systemd gestartet wird?

    Code
    1. systemctl status vdr

    oder durch Upstart:

    Code
    1. status vdr

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Wo hast du den VDR denn her?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Dann wird der VDR durch Upstart gestartet - also über /etc/init/vdr.conf

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • mit was für einem Befehl starte ich mein VDR neu?


    Code
    1. restart vdr


    wenn ich keine .pid habe dann kann ich nicht mit sudo /etc/init.d/vdr restart status und start stop arbeiten


    Auch mit .pid kannst du das nicht tun, weil unser VDR, wie ja schon gesagt, per upstart gestartet wird.


    Code
    1. root@microserver:~# status vdr
    2. vdr start/running, process 1759


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470