Dualhead Konfiguration

  • Nachdem mein System nun auch per "Bildschirm erkennen" funktioniert (neues VBIOS, siehe Link), wollte ich mich mal wieder an die lange gewünschte Dualhead Konfiguration machen.


    Die Erkennung funktioniert wie gesagt mit diesem Board, allerdings nur, wenn ich lediglich einen Ausgang der GT620 belege. Entweder erkennt das System:

    • meinen TV (Bild1)
    • meinen Beamer (Bild2)
    • ...aber nicht beide Geräte, wenn ich diese auch beide angeschlossen habe (Bild3)

    Gibt es da eine Lösung?

  • Und an VGA-Port ist sicher nichts angeschlossen? Ist das neu oder war das schon vor dem Flashen des VBIOS so?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Am besten die xorg.conf.yavdr von allen drei Zuständen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Um zu sehen, was der X-Server da nativ erkennt, würde ich folgendes machen:

    Code
    1. sudo -i
    2. stop vdr
    3. stop xorg-launcher
    4. process-template /etc/X11/xorg.conf.rescan
    5. export XORGCONFIG=/etc/X11/xorg.conf.rescan
    6. /usr/bin/x-daemon -nolisten tcp -noreset :1 vt9
    7. # mit STRG-C abbrechen

    Und dann mal die /var/lib/Xorg.*.log Dateien posten, da sollte dann hoffentlich drin stehen, was der Treiber so an angeschlossenen Bildschirmen erkennt. Leider hab ich im Handbuch zu dem Zotac nichts eindeutiges gesehen, was die onboard-nVidia-Karte gleichzeitig als Ausgabe nutzen kann, Frodo scheint mit der Bildschirmerkennung aber auch schon mit yaVDR 0.5 Probleme gehabt zu haben: Erfahrungsbericht Zotac H77-ITX WiFi C Series (H77ITX-C-E), Mini-ITX, GT620 onboard
    Danach wieder aufräumen:

    Code
    1. rm /etc/X11/xorg.conf.rescan
    2. start vdr
    3. start xorg-launcher

    Um zu sehen, ob es prinzipiell funktioniert, würde ich es mal mit einer von Hand angepassten xorg.conf.yavdr versuchen:
    Die /etc/X11/edid.1.yavdr sichern, wenn nur der Beamer angeschlossen und im WFE erkannt wurde und dann die /etc/X11/edid.0.yavdr mit angeschlossenem TV sichern, dann beide anschließen, auf Dual-Head schalten und die xorg.conf.yavdr (xorg.conf.yavdr.txt) und die beiden EDID-Dateien wieder zurück kopieren und den xorg-launcher stoppen und wieder starten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe erst die logs nach Anweisung erstellt, anschliessend:

    • den TV angeschlossen und die edid.0.yavdr abgespeichert
    • den Beamer angeschlossen, und die neue edid.0.yavdr abgespeichert und in edid.1.yavdr umbenannt
    • dann Deine sorg.conf.yavdr nach /etc/X11 kopiert
    • stop vdr
    • stop xorg-launcher
    • start vdr
    • start xorg-launcher

    Anzeige ist dann auf dem Beamer, obwohl die Anzeigeneinstellungen im WebGUI den TV anzeigen.


    Der TV ist an Ausgang 10 angeschlossen, weil da der HDMI Ton mitkommt (DVI-Port NVIDIA GT620), der Beamer ist am Ausgang 11 angeschlossen (Display Port NVIDIA GT620).


    Der u.g. Link ist übrigens nicht auf dem neuesten Stand. Die, die das Board im Einsatz haben (Frodo, Polaris und ich) haben mit einem neuen BIOS geflasht und dadurch ist es überhaupt erst möglich geworden, die angeschlossenen Geräte per "Erneut nach vorhandenen Bildschirmen suchen" identifizieren zu lassen. Das ging vorher überhaupt nicht. Näheres hier. Daher kam ich auf die Idee, die Dualhead Sache mal wieder zu versuchen.

  • Anzeige ist dann auf dem Beamer, obwohl die Anzeigeneinstellungen im WebGUI den TV anzeigen.

    Das WFE spielt in dem Fall ja keine Rolle, was zählt ist, was in der xorg.conf.yavdr steht - hast du jetzt auf beiden Bildschirmen einen X-Server und kannst übers OSD umschalten?
    Dann musst du nur in den beiden Screen-Sections jeweils die 0 und 1 vertauschen, um die Reihenfolge der Bildschirme zu ändern:

    Code
    1. Section "Screen"
    2. Identifier "Screen0"
    3. Device "Device0"
    4. Monitor "Monitor0"

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja das verstehe ich, aber nach der Xorg Server WebGUI Info müsste der TV anzeigen: Pastebin
    Das wäre ja erst einmal egal, aber die Umschaltung auf den zweiten Monitor klappt nicht. Xorg.log habe ich noch einmal attached. Ich denke, dass der Fehler hier ist:

    Quote

    6.880] (EE) NVIDIA(1): Failed to assign any connected display devices to X screen 1.

  • Seahawk, mach' Dir keine weitere Mühe mit diesem blöden Board. Ich habe es nach diesem alten Thread gelöst.


    Im Script "restart openbox" durch "restart xorg-launcher" ersetzt und gut war's.


    Dann noch die folgende Änderung zur alten Anleitung:

    Code
    1. nano /usr/share/yavdr/templates/var/lib/vdr/plugins/menuorg.xml/86_dswitch

    mit dem folgenden Inhalt:

    Code
    1. <command name="Anzeige umschalten: Beamer/TV" execute="sudo /home/dswitch/dswitch.sh &amp;> /dev/null " />

    . Dann noch

    Code
    1. process-template /var/lib/vdr/plugins/menuorg.xml
  • Hi EdgarWallace,


    Und das funktioniert zuverlässig bei dir ?


    Hab das eben auch hier eingebaut (klar ein bisschen in abgewandelter Form) aber sollte im Prinzip genauso tun.
    Hab halt etwas andere Pfade und auch Bezeichnungen der Files genommen und den Befehl selbst gleich im VDR System Menü eingebaut
    aber funktioniert hat das hier in nem yavdr-0.6 genau einmal obwohl bei jedem switch die passende xorg.conf.pcmonitor
    oder xorg.conf.lgtv (so nenn ich die hier) als xorg.conf.yavdr nach /etc/X11 kopiert wird.


    In der Theorie müsste das also eigentlich soweit klappen aber wie gesagt klappte nur genau einmal
    danach hatte ich nach dem switchen immer auf beiden Ausgabegeräten keinerlei Bild mehr.
    Wobei ich hier direkt per DVI an nem PC Monitor oder per HDMI auf nem LG TV ausgeben möchte.


    Quote

    Im Script "restart openbox" durch "restart xors-launcher" ersetzt und gut war's.

    Kleiner Vertipper - meinst wohl xorg-launcher


    EDIT !
    Ja man könnte sagen es funktioniert, aber nur mit nem Reboot und das is nix.
    Nur komisch das es ein einziges Mal ohne nem Reboot geklappt hat hier.


    Das was das Yavdr Team da eingebaut hat also "Temporär auf den anderen Monitor umschalten" klappt da hier
    um einiges besser (bislang zuverlässig) nur bräuchte ich etwas was auch die Ausgabe zum Ton umswitcht
    da ich am PC den Ton über die PC Lautsprecher will und am TV natürlich den Ton über nvidia hdmi
    (muss das derzeit immer zusätzlich manuell übers WebIf ändern) is unkomfortabel.
    Würde der Ton hier gleichzeitig umgeswitcht wenn ich temporär auf den anderen Monitor schalte wär ich schon zufrieden.



    Gruss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

    The post was edited 1 time, last by Bert ().

  • Hallo Bert,


    ja das ist das erste Mal, dass diese Umschaltung bei mir funktioniert. Wenn Du die alten Links, die ich erwähnet anschaust, dann wirst Du sehen dass es bei meinem Mainboard auch erst funktioniert, seinem das BIOS der integrierten NVIDIA GT620 aufgerüstet ist. Die Variante "Temporär auf den anderen Monitor umschalten" hat bei mir wiederum leider nicht geklappt, was natürlich der bessere Weg gewesen wäre aber es hat nicht sollen sein.


    Du scheinst damit ja prima zurecht zu kommen. Bliebe also der Ton: Warum gibst Du den Ton denn nicht parallel auf allen Kanälen aus? Das habe ich mit einer angepassten asound.conf gelöst: KLICK


    Ansonsten vielleicht eine andere Grafikkarte testen? Viel Erfolg


    P.S. Type werde ich korrigieren

  • Hi,


    Quote

    Warum gibst Du den Ton denn nicht parallel auf allen Kanälen aus?

    Na ja ich hab von dem ganzen Sound Gedöns wenig Ahnung, und im WebIf geht hier nix.
    Ich kann auch nicht wie vielerorts beschrieben im WebIf die Tonausgabe auf alle Geräte setzen (gibts hier scheinbar nicht im yavdr-0.6).


    MIt der asound.conf befass ich mich grade, hab aber keinen Plan wie man da zwei devices also Intel Analog und nvidia hdmi korrekt einträgt
    damit beides parallel klappt.


    pulseaudio verwend ich nicht, ich verwende alsa.


    aplay -l zeigt;



    aplay -L zeigt;


    Meine asound.conf hab ich auf das geändert;


    So einfach hätt ichs gern gehabt aber is leider nicht :D



    Gruss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Du solltest erst einmal checken, auf welchem HDMI Dein Signal rauskommen soll. Meine Ausgaben erfolgen über hw:0,1 sowie hw:1,3


    Korrekt, in yaVDR 0.6 wurde die parallele Ausgabe per alsa aus dem Webinterface herausgenommen. Dü könntest aber doch auch Pulsaudio versuchen. Na ja, meine Konfiguration sieht so aus (auch nicht vergessen, die Kanäle zu "entmuten"):


    aplay -l


    aplay -L


    asound.conf:

  • Hi,


    Ja also mit Pulseaudio hab ich jetzt mal nen Teilerfolg hab mittels;


    Code
    1. svdrpsend plug pulsecontrol list-cards


    mal ein bischen was ausgelesen, sieht so aus;


    Anhand dieser Daten hab ich dann folgendes am Ende in die /etc/pulse/system.pa eingetragen;


    Code
    1. set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo
    2. set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo-extra1
    3. load-module module-combine-sink
    4. set-default-sink combined


    Wenn man dann noch etwas mit den Einstellungen im Vdr Menü bei Applikationen > Tools -> Pulsecontrol herumspielt
    klappt die simultane Ausgabe beider devices, aber kaum startet man das System neu is gar kein Ton mehr da
    und erst wenn man übers WebIf das pulseaudio neu abspeichert gibts wieder Ton.


    Ich hatte auch ein Startup Script in /var/lib/vdr/plugins/pulsecontrol mit Namen startup.script angelegt mit folgendem Inhalt;

    Code
    1. set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo-extra1


    Aber ob das da ist oder nicht spielt anscheinend keine Rolle - habs also wieder gelöscht.



    EDIT !
    Grade nen Neustart des Systems gemacht - Ton wieder komplett weg
    Sieht man im Vdr Menü dann unter Applikationen > Tools -> Pulsecontrol -> verschiebe Wiedergabe is das leer da steht kein Menüeintrag drinnen dann.
    Speicher ich dann im WebIf erneut pulseaudio ab für die Tonausgabe hab ich sofort wieder Ton auf beiden Devices.
    Nun hat man auch wieder im Vdr Menü dann unter Applikationen > Tools -> Pulsecontrol -> verschiebe Wiedergabe wieder Menüeinträge.
    Is nicht leicht zu kapieren - fehlt da noch was oder was is hier los ?
    Für Heute geb ich erstmal auf das frisst alles viel Zeit.


    EDIT 2 !
    Eines hab ich grade noch probiert - hab im WebIf mal die Ausgabe von softhddevice zu xine geändert
    und danach das System neugestartet dabei kam dann plötzlich der Ton nach dem Hochfahren von ganz allein auf beiden devices.
    Hab ich aber nur einmal getestet (war vielleicht auch nur Glück).
    Wieder zurück gestellt auf softhddevice und wie gehabt kein Ton nach Neustart des Systems.


    Hat schon ein gewisses Eigenleben so ein Vdr :D



    Gruss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

    The post was edited 3 times, last by Bert ().

  • Auch bei mir hat Pulsaudio den Reboot nicht überlebt, daher der Wechsel zurück nach Alsa link
    Was sagt das Log eigentlich? Beim Softhddevice sind auch alle Audiobereiche auf Passthrough gestellt?
    Warum probierst Du nicht mal meine asound.conf und fügst die Adressen Deines Systems ein?

  • Hi EdgarWallace,


    Ja hab gestern schon ne ähnliche asound.conf auch probier aber nix erreicht, werd aber mal deine testen.
    MIr wärs ja eigentlich egal ob alsa oder pulseaudio wenn denn nur mal eins davon funktioniert.


    Das Pulseaudio scheint eh etwas zickig zu sein, haben ja andere User auch Probleme mit kein Ton nach nem Reboot;
    [ANNOUNCE] pulsecontrol 0.1.9 - Pulseaudio aus dem OSD heraus steuern


    Na mal sehen,



    Gruss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Hi EdgarWallace,


    Danke schön :]
    Mit deiner asound.conf klappts nun nach anpassen der devices.
    Ob das nun so für mich absolut passt weiss ich nicht da ich die ganzen Options wie bindings usw.. nicht verstehe
    (da werd ich mich wohl mal einlesen müssen)
    aber es klappt und ich hab nun parallel Ton über die Soundcard als auch über nvidia hdmi.


    Wegen pulseaudio da hab ich heute noch einiges probiert aber hat nix zum Erfolg geführt hab da mal mini73 gefragt
    mal sehen vielleicht hat er nen Tipp damit das dann auch klappt nach nem Reboot.
    Zwei Lösungen wären ja besser als eine ;D



    Gruss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau