[0.6.0] VDR startet nach Installation nicht

  • Moin Leute,


    erstmal vielen Dank ans Team für 0.6!


    In dem Announce-Thread steht ja "beim ersten Start nach der Installation läuft das Upstart-Skript first-vdr-start - bitte den Rechner nicht neu starten, solange das aktiv ist (wenn es fertig ist löscht es sich selbst aus /etc/init/first-vdr-start.conf) - danach sollte der VDR gestartet und das Frontend angezeigt werden.".


    Wie lange sollte man denn da warten? Nach einer Stunde ist die Datei immer noch vorhanden und der VDR nicht gestartet. Das kommt mir doch etwas lang vor! ;-)


    Mir scheint, dass es Probleme beim Starten des X-Servers gibt.






    Hat jemand eine Idee, wo ich ansetzen könnte?

    [Spoiler=Meine VDRs]VDR1: Pentium G2120 *** Intel DH77EB *** Zotac GT 630 ZONE Edition *** 120GB SSD (System) *** 4TB (Medien) *** yaVDR 0.5 *** Quattro (DF)Atmolight *** ANTEC Fusion Remote
    VDR2: Asus AT3IONT-I Deluxe *** intern 120GB SSD (System) *** extern 2TB (Medien) *** yaVDR 0.5 *** Lian Li PC-Q07
    VDR3 (in Rente): Pentium3 @ 900 MHz *** 512MB RAM *** Airstar 2 DVB-T *** TT S2300 *** Mahlzeit-ISO 4.0b2 *** ANTEC Fusion

  • Dann probier mal das Event von Hand auszulösen:

    Code
    1. /usr/bin/signal-event first-vdr-start

    dann noch einen Neustart, wenn er durch ist (am Schluss löscht er die /etc/init/first-vdr-start.conf).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Beim manuellen Ausführen kommt folgendes:


    Die Datei ist aber nach wie vor vorhanden.


    Ich vermute jetzt aber mitlerweile, dass meine Grafikkarte (GT 630) nicht richtig erkannt wird:

    Code
    1. dmesg | grep nvidia
    2. [ 3.502557] nvidia: module license 'NVIDIA' taints kernel.
    3. [ 3.506276] nvidia: module verification failed: signature and/or required key missing - tainting kernel
    4. [ 3.520013] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
    5. [ 3.521143] nvidia 0000:01:00.0: irq 45 for MSI/MSI-X
    6. [ 8.731168] nvidia 0000:01:00.0: irq 47 for MSI/MSI-X

    [Spoiler=Meine VDRs]VDR1: Pentium G2120 *** Intel DH77EB *** Zotac GT 630 ZONE Edition *** 120GB SSD (System) *** 4TB (Medien) *** yaVDR 0.5 *** Quattro (DF)Atmolight *** ANTEC Fusion Remote
    VDR2: Asus AT3IONT-I Deluxe *** intern 120GB SSD (System) *** extern 2TB (Medien) *** yaVDR 0.5 *** Lian Li PC-Q07
    VDR3 (in Rente): Pentium3 @ 900 MHz *** 512MB RAM *** Airstar 2 DVB-T *** TT S2300 *** Mahlzeit-ISO 4.0b2 *** ANTEC Fusion

  • Ok, das heißt, dass er bis https://github.com/yavdr/yavdr…ctions/start-sound-device gekommen ist (das ist die letzte Action für das Event). Dann lösch mal /etc/init/first-vdr-start.conf/ und schau, was nach einem Reboot passiert.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Der VDR startet dann und sogar das iMON Display zeigt den Sender an, aber auf dem Fernseher erscheint nur die Login Geschichte auf tty1.


    Hier das syslog.


    Da gibt es einen ganzen Sack voll dieser Meldungen:

    Code
    1. Jan 6 09:09:02 yavdr06 nvidia-persistenced: Started (1355)

    [Spoiler=Meine VDRs]VDR1: Pentium G2120 *** Intel DH77EB *** Zotac GT 630 ZONE Edition *** 120GB SSD (System) *** 4TB (Medien) *** yaVDR 0.5 *** Quattro (DF)Atmolight *** ANTEC Fusion Remote
    VDR2: Asus AT3IONT-I Deluxe *** intern 120GB SSD (System) *** extern 2TB (Medien) *** yaVDR 0.5 *** Lian Li PC-Q07
    VDR3 (in Rente): Pentium3 @ 900 MHz *** 512MB RAM *** Airstar 2 DVB-T *** TT S2300 *** Mahlzeit-ISO 4.0b2 *** ANTEC Fusion

  • Gibt es eine /run/nvidia-persistenced/nvidia-persistenced.pid ? Falls ja, lösch die mal.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die gibt es leider nicht:

    Code
    1. find / -name "*nvidia*pers*"
    2. /etc/alternatives/x86_64-linux-gnu_nvidia_persistenced
    3. /usr/lib/nvidia-352/bin/nvidia-persistenced
    4. /usr/bin/nvidia-persistenced
    5. /usr/bin/stop-nvidia-persistenced
    6. /usr/bin/start-nvidia-persistenced
    7. /usr/share/man/man1/nvidia-persistenced.1.gz
    8. /usr/share/man/man1/alt-nvidia-352-persistenced.1.gz
    9. /usr/share/doc/nvidia-352/html/nvidia-persistenced.html

    [Spoiler=Meine VDRs]VDR1: Pentium G2120 *** Intel DH77EB *** Zotac GT 630 ZONE Edition *** 120GB SSD (System) *** 4TB (Medien) *** yaVDR 0.5 *** Quattro (DF)Atmolight *** ANTEC Fusion Remote
    VDR2: Asus AT3IONT-I Deluxe *** intern 120GB SSD (System) *** extern 2TB (Medien) *** yaVDR 0.5 *** Lian Li PC-Q07
    VDR3 (in Rente): Pentium3 @ 900 MHz *** 512MB RAM *** Airstar 2 DVB-T *** TT S2300 *** Mahlzeit-ISO 4.0b2 *** ANTEC Fusion

  • Hallo zusammen,


    ich habe mich auch am yavdr-0.6.0 und es hat leider nicht funktioniert. Ich bekam kein Bild und wie Zoidson diese Meldungen.


    Da gibt es einen ganzen Sack voll dieser Meldungen:

    Code
    1. Jan 6 09:09:02 yavdr06 nvidia-persistenced: Started (1355)


    Da es sich um unseren einzigen Produktiv-VDR (siehe Signatur) handelt, konnte ich leider nicht weiter rumprobieren, woran es lag. Die Grafikkarte ist die
    built-in Geforce 8200. Ist die Hardware vielleicht zu alt ??


    LG


    Joachim

    Mein VDR: Digitainer II Gehäuse, Asus M85M-US2H, AMD Sempron 140, 2 GB RAM, 1 TB WD Festplatte, Satelco Easywatch / Terratec Cinergy DVB-C, IR- Fernbedienung mit Atric-Einschalter, yavdr-0.5.0a

  • Ich bin nicht sicher, ob das bei dir die gleiche Ursache hat - bei der Geforce 8200 gab es einen Vorschlag für einen Workaround: 0.6.0: VDR stürzt kurz nach dem Start ab


    Also älterer nVidia-Treiber aus der 304er Serie und eventuell (scheint nicht immer nötig zu sein) ein neuerer Kernel wie die Version 3.19 oder 4.2

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986
    Vielen Dank für den Link. Dann werde ich mal schauen, ob ich den VDR heute nochmal haben darf ...

    Mein VDR: Digitainer II Gehäuse, Asus M85M-US2H, AMD Sempron 140, 2 GB RAM, 1 TB WD Festplatte, Satelco Easywatch / Terratec Cinergy DVB-C, IR- Fernbedienung mit Atric-Einschalter, yavdr-0.5.0a

  • Nachdem ich perusmuro's Tipp aus diesem Thread ausprobiert habe, hatte ich auch Bild. Allerdings mit starker Klötzchenbildung auf HD Kanälen und ohne Ton.


    Leider half auch der Tipp aus diesem Thread mit dem Anlegen der Datei /var/lib/vdr/plugins/pulsecontrol/startup.script mit dem Inhalt set-card-profile 0 output:hdmi-stereo nicht.


    Irgendwie scheint da Pulseaudio nicht richtig zu laufen - auch im WFE taucht nichts von Pulseaudio auf. Das Menu dort sieht bei mir genauso aus wie bei 0.5. Ich vermute da ist noch was mit dem Treiber der Grafikkarte im argen. Leider kann ich im Moment auch nicht weiter testen, da morgen meine Frau aus ihrem Kurzurlaub zurück kommt und der VDR dann laufen muss! ;D


    Vielen Dank auf jeden Fall für die Hilfe!

    [Spoiler=Meine VDRs]VDR1: Pentium G2120 *** Intel DH77EB *** Zotac GT 630 ZONE Edition *** 120GB SSD (System) *** 4TB (Medien) *** yaVDR 0.5 *** Quattro (DF)Atmolight *** ANTEC Fusion Remote
    VDR2: Asus AT3IONT-I Deluxe *** intern 120GB SSD (System) *** extern 2TB (Medien) *** yaVDR 0.5 *** Lian Li PC-Q07
    VDR3 (in Rente): Pentium3 @ 900 MHz *** 512MB RAM *** Airstar 2 DVB-T *** TT S2300 *** Mahlzeit-ISO 4.0b2 *** ANTEC Fusion

  • Nur zur Info:


    Ich weis nicht, inwieweit die Probleme mit 8200 auch auf 8300 zutreffen, aber auch ich hatte Probleme mit einem Asus M4N78 Pro MB. Zuerst schien der 304 die Lösung zu sein, doch ein glücklicher Umstand brachte mich auf eine andere Spur und bei mir scheint der 340 zu laufen, wenn ich in grub pci=nomsi benutze. Dies war bei bei älteren Kerneln die ich benutzt hatte nie nötig, doch bei 0.6 mit 3.13 kernel scheint es notwendig zu sein.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • @backalive
    Vielen Dank! Mit pci=nomsi klappt die Installation jetzt auch auf meinem altem System mit built-in nvidia 8200 mit Standard Kernel und nvidia-Treiber 340. Das yavdr-0.6.1 Image hatte dagegen leider nicht geholfen.


    Lg


    Joachim

    Mein VDR: Digitainer II Gehäuse, Asus M85M-US2H, AMD Sempron 140, 2 GB RAM, 1 TB WD Festplatte, Satelco Easywatch / Terratec Cinergy DVB-C, IR- Fernbedienung mit Atric-Einschalter, yavdr-0.5.0a