[0.6.0] Anleitung Installation auf NUC5

  • Hi.


    I hope to buy a NUC6 in a few weeks, so I installed yaVdr 0.6 in a virtual machine in order to reproduce the Eisbaer128 instructions.


    Those are the step I did. I hope someone can correct me if I did some mistake.


    First of all, the most recent version of intel graphics should be installed


    Code
    1. sudo add-apt-repository ppa:oibaf/graphics-drivers
    2. sudo apt-get update && sudo apt-get dist-upgrade
    3. sudo apt-get install xserver-xorg-video-intel


    Next step, source of vdr-plugin-softhddevice should be downloaded.


    Code
    1. sudo apt-get install devscripts # In order to run afterward the 'dch' command
    2. sudo apt-get source vdr-plugin-softhddevice
    3. sudo apt-get build-dep vdr-plugin-softhddevice
    4. sudo apt-get install libva-dev # (only in case the file is not already installed)


    IMPORTANT: DO NOT REMOVE manually vdr-plugin-softhddevice. As it is a part of yaVdr, some other software needed for yaVdr would be also removed


    After download and run build-dep, the folder "vdr-plugin-softhddevice-0.6.1rc1.git20150924.1231" was created (If git of plugin changes I guess the numbers in folder will be different next time)

    Code
    1. cd vdr-plugin-softhddevice-0.6.1rc1.git20150924.1231


    In order to avoid intalling new versions of plugin softhdevice, we should increase the number of versión of our softhdevice:


    Code
    1. sudo dch -i "added vaapi and opengl to compile options"


    In order to edit needed files, I installed nano text editor:


    Code
    1. sudo apt-get install nano


    Makefile should be edited:

    Code
    1. sudo nano Makefile


    And some changes in file should be done. This content will change:

    Code
    1. # support VA-API video output module (deprecated)
    2. #VAAPI ?= $(shell pkg-config --exists libva && echo 1)
    3. # support glx outputAfter that we change to a created folder in order to build the deb package:
    4. #OPENGL ?= $(shell pkg-config --exists gl glu && echo 1)


    for this one:


    Code
    1. # support VA-API video output module (deprecated)
    2. VAAPI ?= $(shell pkg-config --exists libva && echo 1)
    3. # support glx output
    4. OPENGL ?= $(shell pkg-config --exists gl glu && echo 1)


    Instead of editing the Makefile you can run those commands that will do automaticaly the changes for you:

    Code
    1. sudo sed -i s/#VAAPI/VAAPI/ Makefile
    2. sudo sed -i s/#OPENGL/OPENGL/ Makefile



    After that, buildpackage should be run:

    Code
    1. sudo dpkg-buildpackage -b -us -uc -d


    The result of the previous command is (I am sorry, some words are in spanish):




    We change to the previous folder with "cd .." and vdr plugin should be installed (install dependencies if they appeared in the instalation process):


    Code
    1. sudo dpkg -i vdr-plugin-softhddevice_0.6.1rc1.git20150924.1231-0yavdr3~trusty_amd64.deb #Not install the packet with dbg on its name


    nVidia drivers should be removed too:


    Code
    1. sudo apt-get remove --purge nvidia*


    Config file of plugin should be edited:


    Code
    1. sudo nano /etc/vdr/conf.avail/softhddevice.conf


    and the content should be:

    Code
    1. [Softhddevice]
    2. -D
    3. -v va-api
    4. # -v va-api-glx


    xorg.conf.yavdr config file should be also edited:

    Code
    1. sudo nano /etc/X11/xorg.conf.yavdr


    and the content should be (Avoid to use CustomEdid in xorg.conf, because it cause fails in Kodi):


    That is that I understood that is needed to do, in order to make Intel HD work in NUC5. If some corrections are needed, please be free to tell me and I edit the post to fix them.


    Thanks and regards.
    Javier B.

    VDR 1: Intel NUC6i5SYK || SSD 128Gb M.2 2242 ADATA PREMIER || External HD: W.D. Elements 5 Tb || RAM: 4 Gb KINGSTON HYPERX IMPACT − DDR4 || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || easyVdr 3.0
    VDR 2: Xtreamer Ultra || HD 2 Tb || RAM: 4 Gb || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || yaVdr 0.6
    VDR 3: Siemens Gigaset M740 AV + HD Western Digital "My Book Essential-2, 1Tb" (6 partitions ext2) || VDR-NG-EM 0.6 Pro - Rev 844

    The post was edited 20 times, last by jbjbjb ().

  • You understood the instructions very well. Let me answer your questions:
    1. Don't remove the distribuion version of the softhddevice You anyway overwrite with the local debian install and softhddevice is a requirement for yavdr install so in case you remove other yacdr packages will be remved as well. Here a good solution is to change the version of the local install softhddevice-) will add this to the instructions
    2.I initially had a problem with Kodi crashing.Root cause was an custom Edid which seems to create a problem. After removing teh custom Edid everything is working fine.


    Will take some parts of your instructions into my summary, thanx for the inputs.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Hi. Thanks for your answer Eisbaer128 . May be it is because I am not an advanced user of linux, but I do not understand completely your answer:


    Here a good solution is to change the version of the local install softhddevice-) will add this to the instructions


    I do not know what " to change the version of the local install softhddevice-)" is? Do I remove the part of uninstall softhdevice or should I add some more?
    [I edited already this part of the post]


    After removing teh custom Edid everything is working fine.


    I do not know neither what is customEdid nor how to remove it?. Is it removed already in "xorg.conf.yavdr" or should I use some command?.


    Sorry for my inexperience.


    Regards.
    Javier B.

    VDR 1: Intel NUC6i5SYK || SSD 128Gb M.2 2242 ADATA PREMIER || External HD: W.D. Elements 5 Tb || RAM: 4 Gb KINGSTON HYPERX IMPACT − DDR4 || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || easyVdr 3.0
    VDR 2: Xtreamer Ultra || HD 2 Tb || RAM: 4 Gb || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || yaVdr 0.6
    VDR 3: Siemens Gigaset M740 AV + HD Western Digital "My Book Essential-2, 1Tb" (6 partitions ext2) || VDR-NG-EM 0.6 Pro - Rev 844

    The post was edited 1 time, last by jbjbjb ().

  • Just updated the guide with a command to change to version of the debian package. (dch -i "comment .."). The Xorg.conf file I have in my guide doesn't have a custom edid, you don't need to worry. Background: Edid is a set of information the x-server is reading from the connected monitor to get capabilities: resolution, frequencies ... In case this doesn't work you can locally overwrite.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Just updated the guide with a command to change to version of the debian package. (dch -i "comment ..")


    Hi.


    I run dch command but it is not installed in my yaVdr. I am not able to install it either.


    I know the package versión by using:

    Code
    1. dpkg -s vdr-plugin-softhddevice | grep Version
    2. Version: 1:0.6.1rc1.git20150924.1231-0yavdr3~trusty


    Should I run the dch -i "1:0.6.1rc1.git20150924.1231-0yavdr3~trusty" command? But how can I install dch?


    I do not understand how should I update the guide. I am sorry for bothering you again :wand


    Regards.
    Javier B.

    VDR 1: Intel NUC6i5SYK || SSD 128Gb M.2 2242 ADATA PREMIER || External HD: W.D. Elements 5 Tb || RAM: 4 Gb KINGSTON HYPERX IMPACT − DDR4 || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || easyVdr 3.0
    VDR 2: Xtreamer Ultra || HD 2 Tb || RAM: 4 Gb || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || yaVdr 0.6
    VDR 3: Siemens Gigaset M740 AV + HD Western Digital "My Book Essential-2, 1Tb" (6 partitions ext2) || VDR-NG-EM 0.6 Pro - Rev 844

  • Hi again.


    I have seen dch command in your initial post, but I do not know how to run the command, because it is not recognized y my yaVdr. I updated my post with your changes also.


    Regards.
    Javier B.

    VDR 1: Intel NUC6i5SYK || SSD 128Gb M.2 2242 ADATA PREMIER || External HD: W.D. Elements 5 Tb || RAM: 4 Gb KINGSTON HYPERX IMPACT − DDR4 || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || easyVdr 3.0
    VDR 2: Xtreamer Ultra || HD 2 Tb || RAM: 4 Gb || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || yaVdr 0.6
    VDR 3: Siemens Gigaset M740 AV + HD Western Digital "My Book Essential-2, 1Tb" (6 partitions ext2) || VDR-NG-EM 0.6 Pro - Rev 844

  • Whenever you are in doubt which package contains a file use apt-file

    Code
    1. $ sudo apt-get install apt-file
    2. $ sudo apt-file update
    3. $ apt-file search -x "^/usr/bin/dch$"
    4. devscripts: /usr/bin/dch

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Did some further clarifications, should be now really close to a step by step instruction. Hope this helps

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Thanks all of you.


    Everithing understood now. I updated the post in english too.


    Regards.
    Javier B.

    VDR 1: Intel NUC6i5SYK || SSD 128Gb M.2 2242 ADATA PREMIER || External HD: W.D. Elements 5 Tb || RAM: 4 Gb KINGSTON HYPERX IMPACT − DDR4 || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || easyVdr 3.0
    VDR 2: Xtreamer Ultra || HD 2 Tb || RAM: 4 Gb || Remote compatible Microsoft Media Center || 3 tuners pctv nanoStick || yaVdr 0.6
    VDR 3: Siemens Gigaset M740 AV + HD Western Digital "My Book Essential-2, 1Tb" (6 partitions ext2) || VDR-NG-EM 0.6 Pro - Rev 844

  • Hallo Leute,


    ich habe das gleiche Problem wie Husky, dass bei 84% bei der Konfiguration vom nvidia-Treiber auf dem NUC abgebrochen wird. Jetzt wollte ich die von Seahawk vorgeschlagene Methode probieren, allerdings bekomme ich immer die Fehlermeldung, dass auf die .seed-Datei auf Dropbox nicht zugegriffen werden kann.


    Du könntest es mal mit dem Weg über ein Ubuntu-Server ISO und dem preseed von mir probieren, das installiert nvidia-current nicht automatisch mit: yavdr 0.6 preseed - Probleme und Fixes


    Ich wollte nun die Datei manuell ins Verzeichnis auf dem Bootstick kopieren, aber der wird schreibgeschützt eingehängt, egal auf welchem System ich das probiere. Wie kann ich dem Bootstick eine eigene seed-Datei unterschieben?


    Gruß,
    Norman

    VDR1 yaVDR 0.6.1, 2x TT S2-3200 CI, AMD 5050e, ASUS M3N78-EMH HDMI, 2GB RAM, GraKa Asus ENGT220 1GB, Sound per HDMI, 1TB HDD, Blu-ray Disc & HD DVD-ROM Drive LG GGC-H20N, GraphTFT auf 7" HDMI-LCD (China-Variante), Atric-IR, FB Logitech Harmony 600, Yamaha RX-V673, Philips 7606
    VDR2 yaVDR 0.6.1, DVB-s Rev 2.1, Athlon 3000+; 1GB RAM; 1TB HDD; GraKa GF 6600, per DVI an TFT
    VDR3 yaVDR 0.6.1, Intel NUC DN2820FYKH, Harmony 350, DVBSky S960

  • Leg das preseed halt einfach auf einem Webserver im eigenen Netzwerk ab, der das per http anbietet - notfalls genügt ein Rechner mit Python: yavdr 0.6 preseed - Probleme und Fixes


    Damit man nicht auf unstable landet hier noch ein preseed für die stable-PPAs: https://dl.dropboxusercontent.…9/yaVDR/yavdr-stable.seed

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke Seahawk, das hat funktioniert und auch der interne CIR wurde erkannt. Allerdings habe ich noch nicht entdeckt, wie ich ihm mitteile, dass die Harmony mit MCE-Profil sendet.


    Etwas off topic: Ist in der 0.6.1 kein Treiber für die DVB Sky S2 S960 (USB) enthalten? Bei lsusb taucht die Karte nicht auf und mit dmesg kommt

    Code
    1. [ 1160.020457] usb 1-3: new high-speed USB device number 6 using xhci_hcd
    2. [ 1160.037316] usb 1-3: New USB device found, idVendor=0572, idProduct=6831
    3. [ 1160.037340] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    4. [ 1160.037357] usb 1-3: Product: S960 [ 1160.037371] usb 1-3: Manufacturer: Bestunar
    5. [ 1160.037385] usb 1-3: SerialNumber: 20120511


    Gruß,
    Norman

    VDR1 yaVDR 0.6.1, 2x TT S2-3200 CI, AMD 5050e, ASUS M3N78-EMH HDMI, 2GB RAM, GraKa Asus ENGT220 1GB, Sound per HDMI, 1TB HDD, Blu-ray Disc & HD DVD-ROM Drive LG GGC-H20N, GraphTFT auf 7" HDMI-LCD (China-Variante), Atric-IR, FB Logitech Harmony 600, Yamaha RX-V673, Philips 7606
    VDR2 yaVDR 0.6.1, DVB-s Rev 2.1, Athlon 3000+; 1GB RAM; 1TB HDD; GraKa GF 6600, per DVI an TFT
    VDR3 yaVDR 0.6.1, Intel NUC DN2820FYKH, Harmony 350, DVBSky S960

  • Ist in der 0.6.1 kein Treiber für die DVB Sky S2 S960 (USB) enthalten?

    Wenn die Karte nicht vom Kernel 3.13 unterstützt wird, dann nicht.

    auch der interne CIR wurde erkannt. Allerdings habe ich noch nicht entdeckt, wie ich ihm mitteile, dass die Harmony mit MCE-Profil sendet.

    Was für ein CIR-Empfänger ist das?

    Code
    1. sudo ir-keytable
    2. cat /proc/bus/input/devices

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • sudo ir-keytable

    Quote

    Driver ite-cir, table rc-rc6-mce
    Supported protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
    Enabled protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
    Name: ITE8713 CIR transceiver
    bus: 25, vendor/product: 1283:0000, version: 0x0000
    Repeat delay = 500 ms, repeat period = 125 ms


    Aber der Punkt ist nicht, dass der Receiver nicht erkannt wird, Pfeiltasten und ok arbeiten auch jetzt schon, aber halt nicht alle Tasten. D. h. ich muss dem VDR ja irgendwie mitteilen, welches Profil er verwenden soll. Bei den LIRC-Empfängern geht das über die LIRC.conf.


    Ich habe auch mal LIRC aktiviert und Home-Brew MCE ausgewählt, aber das ist nicht die Lösung.


    Gruß,
    Norman

    VDR1 yaVDR 0.6.1, 2x TT S2-3200 CI, AMD 5050e, ASUS M3N78-EMH HDMI, 2GB RAM, GraKa Asus ENGT220 1GB, Sound per HDMI, 1TB HDD, Blu-ray Disc & HD DVD-ROM Drive LG GGC-H20N, GraphTFT auf 7" HDMI-LCD (China-Variante), Atric-IR, FB Logitech Harmony 600, Yamaha RX-V673, Philips 7606
    VDR2 yaVDR 0.6.1, DVB-s Rev 2.1, Athlon 3000+; 1GB RAM; 1TB HDD; GraKa GF 6600, per DVI an TFT
    VDR3 yaVDR 0.6.1, Intel NUC DN2820FYKH, Harmony 350, DVBSky S960

  • Das ist ein Empfänger, der nicht über Lirc, sondern über ir-keytable konfigurert wird - vgl. http://www.yavdr.org/documenta…/ch02s03.html#ir-keytable - soweit ich das im Kopf habe, gibt es noch keine Vorkonfiguration für den Empfänger in yavdr-remote.
    So eine Zeile in der /etc/rc_maps.cfg sollte helfen (am besten als custom Template hinterlegen):

    Code
    1. ite-cir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce


    Zum Testen kannst du die keytable so laden:

    Code
    1. sudo ir-keytable -w /lib/udev/rc_keymaps/rc-rc6-mce

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Falls das so klappt, sag mir bitte Bescheid, dann übernehme ich das in yavdr-remote.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk, ich habe die Zeile hinzugefügt, direkt unter die mit Nuvoton, das war übrigens der in älteren NUC zum Teil verbaute CIR.


    Hat funktioniert! Danke.


    Gruß,
    Norman

    VDR1 yaVDR 0.6.1, 2x TT S2-3200 CI, AMD 5050e, ASUS M3N78-EMH HDMI, 2GB RAM, GraKa Asus ENGT220 1GB, Sound per HDMI, 1TB HDD, Blu-ray Disc & HD DVD-ROM Drive LG GGC-H20N, GraphTFT auf 7" HDMI-LCD (China-Variante), Atric-IR, FB Logitech Harmony 600, Yamaha RX-V673, Philips 7606
    VDR2 yaVDR 0.6.1, DVB-s Rev 2.1, Athlon 3000+; 1GB RAM; 1TB HDD; GraKa GF 6600, per DVI an TFT
    VDR3 yaVDR 0.6.1, Intel NUC DN2820FYKH, Harmony 350, DVBSky S960

  • ich versuche gerade, yaVDR 0.6.1 auf einem Intel NUC i5 mit HD6000 Grafik zu installieren. Ich habe die NUC spezifischen Einstellungen wie hier beschrieben durchgeführt, bekomme aber leider nur einen schwarzen Bildschirm mit einem Mauszeiger (der sich bewegen lässt) und keine VDR Ausgabe.


    Nach dem booten sehe ich im syslog diese Ausgabe:


    Danach meldet sich der VDR im syslog nicht mehr, er scheint aber noch zu laufen:



    Was kann ich da machen?


    Gruß,
    Reiner

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR 0.5.0a, vdr 2.0.6-6yavdr1
    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0, vdr 2.2.0-11easyVDR0~trusty
    Backend: Athlon 2500+, Digital Devices CineS2 DVB-S2, Debian 9, vdr 2.4.0-2~etobi1 (e-tobi)