[0.6.0] Parallelbetrieb LAN und WLAN mittels ifmetric-[gelöst]

  • Hallo,
    analog zu meinem Produktivsystem mit yaVDR 0.5.0a, wollte ich auch bei der 0.6.0 per angepasster /etc/network/interfaces erreichen, dass beim Bootvorgang geprüft wird, über welches Netzwerkinterface der Netzzugang erfolgen kann. LAN, WLAN oder aber auch beides. Dazu habe ich das Paket ifmetric installiert und die /etc/network/interfaces wie folgt angepasst:



    Während das bei der 0.5.0a prächtig funktioniert (zumindest ist mir kein Unterschied gegenüber der Basisinstallation aufgefallen), verzögert es bei der 0.6.0 den Startvorgang immens. Vor allem, wenn lediglich das WLAN-Interface zur Verfügung steht, Kabel also abgezogen wurde. Dann erscheinen im Bootsplash nacheinander folgende Meldungen:


    waiting for networking configuration
    waiting up to 60 more seconds for network configuration
    booting system without full network configuration


    Das System startet dann nach ewiger Verzögerung, die gewünschten Netzwerkinterfaces stehen anschließend jedoch auch so wie gewünscht zur Verfügung. Lediglich die lange Verzögerung nervt.
    Ich vermute mal, meine Konfig passt irgendwo nicht so ganz.
    Wer hat einen Tipp für mich?


    Danke
    VDRDAU


    Zusatzinfo:
    Ursprüngliche Anfrage für die 0.5.0a
    ERLEDIGT: Netzwerkverbindung: Entweder WLAN oder LAN automatisch beim Bootvorgang starten

  • Lediglich die lange Verzögerung nervt.
    Ich vermute mal, meine Konfig passt irgendwo nicht so ganz.

    Du kannst entweder statische IPs vergeben oder die Wartezeiten verkürzen: https://www.linuxquestions.org…thout-network-4175510497/

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Alleine die Wartezeit zu verkürzen könnte evtl. nicht reichen. Prüfe auch, ob Du erfolgreich das Webconfig von einem anderen Rechner aus aufrufen kannst. Ich hatte hier zwei unterschiedliche Probleme:


    1. In /etc/init/tntnet.conf tritt start on static-network-up niemals ein und damit wird tntnet beim Booten nicht gestartet. Evtl. gibt es hier noch Probleme mit anderen Diensten?


    2. Selbst wenn tntnet gestartet wird, kann es gerade bei WLan dazu kommen, daß das Webconfig nicht aufrufbar ist. Der Aufbau der WLan Verbindung beim Booten dauert einfach zu lange und tntnet bindet sich dann scheinbar nicht richtig ans Interface. Hier hilft evtl. ein sleep Befehl vor dem exec Aufruf in der tntnet.conf .


    Derzeit bin ich dazu übergegangen, während des Bootens zu schauen, ob in eth0 ein Netzkabel steck. wlan0 ist nicht auf auto in /etc/network/interfaces eingestellt und wird nur bei Bedarf von folgendem Code beim Booten gestartet:


    Code
    1. # Check for eth0 ethernet cable when running on a system with RT2790 based wlan. Enable wlan if no cable link is detected
    2. if /sbin/ip link | /bin/grep -q 'eth0:.*state.*DOWN'; then
    3. if lspci | /bin/grep -q 'RT2790'; then
    4. logger -t $0 "*** eth0 cable disconnected. Starting wlan0"
    5. echo "eth0 cable disconnected. Starting wlan0"
    6. { ifup wlan0; sleep 5; dhclient wlan0; } &
    7. fi
    8. fi


    Aber noch bin ich nicht so recht zufrieden, da hier immer noch der 1. Fall auftretten kann. Ich teste noch. Es sieht wohl so aus, als ob ich in einem init Script alle Netzwerk Interfaces nach Bedarf selbst starten muss :-( Es


    PS: Bei einem pfsense 2.2.4 Wlan Router klappt DHCP nicht... und ich muss dhclient separat aufrufen. Bei einer Fritzbox klappt es mit dem DHCP. Wäre schön, wenn jemand herausfindet, wo man in Ubuntu drehen muss, damit sich 14.04 wie 12.04 verhält. Aber es gibt hier ein Setup, wo ich nicht sehe, wie man es ohne zusätzliches Script zum laufen bekommt.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Guter Gedanke die Module einzutragen, würde jedoch auch das Problem nicht vollständig beheben. Bis WPA2+DHCP bei WLan durch sind, dauert es des öfteren schon einige Sekunden. Mit dem Eintragen gewinnt man ein paar Sekunden, aber immer genug?


    Aber was passiert, wenn man eben WLan nutzen will und kein Kabel angeschlossen ist? Sobald eines der in /etc/network/interfaces angebenen Interfaces mit DHCP nicht beim booten schnell da ist, gibt es zumindest mit dem webconfig schnell Probleme.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Lauscht tntnet nicht auf 0.0.0.0? Dann würde es auch auf später hinzugekommenen Interfaces automatisch ansprechbar sein.
    Musst du mal gucken, ob man das irgendwo konfigurieren kann.


    Lars

  • Alleine die Wartezeit zu verkürzen könnte evtl. nicht reichen. Prüfe auch, ob Du erfolgreich das Webconfig von einem anderen Rechner aus aufrufen kannst. Ich hatte hier zwei unterschiedliche Probleme:

    Hallo,
    per Zufall und auch verspätetet hier meine Rückmeldung:
    Auch bei mir war ursprünglich das Webfrontend nicht erreichbar, sowohl lokal als auch über Netz nicht. Ich hatte in der failsafe.conf die Wartezeiten auskommentiert. Aus Zeitmangel habe ich mich aber nicht mehr weiter damit beschäftigt. Zumal produktiv noch eine 0.5.0a läuft.


    Nun habe ich aber gerade aus diesem die Lösung übernommen:
    [yavdr 0.6] Rückmeldung / Vorschläge


    darin:
    "- Auf 3 verschiedenen Mainboards gab es die Meldung "Waiting for Network". Teilweise noch den Zusatzcountdown "60 minutes more"
    Wenn in der /etc/network/interfaces statt "auto eth0", "allow-hotplug eth0" eingetragen wird, erledigt sich das Problem mit dem verzögerten Start."


    und mein Webfrontend ist nun auch erreichbar.


    Vielleicht hilft das auch anderen Usern.


    CU
    VDRDAU