ACPI Wakeup mit Intel NUC (Broadwell NUC5i3RYH)

  • Hallo zusammen,


    ich bekomme auf meinem Intel NUC das ACPI-Wakeup nicht zum Laufen. Kann mir jemand einen Tip geben,
    wie ich das hinbekomme (oder die BIOS-Einstellungen, mit dem er seinen NUC5i3RYH betreibt?


    Wenn ich den NUC über BIOS starten lasse (d.h. die Aufwachzeit im BIOS eintrage und Wakeup from S5 wähle),
    startet der Rechner wie gewünscht.


    Wenn ich die Aufwachzeit über ein ACPI Test-Script eintrage, wacht er nicht auf.
    Stattdessen ist - nach manuellem Boot - die Wakeupzeit die er via cat /proc/driver/rtc anzeigt verstellt ...


    Das Verhalten ändert sich auch nicht, wenn ich im BIOS Wakeup from S5 aktiviere oder deaktiviere



    Einige Details zu meinem System:

    • BIOS RYBDWi35.86A.0350 von 12.08.2015
    • Debian Jessie mit Kernel 3.16 (auch mit Kernel 3.19 probiert, Verhalten identisch)
    • HPET im BIOS disabled, und als Startoption "hpet=disable" des Kernel angegeben
    • In /etc/init.d/hwclock.sh "Saving the system clock" abgestellt

    Langsam gehen mir die Ideen aus ...


    m.f.G.
    Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i5) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.30-2 x86_64)

  • Suche im BIOS nach "ErP" und schalte es ab. Ist so was wie Tiefschlaf. Wenn es an ist, wird auch die NIC wegen Energiesparen vollkommen ausgeschaltet, Wecken nicht möglich.


    Albert

  • Hallo ATD,


    ErP find ich im BIOS nicht. Wie könnte das noch heißen??? (und liegt das echt am Power Mode, denn von RTC bootet er ja)


    Meinst Du mit NIC den NetzwerkInterfaceController im Chipsatz, und damit Wake on LAN muß enabled sein?


    m.f.G.
    Michael



    p.s. interessant ist, die veränderte Wakeupzeit nach dem Booten (aus 21:34:49 wird 21:24:52 des nächsten Tages !!! )


    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i5) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.30-2 x86_64)

  • ErP find ich im BIOS nicht. Wie könnte das noch heißen???


    Schau mal hier, ggf Jumper.


    und liegt das echt am Power Mode, denn von RTC bootet er ja


    Das wäre nur logisch.


    Meinst Du mit NIC den NetzwerkInterfaceController im Chipsatz, und damit Wake on LAN muß enabled sein?


    Mit NIC meine ich Network Interface Card, also die Netzwerkkarte selbst.


    p.s. interessant ist, die veränderte Wakeupzeit nach dem Booten (aus 21:34:49 wird 21:24:52 des nächsten Tages !!! )


    Bei Linux sollte das BIOS immer im UTC laufen!


    Albert

  • Hallo Albert,


    Wenn es auf der Intel Seite heißt:


    Zitat

    Enabling ErP ... disables all of the following wake events:


    •In the S4 sleep state (hibernate)
    •In the S5 sleep state except for the power button


    The system only wakes from the S4 sleep state, or the S5 sleep state, with the power button.
    Disabling ErP allows the system to wake on events other than only the power button (wake-on-LAN, wake-on-PS2).


    ... und mein Rechner automatisch (per RTC) aus dem Tiefschlaf erwacht (und nicht nur per Power-On Button), dann ist doch der ErP Mode bei mir schon abgeschaltet. Oder?


    Ich vermute, der ErP Mode wird mittlerweile mit dem BIOS "Wakeup from S5" oder "Wake on LAN from S4/S5" automatisch disabled (und Wake on LAN war bei mir immer eingeschaltet) Da spuckt doch bei mir noch etwas ganz anderes hinein ...


    Das ist aber ein guter Tip mit dem ErP - ich meß heute Abend mal die Stromaufnahme ...


    Frage zum Thema Linux und UTC (ja, das ist normalerweise die bevorzugte Einstellung. Ich habe aber ein DualBoot System mit Windows, und auf meinen anderen Rechnern hab ich das auch ohne UTC zum Laufen bekommen): Das Booten wird ja von Linux nicht disabled, wenn nicht UTC gewählt ist. Oder? Und ob UTC aktiv ist oder nicht weiß das BIOS gar nicht, und die Weckzeit ist ja nicht um 1 Stunde verkehrt, sondern um 1 Tag +/- etwas. Seltsam.


    m.f.G.
    Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i5) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.30-2 x86_64)

  • Hallo zusammen,


    hab das jetzt mit einem Linux 4.2 (Debian Testing) probiert, die Uhr steht auf UTC - hilft alles nichts ...


    Hat keiner einen Tip???


    M.f.G.
    Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i5) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.30-2 x86_64)

  • die Uhr steht auf UTC - hilft alles nichts ...


    Wobei: WOL oder Time?


    Albert

  • Hallo Albert,


    muß mich bei Dir entschuldigen - stimmt wirklich: es läuft nur mit UTC (hätt ich nicht geglaubt, weil ich meinte ihn früher mit locale hinbekommen zu haben. Da mag ich mich aber täuschen).


    Hab gestern nochmal die ganzen Einstellungen überprüft - in manchen Linux Scripten wird einfach von UTC ausgegangen (eine Stelle hab ich gefunden, es gibt aber scheinbar mehrere)

    • WakeUpOnRtc im BIOS ausschalten
    • hwclock --systohc --UTC => damit merkt sich (wahrscheinlich vor allem) Linux: RTC ist im UTC Mode
    • dann mein script starten (was 2x die Wakeupzeit nach /sys/class/rtc/rtc0/wakealarm schreibt
    • dann Fehlermeldung beim 2. Schreiben nach /sys/class/rtc/rtc0/wakealarm (device ist schon belegt; bei dem NUC Mainboard reicht also nur 1x schreiben) => hatte ich vorher noch nie gesehen!!! also macht er jetzt sogar etwas.
    • mit cat /proc/driver/rtc die Uhrzeit kontrollieren (sie ist jetzt wirklich nur 2 min in die Zukunft wie im Script eingestellt - und nicht wie bei locale 5 min in die Zukunft (da war ein weiterer Effekt am Werkeln))
    • poweroff eingeben - und nach 2 min schaltet die Kiste wirklich wieder ein. Spitze!!!

    Hab im Forum einen Beitrag gefunden, wie man Windows 7 auch beibringt, mit RTC und UTC klarzukommen (nicht ganz: Win-7 stellt dann die RTC nichtum, wenn die Zeit nicht paßt) aber mein Rechner läuft die meiste Zeit mit Linux als VDR


    Vielen Dank für die Tip´s ...


    m.f.G.
    Michael

    VDR: Zotac ION-ITX F mit 2xSundtek Media-TV USB-Stick (für DVB-C); Debian Wheezy (3.2.0-4-686-pae)
    VDR: ASRock Q1900DC mit 1xTerratec Rev. 2 USB Stick (für DVB-C); Debian Ubuntu 14.04 LTS
    VDR: Intel NUC (Skylake i5) mit 128 GB SSD, 1GB Disk, 2xSundtek USB DVB-C Stick; Debian Stretch (4.9.30-2 x86_64)

  • muß mich bei Dir entschuldigen


    Warum das? Du bist ein netter Mensch und für solche tue ich, was in meiner "Macht" steht. Das ist wohl selbstverständlich. ;-)


    Albert