ACPI Wakeup mit ASRock AM1H-ITX mit Athlon 5350 und Ubuntu 14.04 (Gelöst)

  • Hallo zusammen


    ich habe das gesamte Wochenende damit verbracht ACPi wakeup mit dem ASRock AM1H-ITX unter Ubuntu 14.04 zum laufen zu bekommen und weißß jetzt nicht mehr weiter.


    Meine letzte Konfiguration entspricht der aus dem Wiki von mythtv https://www.mythtv.org/wiki/ACPI_Wakeup.


    Hier die Settings im BIos (ich habe auch schon andere probiert):


    Suspend to Ram: Auto
    Check ready Bit: Enabled
    ACPI HPET Table: Enabled
    RTC Arlarm Power on: By OS


    Der Rest ist disabled.


    Gibt es jemanden, der ACPI wakeup mit diesem Board zum laufen bekommen hat und hat jemand Ideen/Einstellungen die nicht iin den einschlägiegen Wikis/howtos und forum poasts genannt werden?


    LG.


    Hempel

    ASRock AM1H-ITX
    Athlon 5350
    Seagate Baracuda 1000 GB
    Digital devices Cine S2
    Seagate Barracuda 1000GB


    Ubuntu 14.04 LTS
    vdr (2.2.0/2.2.0)

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Hempel ()

  • Naja, auch für VDR gibt es ein Wiki: http://www.vdr-wiki.de/wiki/index.php/ACPI_Wakeup


    Wenn HPET ausschalten nicht hilft, könntest Du eines der wenigen Boards erwischt haben das evtl. nicht funktioniert. Test-Timer sollte nicht zu nah in der Zukunft sein ...


    Mein letztes vor vielen Jahren war auch ein ASRock Mainboard, das habe ich dann eben wieder zurückgegeben, weil das ein eine essentielle Funktion ist.


    Regards
    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von fnu ()

  • Hallo fnu


    danke für die Antowort. Das Wiki hatte ich shcon ohne Erfolg abgearbeitet, habe jetzt aber beschlossen es erneut zu versuchen und alle Einstellungen aus dem anderen WIki rückgängig gemacht.


    Ich glaube, dass es eigentlich funktionieren müsste, da dmesg folgendes ausgiebt:


    Code
    1. dmesg | grep rtc
    2. [ 1.246897] rtc_cmos 00:05: RTC can wake from S4
    3. [ 1.248511] rtc_cmos 00:05: rtc core: registered rtc_cmos as rtc0
    4. [ 1.250009] rtc_cmos 00:05: alarms up to one month, y3k, 114 bytes nvram
    5. [ 1.295614] rtc_cmos 00:05: setting system clock to 2015-09-06 18:16:45 UTC (1441563405)


    oder sehe ich das falsch?

    ASRock AM1H-ITX
    Athlon 5350
    Seagate Baracuda 1000 GB
    Digital devices Cine S2
    Seagate Barracuda 1000GB


    Ubuntu 14.04 LTS
    vdr (2.2.0/2.2.0)

  • OK! Hab den Fehler gefunden und manuelle klapp es jetzt!:)


    Der Timer wurde aus einem init script, was ich vorher geschrieben hatte gesetzt :wand . Der entscheidende Hinweis aus dem Wiki (nochmal danke Fnu!) war also:


    Code
    1. grep "hwclock" /etc/init.d/*


    Irre, wie man sich manchmal totsuchen kann! Das tolle ist aber, dass das motherboard mit ACPI wakeup funktioniert.


    Das merkwürdige ist jetzt aber, dass der Timer vom VDR völlig schräg gesetzt wird. Ich habe einen timer 10 min in der Zukunft gesetzt und er wird auch vom schutdown script gesetzt, allerdings viel zu weit in der Zukunft:



    :rolleyes:

    ASRock AM1H-ITX
    Athlon 5350
    Seagate Baracuda 1000 GB
    Digital devices Cine S2
    Seagate Barracuda 1000GB


    Ubuntu 14.04 LTS
    vdr (2.2.0/2.2.0)

  • Hempel


    IIRC können manche Boards können keine Jahreszahl nur Tag/Monat, daher manchmal so eine komische Anzeige. Interessanter wäre ob das Gerät nun passend aufwacht?


    Für AMD Hardware muss man schon immer HPET abschalten, bei Intel kam das erst so ab SandyBridge hier und da rein ...


    Regards
    fnu

    HowTo: APT pinning

  • Hi


    ich habe das Gefühl, dass es eher mit der Brückenzeit zwischen den timern zu tun hat. Wenn ich einen timer > 30 min setzte, wird der timer korrekt gesetzt (laut /proc/driver/rtc). HPET ist momentan deaktiviert.


    Ich wernde heute Nacht mal eine Aufnahme probieren und probiere dann morgen auch mal mit aktiviertem HEPT und gucke was passiert.


    Manuell wacht es uaf jeden Fall auf, also wird es irgendwie klappen.

    ASRock AM1H-ITX
    Athlon 5350
    Seagate Baracuda 1000 GB
    Digital devices Cine S2
    Seagate Barracuda 1000GB


    Ubuntu 14.04 LTS
    vdr (2.2.0/2.2.0)

  • Das ist was ich meinte, der Test-Timer sollte nicht zu nah in der Zukunft liegen ...


    Die Brückenzeit von 30min braucht heute keiner mehr, bei mir steht die auf 10min, moderne HW mit SSD ist sehr schnell wieder gestartet ...


    Regards
    fnu

    HowTo: APT pinning

  • So


    Ich habe jetzt einmal mit HEPT versucht und das klappt nicht. DIe Einstellung ist also einfach wie im ersten post und aufwachen tut das motherboard auch richtig (zumindest, wenn der timer weit genug in der Zukunft liegt). Alles andere habe ich noch nicht probiert.

    ASRock AM1H-ITX
    Athlon 5350
    Seagate Baracuda 1000 GB
    Digital devices Cine S2
    Seagate Barracuda 1000GB


    Ubuntu 14.04 LTS
    vdr (2.2.0/2.2.0)