BM2LTS - div. Hardware & Kodi.tv

  • Dear cinfo,
    As now we have Kodi 17.1, can we have an update please?
    Is a new image required or we can update over the terminal?


    Thank you in advance.


    Hi,


    Install Kodi Unstable

    Code
    1. sudo add-apt-repository ppa:team-xbmc/unstable
    2. sudo apt-get update
    3. sudo apt-get upgrade


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Hallo zusammen!


    Ich habe heute mal BM2LTS 2.95 auf dem NUC mit Kodi installiert. Läuft bisher ganz gut. Nun habe ich aber das Problem das nach einem Reboot das NAS als Aufnahmeverzeichnis verschwindet.
    Ich binde es über vdr-ip:8002 ->RBC.. ein und es ist danach vorhanden. Nach dem Reboot ist es im Kodi nicht mehr da,allerdings besteht der Eintrag im vdr unter Netzwerkverbindungen noch.
    Welchen Fehler mache ich hier, es funktioniert ja wohl bei anderen.


    Gruß tft

    Kopfstation: Netceiver C94 mit 3x Dual S2-Tuner
    Switch Zyxel GS1910-24 mit VLAN
    Switch Cisco SLM2008 mit VLAN
    Raspberry Client
    Intel D525MW_2GB RAM_60GB SSD_eHD im Avantgarde Gehäuse inkl. Reel-Display mit BM2LTS_V2.95.1 RC01
    vdr 1.7.21.9
    NAS HP ProLiant GEN8, Openmediavault
    NUC D34010WYK Easyvdr 3.0

    The post was edited 3 times, last by tft ().

  • Hallo zusammen!


    Ich habe heute mal BM2LTS 2.95 auf dem NUC (D34010wyk) mit Kodi installiert. Läuft bisher stabil. Nun habe ich aber das Problem das nach einem Reboot das NAS als Aufnahmeverzeichnis verschwindet.
    Ich binde es über vdr-ip:8002 ->RBC.. ein und es ist danach vorhanden. Nach dem Reboot ist es im Kodi nicht mehr da,allerdings besteht der Eintrag im vdr unter Netzwerkverbindungen noch.
    Welchen Fehler mache ich hier, es funktioniert ja wohl bei anderen.


    Gruß tft


    Mit der Version 2.95.1_RC01 habe ich es aufgegeben, weil ich keine Lösung für das Problem gefunden habe.


    Ich habe stattdessen die 2.94.4_RC10 genutzt, dort tritt das Problem nicht auf und das NAS wird bei jedem booten korrekt eingebunden.
    Ich habe diese Release auf Kodi 17.1 stable aktualisiert und es läuft bisher sehr gut.


    Bei dieser Version taucht aber immer kurz nach dem Starten die Meldung "Sie müssen sich legitimieren,um >/usr/lib/update-notifier/package-system-locked < mit Systemverwalterrechten auszuführen
    Eine Anwendung versucht eine Aktion auszuführen, die Privilegien erfordert. Eine Legitimation ist erforderlich, um diese Aktion auszuführen....


    Da ich trotz Forensuche und mangels Kenntnisse zu keiner sauberen Lösung gefunden habe, habe ich "package-system-locked" in "package-system-locked_org" umbenannt und jetzt kommt keine Meldung mehr. Sicher nicht die richtige Lösung, vielleicht kennt einer diese ja.
    Dann fehlten noch die Zifferntasten bei der RC6 Fernbedienung. Nachdem ich in der /etc/rc.keymaps/rc6_mce die Zifferntasten von KEY_KP0...KEY_KP9 in KEY_0...KEY_9 umbenannt habe, funktionieren diese auch in Kodi. Warum diese im Ursprung so genannt wurden hat sich mir nicht erschlossen, diese Variante habe ich in keiner Beschreibung bisher finden können.


    Für das Thema mit den festen IP-Adressen (bei externen Netceiver), habe ich für mich folgenden Workarround gefunden:


    Kopieren der interfaces nach /etc/networks mit entsprechend angepassten Inhalt:


    und danach gleich folgende Änderungen in der /etc/default/sysconfig machen:


    danach Reboot


    Bisher läuft es sehr gut.


    Gruß tft

    Kopfstation: Netceiver C94 mit 3x Dual S2-Tuner
    Switch Zyxel GS1910-24 mit VLAN
    Switch Cisco SLM2008 mit VLAN
    Raspberry Client
    Intel D525MW_2GB RAM_60GB SSD_eHD im Avantgarde Gehäuse inkl. Reel-Display mit BM2LTS_V2.95.1 RC01
    vdr 1.7.21.9
    NAS HP ProLiant GEN8, Openmediavault
    NUC D34010WYK Easyvdr 3.0

    The post was edited 2 times, last by tft ().

  • Ich habe es jetzt noch einmal mit der Version 2.95.1_RC01 und Kodi 17.3 versucht.
    Das Problem mit der "Vergessen" der NAS-Netznetzwerkverbindung bleibt. Ich konnte dies aber mit einem Eintrag in der fstab umgehen, so das mir das Laufwerk wie gewohnt nach einem Reboot zur Verfügung steht.
    Auch sind die hier " NUC startet bei Timeraufnahmen nicht" von mir beschriebene Probleme geblieben.
    Um dies erst einmal zu umgehen lasse ich den NUC durchgehend laufen und schalte am Ende nur den TV aus. Damit scheint Ubuntu/Kodi aber nicht klar zukommen, da nach jedem Einschalten des TV ich entweder den Desktop von Ubuntu oder ein ruckelndes/klötzchenbehaftetes Bild sehe.
    Im ersteren Fall muss ich mit einer Maus Kodi neustarten, da ich mit der Fernbedienung das Kodi-ICON nicht erreiche. Beim 2.Fall genügt ein Umschalten des Kanals um ein stabiles Bild zu bekommen. Die Energieeinstellung von Ubuntu habe ich soweit geprüft, das keine Timeouts für den Bildschirm gesetzt sind.
    Das Ganze ist so bei mir nicht wirklich familientauglich.


    Die Frage die sich mir stellt, liegt es am NUC D34010 der mit den Energieeinstellungen etc. nicht klarkommt? (wenn man Google befragt gibt es wohl doch das ein oder andere Probleme mit diesem NUC-Typ beim Wakeup etc.)
    Wenn das Problem beim Starten von Timeraufnahmen aus dem ausgeschalteten Zustand mit dieser NUC-Version nicht wäre, hätte ich zumindest die Wiedergabeprobleme auch nicht.
    Nun würde ich ja mir den NUC7 i3... zulegen um diese Probleme zu umgehen. Um aber einen eventuellen "Fehlkauf" zu umgehen würde ich in die Runde noch mal folgende Fragen stellen:


    -besteht die NAS-Einbindung nach einem Reboot weiter
    -startet der NUC aus dem ausgeschalteten Zustand bei programmierten Timeraufnahmen


    Hat damit jemand schon Erfahrungswerte mit diesem Typ.


    Ansonsten käme ja noch in Betracht den NUC als Server zu betreiben und mit Raspi/Odroid den Client abzubilden. Wie gut ist denn dort die Bildausgabe an einem 65 Zoll Fernseher. Ich gehe mal davon aus das es durchaus Unterschiede in der Qualität zu einem NUC7 geben dürfte.


    Danke und Gruß
    tft

    Kopfstation: Netceiver C94 mit 3x Dual S2-Tuner
    Switch Zyxel GS1910-24 mit VLAN
    Switch Cisco SLM2008 mit VLAN
    Raspberry Client
    Intel D525MW_2GB RAM_60GB SSD_eHD im Avantgarde Gehäuse inkl. Reel-Display mit BM2LTS_V2.95.1 RC01
    vdr 1.7.21.9
    NAS HP ProLiant GEN8, Openmediavault
    NUC D34010WYK Easyvdr 3.0


  • Ist jetzt mangels Antwort davon auszugehen das es keine Erfahrung dahingehend mit dem NUC7 gibt,weil ihn noch keiner wirklich benutzt, oder geht es vielleicht mit diesem Typ nicht.


    Gruß tft

    Kopfstation: Netceiver C94 mit 3x Dual S2-Tuner
    Switch Zyxel GS1910-24 mit VLAN
    Switch Cisco SLM2008 mit VLAN
    Raspberry Client
    Intel D525MW_2GB RAM_60GB SSD_eHD im Avantgarde Gehäuse inkl. Reel-Display mit BM2LTS_V2.95.1 RC01
    vdr 1.7.21.9
    NAS HP ProLiant GEN8, Openmediavault
    NUC D34010WYK Easyvdr 3.0

    The post was edited 1 time, last by tft ().

  • Hi,


    Quote

    Im ersteren Fall muss ich mit einer Maus Kodi neustarten, da ich mit der Fernbedienung das Kodi-ICON


    einfach mal auf der Konsole

    Code
    1. new

    eingeben dann sollte alles neu starten incl. Kodi.


    Das Problem ist aber ein Kernel Problem bzw. warum die EPG Daten machmal nicht passen habe ich noch nicht raus gefunden.
    Man Kdi beim Laden zu sehen wie es am VNSI-laden der EPG Daten abstürzt.


    Mit dem NUC7 mit i3 gibt es kein Probleme mit Kernel und Ubuntu-Umgebung/Kodi -- nur sollte man das auch mal im Kodi-Forum zur Verion 17.3 mal näher anfragen.


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA