Mit epgd & epg2vdr nur wenige Sender mit EPG beim LIVE-Plugin

  • Hallo,
    ich habe mit folgender Anleitung

    Code
    1. http://www.vdr-portal.de/board16-video-disk-recorder/board99-distributionen/board96-yavdr/121713-epgd-epg2vdr-how-to/

    versucht, EPGD und epg2vdr auf meinem Server (...und später auf den Clienten einzurichten). Ich habe kein epgDATA-Abo, habe aber gedacht, dass sich epgd die Daten (so wie ohne epgd auch) vom DVB-S2-Strom holen kann.
    Nun werden aber im Live-Plugin unter <server-ip>:8008 nur wenige Sender (MDR, Sport1, ProSiebenMAXX und andere Exoten) mit EPG angezeigt.
    Wenn ich mir aber nun unter "epgd-showmerge S19.2E-1-1019-10301" die Daten von "Das Erste HD" aufrufe, werden diese einwandfrei angezeigt.
    Ich nehme nunmehr an, dass die Daten nicht ordnungsgemäß an epg2vdr übergeben werden.
    Kann ich das irgendwo überprüfen und ggfs. korrigieren?
    Unter "/var/lib/vdr/setup.conf" erscheint zum Thema epg2vdr nur folgender Eintrag "epg2vdr.Uuid = 2F0F1AEE-E041-48B3-B032-139F3ACBA7FC".
    Laut

    Code
    1. http://projects.vdr-developer.org/projects/plg-epg2vdr/wiki

    sollten da doch noch andere Sachen hinterlegt sein. Liegt es evtl. daran?
    Vielen Dank für jede Hilfe im Voraus
    Gruß
    Sven

  • Wozu macht epgd/epg2vdr Sinn, wenn man keine externen Daten benutzt?


    Was hast Du denn eingestellt? Im Plugin sollte blacklist auf 0 stehen, dann brauchts eigentlich garkeinen Eintrag in der channelmap. Bei blacklist=1 sollte jeder Kanal, denn Du haben willst, in der channelmap stehen.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hallo,

    Quote


    Wozu macht epgd/epg2vdr Sinn, wenn man keine externen Daten benutzt?

    Die Idee hatte ich aus länger zurückliegender Hilfe:
    TVScraper und MarkAd auf Headless-Server


    Nach weiterem Rumschnüffeln kam mir noch die Idee, mal die channelmap.conf anzuschauen.
    Und siehe da: Fast alle Sender waren (sicher mein Verständnisfehler aus der Anleitung im ersten Post) mit "epgdata"-Kennung versehen. Nach Austauschen aller Kennungen zu "vdr:000:0:0" und dem Löschen "unnötiger" Kanäle funktioniert es jetzt wie gewünscht.
    Nur Bilder werden mir nicht angezeigt, obwohl ich auch scraper2vdr installiert habe.
    Da fehlt mir noch der Lösungansatz.
    Vielleicht weißt du ja Rat.
    Gruß
    Sven

  • Weil der scraper nur mit ordentlichen externen Daten funktioniert. Wenn Du keine exteren Daten hast, kannst du aber immernoch das alte tvscraper Plugin nehmen. Kannst dich sonst auch mal nachdem tvm-Plugin für den epgd umschauen. Da brauchts kein Abo, ist aber rechtlich in der Grauzone.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB