VDR 2.2 / SoftHDDevice / SD to HD Audio Problem

  • Hallo zusammen,


    ich habe ein Update des VDR auf Version 2.2 durchgeführt, das SoftHDDevice Plugin ist auf dem aktuellen GIT Stand.
    Seit der Aktualisierung gibt es ein Problem beim Umschalten von einem SD auf einen HD Sender.


    Entweder ist der Ton komplett weg oder er hat Aussetzer. Ein dettach, attach vom SoftHDDevice Plugin behebt das Problem.
    Das ist allerdings nicht ideal.


    Der Ton wird via HDMI und Passthrough ausgegeben.


    Im Log kann ich allerdings nichts auffälliges finden.


    Hat vielleicht jemand eine Idee?



    Zusatzinfos: Ubuntu 14.04, Kernel 3.13.0-48



    Gruß
    Scorp

    HD DVB-C System / Ubuntu 14.04 x64 / Kernel 3.13.0-48 x64; VDR 2.2.x; VDRadmin 3.6.10 / ACPI Wakeup

    SoftHD-Device GIT / Vdpau / Nvidia 337.25

    ASUS AT5IONT-I; Atom D525; 4GB; Nvidia GT218; 1x DD Cine C/T v6; 1x DD DuoFlex C/T v2; (20~40 Watt)

  • Hi,
    Nutzt du alsa oder pulseaudio? Bringt der 3.16 evtl ne Verbesserung?


    Gesendet von meinem HTC One mit Tapatalk 2

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hier ist alsa im Einsatz.



    "!!Kernel Information
    !!------------------


    Kernel release: 3.13.0-48-generic
    Operating System: GNU/Linux
    Architecture: x86_64
    Processor: x86_64
    SMP Enabled: Yes



    !!ALSA Version
    !!------------


    Driver version: k3.13.0-48-generic
    Library version: 1.0.27.2
    Utilities version: 1.0.27.2



    !!Loaded ALSA modules
    !!-------------------


    snd_hda_intel
    snd_hda_intel



    !!Sound Servers on this system
    !!----------------------------


    No sound servers found.



    !!Soundcards recognised by ALSA
    !!-----------------------------


    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xf9ef8000 irq 60
    1 [NVidia ]: HDA-Intel - HDA NVidia
    HDA NVidia at 0xfbcfc000 irq 19


    "





    Was ist mit 3.16 gemeint? Ich vermute mal es geht um den Kernel.



    Da das Problem unter Kodi/XBMC nicht aufzutreten scheint tippe ich eher auf das Ausgabeplugin als Fehlerquelle.

    HD DVB-C System / Ubuntu 14.04 x64 / Kernel 3.13.0-48 x64; VDR 2.2.x; VDRadmin 3.6.10 / ACPI Wakeup

    SoftHD-Device GIT / Vdpau / Nvidia 337.25

    ASUS AT5IONT-I; Atom D525; 4GB; Nvidia GT218; 1x DD Cine C/T v6; 1x DD DuoFlex C/T v2; (20~40 Watt)

    The post was edited 3 times, last by Scorp ().

  • Hi,
    Ja ich meinte den neuen Ubuntu Kernel.


    Hast du mal mit pulseaudio getestet?


    MfG Stefan


    Gesendet von meinem HTC One mit Tapatalk 2

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Scorp ,
    ich hatte auch mal eine zeitlang immer diese nervigen Tonaussetzer beim Umschalten zwischen Sendern mit und ohne Dolby-Ton und das ist ja meistens so, wenn man zwischen HD- und SD-Sendern umschaltet.
    Mir hat damals geholfen den Parameter "AudioDrift Korrektur" im softhddevice-Plugin zu deaktivieren.
    Siehe hierzu auch diesen Thread!


    Vielleicht hilft dies auch bei Dir. Seit dem ich diesen Parameter abgeschalten habe gab es nie wieder Tonaussetzer! :D


    Paulaner

  • Paulaner
    Danke für den Hinweis. Das werde ich mal ausprobieren.



    @SurfaceCleanerZ
    Eigentlich möchte ich sofern möglich bei der LTS Konfiguration bleiben, aber Danke für den Tipp.

    HD DVB-C System / Ubuntu 14.04 x64 / Kernel 3.13.0-48 x64; VDR 2.2.x; VDRadmin 3.6.10 / ACPI Wakeup

    SoftHD-Device GIT / Vdpau / Nvidia 337.25

    ASUS AT5IONT-I; Atom D525; 4GB; Nvidia GT218; 1x DD Cine C/T v6; 1x DD DuoFlex C/T v2; (20~40 Watt)

  • Hi,
    Der 3.16 ist LTS. Es gab eine Update Version dafür damit.


    Gesendet von meinem HTC One mit Tapatalk 2

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hallo zusammen,


    ich habe nun intensiv getestet. Das Abschalten der Drift Korrektur scheint geholfen zu haben.
    Das Verhalten werde ich weiter beobachten.


    Vielen Dank für den Tip.



    Gruß
    Scorp

    HD DVB-C System / Ubuntu 14.04 x64 / Kernel 3.13.0-48 x64; VDR 2.2.x; VDRadmin 3.6.10 / ACPI Wakeup

    SoftHD-Device GIT / Vdpau / Nvidia 337.25

    ASUS AT5IONT-I; Atom D525; 4GB; Nvidia GT218; 1x DD Cine C/T v6; 1x DD DuoFlex C/T v2; (20~40 Watt)