[VDR4Arch] Schneiden von Aufnahmen

  • Seit längerem habe ich das Problem wenn ich eine Aufnahme schneiden will eine Art Standbild stehen bleibt das ständig "zuckt". Ein springen zu den Markierungen der Aufnahme ändert daran ebenfalls nichts, das Bild bleibt stehen wo man die Aufnahme angehalten hat und "zuckt".


    Woran kann das liegen?


    Nehme ich yaVDR mit aktuellem Testing (Dual-Boot), also ebenfalls VDR 2.2.0, kann ich ganz normal scheiden wie gewohnt.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Ausgabe: SHD
    Sender: Alle wo ich Aufnehme

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Könntest du mal eine Beispielaufnahme irgendwo hochladen?


    Wozu? Ich habe das Problem mit meinen beiden VDR unter Arch, nehme ich yaVDR das auf die gleichen Aufnahmen zugreift geht alles tadellos. Die Info habe ich extra im ersten Post mit angegeben woraus man erkennen sollte das es nicht an den Aufnahmen liegt.


    Kann da "graphicsmagick" mit reinspielen, das nutzt du ja nicht.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Ja, das mache ich mal. Kam mir vorhin auch so in den Sinn ;D

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Mit Minimal Konfiguration (vdr, shd, skindesigner) selbes Verhalten.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Selbes Verhalten mit dieser Kombination:

    Code
    1. [root@vdr03 conf.d]# ls -l
    2. insgesamt 8
    3. -rw-r--r-- 1 root root 4753 25. Mär 18:43 00-vdr.conf
    4. lrwxrwxrwx 1 root root 30 31. Mär 17:11 50-dbus2vdr.conf -> ../conf.avail/50-dbus2vdr.conf
    5. lrwxrwxrwx 1 root root 32 31. Mär 17:11 50-restfulapi.conf -> ../conf.avail/50-restfulapi.conf
    6. lrwxrwxrwx 1 root root 34 15. Apr 16:17 50-softhddevice.conf -> ../conf.avail/50-softhddevice.conf
    7. lrwxrwxrwx 1 root root 34 31. Mär 17:11 50-svdrpservice.conf -> ../conf.avail/50-svdrpservice.conf

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Ohne jetzt einen riesen Streit heraufzubeschwören.
    dbus2vdr ist nicht minimal.
    restfulapi ist nicht minimal.
    svdrpservice ist nicht minimal.


    Und ich habe immernoch keine konkrete Aussage, bei welchen Aufnahmen das passiert. "Alle wo ich aufnehme" ist keine konkrete Aussage.
    Sonst kann ich dir nämlich auch sagen, dass es bei mir funktioniert und den Thread nicht weiter beachten.


    Du wurdest darum gebeten in minimaler Konfiguration zu testen --> Machst du nicht.
    Du wurdest darum gebeten eine Testaufnahme bereitszustellen --> Machst du nicht.


    Wie genau soll ich dir helfen?

  • So ist das selbe Verhalten:

    Code
    1. [root@vdr03 conf.d]# ls -l
    2. insgesamt 8
    3. -rw-r--r-- 1 root root 4753 25. Mär 18:43 00-vdr.conf
    4. lrwxrwxrwx 1 root root 34 17. Nov 14:06 50-softhddevice.conf -> ../conf.avail/50-softhddevice.conf


    Ich kann das bei allen Aufnahmen (neue, alte, SD, HD) nachstellen mit vdr4arch, insgesamt knapp 3TB.


    Es liegt nicht an den Aufnahmen, yaVDR greift auf die gleichen zu und bearbeitet diese ohne das Phänomen.


    vdr4arch:

    Code
    1. [root@vdr03 conf.d]# pacman -Qs ffmpeg
    2. local/ffmpeg 1:2.6.1-2
    3. Complete and free Internet live audio and video broadcasting solution


    yaVDR:
    Testing:

    Code
    1. ii ffmpeg 7:0.10.12-0yavdr0~precise Multimedia player, server, encoder and transcoder


    Stable:

    Code
    1. ii ffmpeg 4:0.8.17-0ubuntu0.12.04.1 Multimedia player, server, encoder and transcoder (transitional package)


    Jetzt habe ich meine HDD, die ich bis vor dem Umzug auf SSD verwendet habe, per USB gestartet


    Code
    1. [root@vdr03 ~]# pacman -Qs ffmpeg
    2. local/ffmpeg 1:2.5.2-2
    3. Complete and free Internet live audio and video broadcasting solution
    4. [root@vdr03 ~]# pacman -Qs vdr-softhddevice
    5. local/vdr-softhddevice 1:0.6.1rc1_32_ga3c0052-4
    6. software and GPU emulated HD output device plugin for VDR


    Damit kann ich wieder schneiden unter vdr4arch.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Hast du mal versucht das softhddevice Plugin neu zu bauen? ffmpeg 2.6.1 ist jünger als 2 Monate, als der Bau von softhddevice vermutlich das letzte Mal angestoßen wurde: https://github.com/VDR4Arch/vd…/plugins/vdr-softhddevice

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Um ganz sicher zu sein habe ich gerade eine Aufnahme von Das Erste HD und eine Aufnahme von VOX HD geschnitten.
    Alles ganz normal bei mir. Letztes Update von vor einer Stunde.


    Mach doch mal ein Downgrade auf ffmpeg 2.5.2 auf dem anderen System.
    Wenn es damit weg ist muss sich jemand bei johns beschweren. Dann muss er wieder nacharbeiten.

  • Neubau von softhddevice gegen das aktuelle ffmpeg wäre auch mein Favorit.
    Wenn da wieder jemand Schindluder mit den Headern getrieben hat (ABI geändert, ohne SO-Version hochzuzählen), dann hilft nichts anderes.


    Lars.

  • Mach doch mal ein Downgrade auf ffmpeg 2.5.2 auf dem anderen System.


    Dann startet der VDR nicht mehr.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Hast du mal versucht das softhddevice Plugin neu zu bauen?


    Ich habe das aktuelle SHD GIT und das Repo von vdr4arch jeweils neu gebaut mit der aktuellen Version von ffmpeg

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Musst du neu kompilieren auf die alte Version.


    Habe ich.


    Jetzt ist die Version drauf:

    Code
    1. [root@vdr03 ~]# pacman -Qs ffmpeg
    2. local/ffmpeg 1:2.5.2-2
    3. Complete and free Internet live audio and video broadcasting solution


    In meiner VM ist ebenfalls diese ffmpeg Version installiert (ebenfalls downgrade), dann das Build Verzeichnis von SHD geleert und neu gebaut. Dieses Paket installiert am VDR, startet trotzdem nicht....

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR