[gelöst] Hilfe!!! Hab meinen Konsolen-Font "xos4 Terminus" verloren!

  • Ich benutze unter openSUSE 13.2 das KDE "Konsole"-Fenster für Shells. Darin verwende ich den Font "xos4 Terminus" (der einzige, mit dem man arbeiten kann ;-).


    Seit letzter Nacht wird dieser Font nun nicht mehr verwendet, sondern ein anderer, der zu groß ist und außerdem kein fixed font ist. Jetzt suche ich schon den ganzen Tag nach meinem guten alten "xos4 Terminus" Font, und kann ihn einfach nicht mehr für das Konsole-Fenster einstellen. Ich habe noch einen Laptop, auf dem ich openSUSE zuerst installiert hatte, und auf dem ist alles noch in Ordnung (da wurden seit der Installation keine Updates mehr eingespielt). Ich habe alles unter /usr/share/*font* auf beiden Rechnern verglichen, und das ist alles vollkommen identisch. Auch in /etc gibt es keinen Unterschied zwischen den beiden Rechnern, was "terminus" betrifft. Der einzige Unterschied zwischen den beiden Maschinen findet sich in /var/cache/fontconfig. Da kommt der String "terminus" auf der "guten" Kiste in einer Datei vor, auf der "schlechten" nicht.


    Wenn ich im KDE "Configure Desktop/System Administration/Font Management" öffne, dann sehe ich auf der "guten" Maschine "xos4 Terminus", auf der "schlechten" nicht. Das Paket "terminus-bitmap-fonts" ist auf beiden PCs installiert. Es hat ja auch bis letzte Nacht wunderbar funktioniert. Ich vermute, daß ein Online-Update schuld an dieser Misere ist, dann kurz nach dem Update wollte ich ein Shell-Fenster öffnen und wurde mit dem falschen Font konfrontiert. Ich verstehe nur nicht, warum ich keinen diesbezüglichen Unterschied zwischen den beiden Maschinen finden kann, außer dem in /var/cache/fontconfig. Allerdings habe ich bereits 'fonts-config -f' gemacht, was leider nichts gebracht hat.


    Kann mir bitte jemand hier einen Tipp geben, was ich noch machen könnte, um diesen Font wieder in der Konsole verwenden zu können? Ohne den kann ich einfach nicht arbeiten...


    Klaus

  • In Arch Linux gibt es dafür extra eine Fontconfig Regel, die den Font aktiviert.
    Wenn ich das Buildscript für den Font so sehe, scheint diese Regel aber schon im Quellpaket mitgeliefert zu werden.


    BTW: So hübsch ist der Font aber auch nicht. Außerdem ein Bitmap Font...

  • 'fc-cache -f -v' hat leider nichts geholfen.


    Hier der Output davon, falls man da was sehen kann:


    /usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
    /usr/share/fonts/100dpi: caching, new cache contents: 398 fonts, 0 dirs
    /usr/share/fonts/75dpi: caching, new cache contents: 398 fonts, 0 dirs
    /usr/share/fonts/Speedo: caching, new cache contents: 0 fonts, 0 dirs
    /usr/share/fonts/Type1: caching, new cache contents: 29 fonts, 0 dirs
    /usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
    /usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
    /usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
    /usr/share/fonts/ghostscript: caching, new cache contents: 52 fonts, 0 dirs
    /usr/share/fonts/misc: caching, new cache contents: 136 fonts, 0 dirs
    /usr/share/fonts/truetype: caching, new cache contents: 115 fonts, 0 dirs
    /usr/share/fonts/uni: caching, new cache contents: 2 fonts, 0 dirs
    /usr/X11R6/lib/X11/fonts: skipping, no such directory
    /opt/kde3/share/fonts: skipping, no such directory
    /usr/local/share/fonts: skipping, no such directory
    /root/.local/share/fonts: skipping, no such directory
    /root/.fonts: skipping, no such directory
    Re-scanning /usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
    Re-scanning /usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
    /var/cache/fontconfig: cleaning cache directory
    /root/.cache/fontconfig: not cleaning non-existent cache directory
    /root/.fontconfig: not cleaning non-existent cache directory
    fc-cache: succeeded


    Klaus

  • Neu Installieren hat auch nichts gebracht (hatte ich im Übrigen auch schon probiert, allerdings nicht mit dem Link, den du gepostet hast).


    Weder kommt die Konsole mit dem gewünschten Font, noch erscheint er in "Configure Desktop/System Administration/Font Management", und auch in /var/cache/fontconfig taucht er nicht auf.


    Es ist zum Verzweifeln...


    Klaus

  • Das müsste ja testweise auch direkt gehen, oder?


    Code
    1. kls@falcon:/home/kls > xset fp+ /usr/share/fonts/
    2. xset: bad font path element (#9), possible causes are:
    3. Directory does not exist or has wrong permissions
    4. Directory missing fonts.dir
    5. Incorrect font server address or syntax


    Die Meldung kommt gleichermaßen auf beiden Maschinen.


    Klaus

  • Das wäre dann


    xset fp+ /usr/share/fonts/misc


    Damit kommt keine Fehlermeldung, aber helfen tut es auch nicht.
    Nur zur Sicherheit: nach solchen Befehlen mache ich immer alle Konsole-Fenster zu und öffne ein neues, damit auch sicher alle neuen Einstellungen greifen.


    Klaus

  • Siehst Du den Font denn mit xfontsel? (Font Problem oder KDE Problem)
    Was sind denn das für updates gewesen? zypper logfile?
    Hast Du snapper laufen und kannst checken was sich geändert hat bzw. ein snapshot booten?

    VDR1:ASRock Ion 3D 152B, Sundtek SkyTV Ultimate openSUSE Leap 42.2, VDR 2.4.0,
    VDR2: ASRock J4105-ITX, DVBSky S952, openSUSE Tumbleweed, VDR 2.4.0

    softhddevice/vaapidevice, DFAtmo, xmltv2vdr, tvscraper, tvguideng, VDRAdmin-AM (alles git)

  • Guter Tipp! Mit xfontsel sehe ich den Font.


    In /var/log/zypp/history habe ich das hier gefunden:


    2015-03-31 22:41:49|install|libbluedevil2|2.1-2.4.1|x86_64||repo-update|5fd834a7008c46f6df1d58c4dfbd92dc9d46e5af44395e28bce534fdda36d032|
    2015-03-31 22:41:50|install|libfreetype6|2.5.3-2.4.1|x86_64||repo-update|dde4d17cc1d046785a4a2c7bd703c695f73c7b961e2362c54e3d828717197b4c|
    2015-03-31 22:41:50|install|libfreetype6-32bit|2.5.3-2.4.1|x86_64||repo-update|951635a761d43e981071e275dc1f2da0e753aa2b65ad3e1a4aeff2c3d39565c0|
    2015-03-31 22:41:50|install|libgnutls28|3.2.18-8.1|x86_64||repo-update|940c15cf5bf79d0f5fd0a51efdd9c5b3d33fd73032b5b090d5b9af86dfc0ef97|
    2015-03-31 22:41:53|install|lvm2|2.02.98-43.21.1|x86_64||repo-update|5fafc98342bbabfb2613c79c570d8f8ebb1a247d7cb20667592e7d57ab286a7d|
    2015-03-31 22:41:55|install|timezone|2015b-16.1|x86_64||repo-update|6d99740197c2822de80cda34c5cf04852fd7d681adf9ded911b74a4542a888bb|
    2015-03-31 22:41:56|install|timezone-java|2015b-16.1|noarch||repo-update|0dcef74b3c450bea8a2e9cce0cba0668f8892fff4951aab5ced2cf3371b25d10|
    2015-03-31 22:41:58|install|bluedevil|2.1.1-2.5.1|x86_64||repo-update|45922d34ef785c9eadc08772bf73f699594913d7f0cb326f4de744fa0824306e|
    # 2015-03-31 22:42:14 libreoffice-4.3.6.2-12.3.x86_64.rpm installed ok
    # Additional rpm output:
    # Unknown media type in type 'all/all'
    # Unknown media type in type 'all/allfiles'
    #
    2015-03-31 22:42:14|install|libreoffice|4.3.6.2-12.3|x86_64||repo-update|963158f32a51385bb381b0e9e8f7a0b2ad6f9512dd58788959502154465e0cae|
    2015-03-31 22:42:14|install|ft2demos|2.5.3-2.4.1|x86_64||repo-update|071fbcb4864b01df87e55cea51d9a41f2d41c338cebb19c42ecb2db33cd286d4|
    2015-03-31 22:42:14|install|freetype2-devel|2.5.3-2.4.1|x86_64||repo-update|085698a87d06bf83f23be538a8cabb252e7ad1775e2f07f7b5e69ed4bdc9e8f2|
    2015-03-31 22:42:15|install|gnutls|3.2.18-8.1|x86_64||repo-update|c6f8d8484aa41fdc6b791e6b5f5c748214b5aca2bf22de5150f910333c0ff436|
    2015-03-31 22:42:15|install|bluedevil-lang|2.1.1-2.5.1|noarch||repo-update|c80feea3ed3fcfd04eb4d95cf3d775024951cacc4a342e57cf676f80ae633547|
    2015-03-31 22:42:17|install|libreoffice-calc|4.3.6.2-12.3|x86_64||repo-update|66421a76b1be2cb2ba9168e93beb277619ef135aef7047d38b5a684dad189956|
    2015-03-31 22:42:17|install|freetype2-devel-32bit|2.5.3-2.4.1|x86_64||repo-update|1ae938070e6304e1a27b2268260ccd3190cef4a222afa71817602f3fbed17e2a|
    # 2015-03-31 22:42:19 libvirt-client-1.2.9-20.2.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/libvirt-guests...
    #
    2015-03-31 22:42:19|install|libvirt-client|1.2.9-20.2|x86_64||repo-update|2bf38c585a944d9cf426f03923f01f8bfbed3042432097a5e14b8ba1164742d6|
    2015-03-31 22:42:19|install|libreoffice-icon-theme-galaxy|4.3.6.2-12.3|noarch||repo-update|d39d4a756db186529d5bd236cc3da0082d1ac568bf87b9cc3b5eaa8c7f70c133|
    2015-03-31 22:42:20|install|libreoffice-icon-theme-hicontrast|4.3.6.2-12.3|noarch||repo-update|11e0d8fd54ef101d1c72e090c17f45c71469da78829241dd5ab0fd7128c86c27|
    2015-03-31 22:42:21|install|libreoffice-icon-theme-oxygen|4.3.6.2-12.3|noarch||repo-update|03941722d88860f2daafc7a23957473e871c1bc2fe9b0270934638fadb98457c|
    2015-03-31 22:42:21|install|libreoffice-icon-theme-sifr|4.3.6.2-12.3|noarch||repo-update|5702246b7fbbf361873ec93a8bd34e59062ec0c78b8b85372eeb6fc2acb6e3d9|
    2015-03-31 22:42:23|install|libreoffice-l10n-en|4.3.6.2-12.3|noarch||repo-update|e8ccc6c9e183b448c0c58501a6df18536c59d815449fbdc48e3a8d19f09fba47|
    2015-03-31 22:42:23|install|libreoffice-base|4.3.6.2-12.3|x86_64||repo-update|67eb90f1635d69e5a92072ad908f2459b97a8ebafba8884cfdc91b17acb4ab65|
    2015-03-31 22:42:24|install|libreoffice-draw|4.3.6.2-12.3|x86_64||repo-update|2a7bc2dad0aced51806fe5c3bc2c7748b9a9d4fd6a1b70abc3a83238976a4193|
    2015-03-31 22:42:24|install|libreoffice-impress|4.3.6.2-12.3|x86_64||repo-update|8322c9ebbbb22d63e67ae52bc1462270793ca527f29db560ab4e63775a0308bd|
    2015-03-31 22:42:25|install|libreoffice-math|4.3.6.2-12.3|x86_64||repo-update|0d86e0604fe0e3352e6c0016087639d31d4a2d74bb6a01bf68482a2a46da7840|
    2015-03-31 22:42:26|install|libreoffice-writer|4.3.6.2-12.3|x86_64||repo-update|3e85126fb35acf4cdc037c7cfb652c0f1f0c3cf288cd68685b682b8e3b0474a8|
    2015-03-31 22:42:27|install|libreoffice-writer-extensions|4.3.6.2-12.3|x86_64||repo-update|23cd162c5b19eda6d35ea8b0d8b426cebaab05faa3f41f8d146e557b7f65121f|
    2015-03-31 22:42:28|install|libreoffice-pyuno|4.3.6.2-12.3|x86_64||repo-update|e107d6a51204479df6cb44bfd11e851d5dd98611f5485d426847e6773d77ee76|
    2015-03-31 22:42:28|install|libreoffice-kde4|4.3.6.2-12.3|x86_64||repo-update|7109c5730eab89451e714e7d58bb2b38e3b47505febe86282a5799cbbae585c2|
    2015-03-31 22:42:28|install|libreoffice-filters-optional|4.3.6.2-12.3|x86_64||repo-update|808ac065c98f856d5b359ae016c8e25f9d557b9cc2e87ba4670893e95ffd95de|
    2015-03-31 22:42:29|install|libreoffice-base-drivers-mysql|4.3.6.2-12.3|x86_64||repo-update|eb3560c07d99f33cb7cbbda16cd7f61a7a4175940612fa1bf9596f5a0385b6b4|
    2015-03-31 22:42:29|install|libreoffice-mailmerge|4.3.6.2-12.3|x86_64||repo-update|50b7028357be6afba0041d0cef6abf5c7b7e3f82fe231ad83c45c76bc518676a|
    2015-03-31 22:42:31|install|libreoffice-calc-extensions|4.3.6.2-12.3|x86_64||repo-update|716e90d9d649e84ab44f9e303fa25228206319b2564f72eda4269eda1150b0d0|
    # 2015-03-31 22:42:31 Output of lvm2-2.02.98-43.21.1.x86_64.rpm %posttrans script:
    # /usr/lib/module-init-tools/regenerate-initrd-posttrans: line 46: mkinitrd: command not found
    # 2015-03-31 22:42:31 lvm2-2.02.98-43.21.1.x86_64.rpm %posttrans script failed (returned 127)
    2015-03-31 23:43:31|install|libgd3|2.1.0-7.5.1|x86_64||repo-update|a1ad168644a49209280c2f5e9f1822fb2e767d225db5d968ac9d059a74d646c6|
    2015-03-31 23:43:31|install|gd|2.1.0-7.5.1|x86_64||repo-update|b10e1dc86c61e6444f2ea5c36c35cadb44a0866a5f8505feca6ff47dbf09a8cb|
    2015-04-01 00:35:46|install|terminus-bitmap-fonts|4.38-7.1.5|noarch|root@falcon|repo-oss|1bef3ac899174163a97cbe9cae4fd1a117d055fc|


    Der letzte Eintrag mit 'terminus-bitmap-fonts' war mein Versuch, den Font neu zu installieren, was aber leider ohne Erfolg blieb.


    Snapper habe ich nicht am laufen.


    3PO : 'xset -q' zeigt


    Font Path:
    /usr/share/fonts/misc:unscaled,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/ghostscript/,/usr/share/fonts/cyrillic:unscaled,/usr/share/fonts/truetype/,built-ins,/home/kls/.fonts,/usr/share/fonts/misc



    Also wenn xfontsel den Font kennt, "Configure Desktop/System Administration/Font Management", aber nicht, dann liegt das Problme wohl an KDE. Fragt sich nur, was es ist?


    Klaus

  • Anscheinend bin ich nicht der Einzige mit diesem Problem: http://lists.opensuse.org/open…ory/2015-04/msg00023.html


    Auf meinem "guten" Laptop bekomme ich


    > fc-match "xos4 Terminus"
    ter-112n.pcf: "xos4 Terminus" "Regular"


    auf dem "schlechten" PC dagegen


    > fc-match "xos4 Terminus"
    DejaVuSans.ttf: "DejaVu Sans" "Book"


    Leider gibt es in der openSUSE-Liste noch keine Lösung, daher hier mal die Frage, ob jemand etwas aus dem Ergebnis des 'fc-match' Aufrufs schließen kann, und vielleicht sogar eine Lösung parat hat.


    Klaus

  • Genau diese Ausgabe kommt bei mir auch. Klar, denn xos4 ist bei mir nicht installiert...


    Evtl. gibt's da irgendwo eine Einstellung, dass nur skalierbare (TTF-)Fonts verwendet werden sollen?


    CU
    Oliver