Intel DH67BL - Bios Chip flashen

  • Hallo,


    ich habe ein DH67BL mit Bios 0076 und wollte auf 0160 flashen. Der Updatevorgang lief an und dann ging der PC aus, seitdem laufen nur noch die Lüfter an. Kein Bios mehr.


    Der Grund ist das bei diesem Board zwingend ein "Zwischenschritt" nötig gewesen wäre auf 0132. Die Information stand nur im 0132 und nicht im 0160. Toll!


    Der Bios-Chip ist aufgelötet, müßte ein SOIC Bios Chip sein. Aus- und Einlöten ist kein Problem da SMD Lötequipment vorhanden ist.


    Kann mir einer von Euch diesen Chip wieder programmieren, bzw. kennt ihr jemanden der helfen kann?


    Typ des Chips:

    Code
    1. Winbond 25Q80BVSIG, Ersatztyp: 25X80BVSIG, 25X80AVSIG, 25X80VSIG

    Gruß utiltiy



    VDR Projekte VDR Projects

    The post was edited 1 time, last by utiltiy ().

  • Dieselbe ******* hatte ich mit meinem DP67DEB3 letztes Jahr auch. Allerdings hatte ich meines Erachtens alles richtig gemacht. Glücklicherweise war noch Garantie drauf und mir wurde das Board getauscht (per DHL Express nach Holland o.O). Auf dem Ersatzboard war natürlich das gleiche alte BIOS drauf. Man sollte meinen BIOS Updates sollten im Jahr 2015 problemlos laufen. Ich nehm jetzt jedenfalls Abstand von Intel BIOS Updates.


    Wie dem auch sei: Wenn du keine Garantie mehr hast, kannst du den Chip glaube ich auch per SPI on board flashen.

  • Den Intel "Tipp" habe ich probiert, ohne Erfolg. Ich komme da nicht um "aufwendiges" Flashen, wenn man es so beschreiben will nicht herum.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Danke, habe ich auch schon probiert.


    Hier sieht man den "Zwischenschritt"

    Gruß utiltiy



    VDR Projekte VDR Projects


  • Typ des Chips:

    Code
    1. Winbond 25Q80BVSIG, Ersatztyp: 25X80BVSIG, 25X80AVSIG, 25X80VSIG


    Bist Du Dir da sicher? Das ist nur ein 8MBit-Chip (1MByte). Das BIOS-File ist ca. 9MByte groß. Wenn Du den Chip neu programmieren willst, benötigst Du einen Chip von einem funktionierenden Board zum Auslesen. Das Update-File enthält nicht das vollständige BIOS. Du duplizierst dann allerdings das Board, da Seriennummer, MAC der Netzwerkkarete, ... im residenten Teil des BIOS enthalten sind.


    Gegebenenfalls kann ich Dir einen Chip auslesen und neu programmieren.


    Gruß
    e9hack

  • Ich hatte hier ähnliche Probleme mit dem BIOS.


    Nach dem ich dann alle (Ja, wirklich alle Bios Versionen an dem Auslieferungszustand!) der Reihe nach per Recovery Bios Update aufgespielt hatte ging es endlich. Ich denke dir wird auch nichts anderes übrig bleiben.
    Der Recovery Bios Update, mit gestecktem Jumper, scheint bei Intel die einzige Möglichkeit zu sein BIOS korrekt zu updaten. Und dabei ist es auch unbedingt wichtig, dass man kein Update überspringt!


    In deinem Fall solltest du versuchen zuerst einmal die letzte lauffähige BIOS-Version (0076) per Recovery Bios Update zu flashen. Damit sollte das Board dann eigentlich wieder booten.
    Und von da ab dann Version für per Recovery Bios Update updaten.


    Viel Erfolg, ich drücke die Daumen!

    Gruss
    SHF


  • Und dabei ist es auch unbedingt wichtig, dass man kein Update überspringt!

    Das stimmt beim DH67BL so nicht und Du verallgemeinerst Deine schlechten Erfahrungen mit einem einzigen Mainboard, dem DH77KC. Das habe ich btw. auch und hatte keinerlei Probleme bei einem der Updates, das Board läuft, und läuft, und läuft ...


    Einzig für das DH67BL benötigt es das Wissen um den Zwischenschritt, das Thema hatte ich hier schon mal vor Jahren beschrieben. Mit Version 0132 für das DH67BL wird in der Struktur der BIOS Software etwas verändert, was bei nachfolgenden Versionen nicht mehr angepasst, aber vorrausgesetzt wird. Ich lese gewissenhaft Service-Notes vor Updates, sollte eigentlich jeder tun, so auch bei diesem Board, habe mehrere davon im Einsatz. Die Umstände sind in der Note für 0132 (kurz) beschrieben. Es ist keineswegs nötig jede Version installieren zu lassen, wie auch nicht bei anderen Intel Mainbords, habe einige hier am laufen ...


    Das was "utiltiy" beschreibt ist bekannt wenn man den Zwischenschritt vergessen hat, gibt da einige Berichte in verschiedenen Foren. Einige Nutzer konnten das Mainboard tatsächlich mit dem BIOS Recovery wiederbeleben, bei mehr Nutzern war das Mainboard nimmer zu retten, hatten aber zu der Zeit noch Garantie von Intel drauf. Bisher hatte "utiltiy" ja kein Glück, wenn's mit der Ur-Version 0076 nicht klappt, kann ich nur hoffen das gute Stück hat noch was Garantie bei Intel ...


    Regards
    fnu

    HowTo: APT pinning

    The post was edited 3 times, last by fnu ().

  • als ich das DH77EB bekommen hatte, wollte ich das BIOS auf eine aktuelle Version flashen. Und saß dann vor einem Rechner, bei dem nichts mehr lief. Die Prozedur mit dem Jumper und dem Recovery-BIOS-Flash half. Das alte BIOS war zu alt; es wurde was geändert. Seitdem das neue BIOS drauf ist, könnte man auf diesen Schritt verzichten.

    neuer Client: intel DH77EB, G1620, 4GB, 80GB, GT610, yaVdr 0.5 (ubuntu 14.04, vdr 2.0.6, streamdev-client 0.6.1-git)
    neuer Server: intel DH77KC, G1620, 4GB, 30GB, yaVdr0.5 (ubuntu 12.04.5, vdr 2.0.6, streamdev-server 0.6.1-git)
    alter Server: Asus P5BP-E/4L (BIOS-Bugs ohne Ende, kein VT-d, ...), Xeon L3360, 8GB, 9,6TB, DVD-RW, Ubuntu 12.04 AMD64, Samba 3.6.3, vdr-1.7.27 (yavdr PPA), vdr-streamdev-server
    alter Client: Asus M3N78-EM, 5050e, 4GB, 320GB, 8400GS, DVD-RW, Ubuntu 10.04 AMD64, nvidia 295.75, vdr-1.7.27 (yavdr PPA), vdr-streamdev-client, xineliboutput...

  • Bist Du Dir da sicher? Das ist nur ein 8MBit-Chip (1MByte). Das BIOS-File ist ca. 9MByte groß.


    Was heißt sicher, das sind die Informationen wo ich mir zusammengesucht habe (siehe auch Link von 3PO zu Ebay, da ist auch so ein Chip "sichtbar"). Deine Nachfrage ist durchaus berechtigt. Wobei am MB eben dieser Chip vorhanden ist.


    fnu
    Danke für die Erläuterung zu dieser Sache beim DH67BL :tup


    Gruß utiltiy



    VDR Projekte VDR Projects

  • Das alte BIOS war zu alt; es wurde was geändert. Seitdem das neue BIOS drauf ist, könnte man auf diesen Schritt verzichten.

    Hmm, bei meinen zwei ist mir das noch nicht untergekommen, aber vmtl. habe ich auch keine so große Sprünge zw. den Versionen gemacht. IIRC ist aber in den Servicenotes zum DH77EB nichts dergleichen beschrieben ... ?


    utiltiy


    Sag, war beim BIOS Update eine zusätzliche Grafikkarte drin? Wenn ja, ausbauen und dann nochmal das BIOS Recovery mit 0076 *) versuchen. Sollte es dann je wieder laufen, ohne Grafikkarte weiter auf 0132 und dann auf 0160.


    Regards
    fnu


    *) Downloads

    HowTo: APT pinning

  • Sag, war beim BIOS Update eine zusätzliche Grafikkarte drin?


    Nein. Ich habe die Tipps bisher alle probiert.
    - Komponeten sind eh keine zusätzlichen verbaut im Moment
    - Batterie raus, warten
    - Batterie raus, warten, Jumper runter und USB Stick anstecken, PC einschalten und 10 min. warten
    - usw....
    - nichts, außer schwarzer Bildschirm und Lüfterlauf


    Neben dem CPU Sockel ist eine LED die nach kurzer Zeit, ich denke wenn er in den POST soll, rot leuchtet. Erst dachte ich es ist der Lüfter welcher eine LED hat den das Gehäuse ist neu hinzugekommen bei mir.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Es läuft einfach nicht zur Zeit....


    Ich habe nun meine beiden anderen VDR geöffnet die das selbe Board verbaut haben. Leider haben die einen:

    Code
    1. Winbond 25Q32BVSIG


    verbaut. Also 32M-Bit. Das defekte Board hat einen 8M-Bit. :§$%

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Also 32M-Bit. Das defekte Board hat einen 8M-Bit.

    Das "ge-Himmel-te" ist ja allerste Revision "-201", wie wir festgestellt haben.


    Was sind die anderen beiden? Stocking-ID: G10189-2xx ...


    Regards
    fnu

    HowTo: APT pinning

  • -205
    -211

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Hallo,


    das Board läuft wieder.


    Ein bekannter Hardwareentwickler hat den Biosbaustein aus einem meiner "ganzen" Boards ausgelesen und in "defekte" eingespielt.


    erster Test:
    - Board ist gestartet mit den "Daten" vom Clone mit SN, Rev. MAC usw.


    Doppelte MAC im gleichen Netz ist ohne ständiges zu tun auch nicht was mir gefallen hat


    also ran an das *.bin File und die entsprechenden Zeilen gesucht und angepaßt


    zweiter Test:
    - Board ist wieder gestartet mit den "Daten" wo dazu gehören


    Problem unter Linux war jedoch jetzt dass die Netzwerkkarte nicht initialisiert wurde. Im Log fand ich "The NVM Checksum is not valid", im Netz fand ich diverse Lösungsansätze von Kernelparameter bis Treiber "manipulieren" und dessen Check ausklammern. Das Problem hat übrigens nur Linux, bei Windows kommt das gar nicht zum tragen weil dort keine Abfrage vorhanden ist.


    Dann fand ich bei Intel ein Tool "Preboot" welches ich ebenfalls probiert habe. Die ersten Befehle haben die WOL Funktion aus- und eingeschaltet und irgendwie Einfluss auf die Logausgabe gehabt. Die "Checksum" Fehlermeldung war dann weg, die Karte lief aber immer noch nicht. Darauf fand ich versteckt den Befehlaufruf hier

    Code
    1. bootutil 32 -NIC=1 -DEFAULTCONFIG


    Nach dem nächsten Reboot lief die Netzwerkkarte wieder.


    Soweit so gut, irgendwas geht immer :]

    Gruß utiltiy



    VDR Projekte VDR Projects

    The post was edited 1 time, last by utiltiy ().