[rpihddevice] OSD mit GPU-Unterstützung und Pixmap-Support

  • Hi Uwe,
    Thomas hat heute einen Patch erstellt, der auch das softhddevice High-Level-OSD unterstützt. Vielleicht probierst Du den mal. Ich hatte zwischenzeitlich nichts daran gemacht und wollte mich eigentlich diese Woche mal daran setzen. Allerdings machen 2 Patches für dieselbe Sache wenig Sinn.


    Gruß, kanadakruemel

    VDR: 2.2.0, Intel DH67BL + i3 2120T + 4GB + 60GB SSD + 2TB Seagate ST2000DL003
    + CIR + DD Cine S2 V6 + ASUS ENGT520

  • Ja, ich habe das auch schon seit Ewigkeiten (fand es jetzt aber nicht so schlimm, dass ich dem nachgegangen bin). Ich benutze auch den Classic-Skin. Ich habe allerdings das Gefühl, dass es nicht senderspezifisch ist, sondern mal beim einen Sender, mal beim anderen Sender nicht funktioniert (vielleicht abhängig von den EPGs für die aktuelle und nächste Sendung). Und es ist bei mir auch so, dass die EPGs in der Senderübersicht ok sind, nur die Ansicht mit "OK"-Taste, oder beim Umschalten, wo man die laufende Sendung und die Sendung danach sieht, ist dann einfach ein grauer Kasten. Ich habe allerdings einen RPI2.


    Viele Grüße

  • Mein Raspberry Pi 2 läuft unter Arch Linux ARM. Mit einem selbst gebauten VDR 2.3.8, rpihddevice mit hardwarebeschleunigtem OSD habe ich keine Probleme mit den Skins Classic, STNG und LCARS bei der Darstellung der Kanalanzeige beim Umschalten. Der Empfang erfolgt über streamdev-client, der EPG kommt über epg2vdr.


    Der VDR wird bei der MLD ja recht umfangreich gepatcht - habt ihr das mal mit einem Vanilla-VDR probiert? Sind Leute betroffen, die etwas anderes als die MLD für den Raspberry Pi einsetzen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Also ich benutze kein MLD, nur selbst gepatchten VDR (deshalb habe ich auch nix gepostet, weil ich vermutet habe, dass es an irgendwas von mir liegt). :)

    Ich benutze allerdings auch kein streamdev und epg2vdr, sondern satip plugin und Inverto IDL-400s mit satip-axe (minisatip). Vielleicht liegt es ja an der Empfangsmethode?

  • Habe das eben nochmal nachgestellt.


    GPU Unterstützung ist an (rpihddevice.AcceleratedOsd = 1)


    Auf 3Sat HD wird keine Programminfo angezeigt.

    Das läuft aktuell und wird auch unter Programm angezeigt:

    Nur die Programminfo welche nach dem Umschalten oder beim drücken von ok kommt - ist leer.

  • Stimmt denn die Systemzeit? Nicht dass der Raspberry sich gerade in die 70er zurückversetzt fühlt...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi, habe das Problem auch schon länger, habe das umgangen in dem ich den Skindesigner installiert hab. Das Problem kam mit einem dem letzten rpihddevice updates rein. (Wie gesagt ist schon länger.) Habe das aber auch nicht weiter verfolgt. Ist auch nur beim Classic Skin alle anderen funktionieren.

    CPU: AMD Athlon x2 240e Mainboard: MSI 770-C45
    DVB: KNC-ONE DVB-C, Technotrend 1501 DVB-C, Technisat Airstar2 DVB-T
    Gehäuse: Thermaltake DH102, Windows MCE-Remote an IMON
    Grafikkarte: Gainward nVidia GeForce GT210 Grafikkarte, Sound über HDMI