[gelöst] Q1900 macht kein ACPI-Wakeup

  • Ich dachte eigentlich langjährige ACPI-Wakeup-Erfahrung mit verschiedensten Boards zu haben, aber irgendwie will mein Q1900M nicht aufwachen:


    ...und es wacht nicht auf.
    Im BIOS steht Wakeup nach RTC auf "per Betriebssystem", ich hatte es auch schon auf "Deaktiviert", aber es ändert sich nichts.
    Hat jemand eine Idee?

  • Mein Q1900M wacht problemlos auf, wie auch mein D1800M in Tests, musste nix dazu tun ...


    Regards
    fnu

    HowTo: APT pinning

  • Hat jemand eine Idee?


    Jo. Im BIOS RTC UND DeepSleep (o.Ä.) aus. HPET spielt keine Rolle.


    Albert

  • HPET spielt keine Rolle.

    Es gibt auch Intel basierte Mainboards wo das sehr wohl ein Rolle spielt ... hatte selbst eines von MSI ...


    rüsseltier
    "ACPI_HPET_table" ist bei mir aber "enabled" ...


    Regards
    fnu

    HowTo: APT pinning

  • Im BIOS RTC UND DeepSleep (o.Ä.) aus. HPET spielt keine Rolle.


    RTC hatte ich schon auf deaktiviert (siehe mein erstes Posting), ohne Änderung.
    Deep S5 war und ist deaktiviert.
    HPET habe ich nun wieder angemacht.


    Jetzt wird es aber ganz schräg - egal was ich an wakealarm an timestamps übergebe (+25 minutes, +15 minutes), bei alrm_time steht immer die aktuelle Uhrzeit + 5 Minuten:

  • So sieht übrigens meine proc/acpi/wakeup aus:

    Code
    1. Device S-state Status Sysfs node
    2. PS2K S4 *enabled pnp:00:07
    3. UAR1 S4 *disabled pnp:00:08
    4. XHC1 S4 *enabled pci:0000:00:14.0
    5. PXSX S4 *disabled
    6. PXSX S4 *disabled
    7. PXSX S4 *disabled
    8. PXSX S4 *disabled
    9. PWRB S0 *enabled


    Normal oder fehlt da ein Eintrag fü die RTC?

  • Das wird immer kurioser - aus +80min werden +20 min:

  • Langsam hege ich den Verdacht, dass das ein UTC-Konvertierungsproblem ist (80-60=20).


    Bevor die Frage kommt: das System läuft auf localtime wegen einem Dualboot-Windows.


    In der /etc/default/rcS habe ich UTC=no stehen.
    Warum wird dann selbst beim echo eines harten Timestamps in /sys/class/rtc/rtc0/wakealarm eine Stunde abgezogen?

  • das System läuft auf localtime wegen einem Dualboot-Windows


    Das wird so nichts. Stelle UTC in BIOS ein und sorge dafür, dass winzigweich damit auch klar kommt. Das geht.


    Albert

  • Hi,


    könnte jemand mit einem Q1900M mal bitte die Einstellungen angeben, finde kein HPET oder so... bei mir ist auch kein BIOS sondern eine UEFI FW drauf. Oder kann man das irgendwo umstellen, das habe ich aber auch nicht gesehen.

    Gruß Martin (linuxdep)

  • könnte jemand mit einem Q1900M mal bitte die Einstellungen angeben, finde kein HPET oder so... bei mir ist auch kein BIOS sondern eine UEFI FW drauf. Oder kann man das irgendwo umstellen, das habe ich aber auch nicht gesehen.


    HPET spielt hier keine Rolle. Im BIOS oder nenne es UEFI FW die Zeit gaaanz einfach eine Stunde zurücksetzen. Wenn wir also jetzt 22:55 haben, dann im BIOS/ UEFI FW die Uhr auf 21:55 stellen. ;-)


    Edit: Wenn Du aus welchem Grund immer HPET unbedingt abschalten willst, dann tust Du es über grub.


    Albert

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von ATD ()

  • Mein Q1900M wacht problemlos auf, wie auch mein D1800M in Tests, musste nix dazu tun ...

    fnu

    Falls du das Q1900 noch am laufen hast, könntest du mal deine Wakeup Einstellungen posten? Meins wacht auch nicht auf...

    Danke

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • Dumpfbacke


    Keine Änderungen im BIOS/EFI, aber HPET unter Ubuntu ausgeschaltet:

    Code: /etc/default/grub
    1. ...
    2. GRUB_CMDLINE_LINUX="hpet=disable"
    3. ...

    Cheers

    fnu

    HowTo: APT pinning

  • Der Grub Eintrag hat leider nichts gebracht.

    Ich habs jetzt mal im Bios abgeschaltet, alle Wakeup-Einträge auf Off gesetzt und RTC auf "by OS", damit scheint es zu funktionieren.

    Ich beobachte mal.....

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)