SkinDesigner 0.1.2 - BlackHole

  • Jepp das war es :)

    Gruß utiltiy



    VDR Projekte VDR Projects

  • @vectra: hast du es denn mal ganz ohne Patches versucht? Vielleicht liegt es auch an einer Einstellung im VDR oder an einem anderen Plugin?! Wenn es ohne Patches immer noch crasht dann wäre das wohl so.


    Da die Crashes mit dem extrecmenu und dem remotetimers Plugin quasi identisch sind, muss da noch irgendwas anderes von außen reinspucken. Schon recht seltsam die Sache...wenn ich den Crash reproduzieren könnte, könnte ich ihn sicherlich auch fixen. Vielleicht magst du ja noch ein bisschen forschen ;)


    Ciao Louis

  • Was mir noch auffällt:
    In der Kanalmenüdarstellung werden rechts unten die nächsten Programme durchgescrollt.
    Es fehlt aber am Anfang die direkt nachfolgende Sendung.
    Also zeigt der Index start auf die übernächste Sendung, und nicht auf die nächste. Deshalb fehlt diese.


    Ob dies ein gewollt ist oder ein Bug weiß ich nicht ?


    Als workaround habe ich diese manuell also vor der loop eingefügt.

    Files

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • Wenn ich mit nem Vanilla VDR und den vorhandenen Plugins teste dann klappt es. Das hatte ich ja gestern wo ich unterwegs war getestet. Was mich stört das der Absturz erst nach dem dritten Patch kam. Ich teste das nachher mal nur mit dem Mainmenuhooks und menuselection.


    Wenn es dann crasht dann schalte ich mal Plugins ab und ersetze die Setup.conf


    Aber dann brauch ich erst mal wieder neue Tipps ;D :rolleyes:

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-) *


    vectra --- glasslike ---

  • Ob dies ein gewollt ist oder ein Bug weiß ich nicht ?


    Das ist ein Bug, das muss ich noch fixen...


    Ciao Louis

  • @vectra: ok, zumindest läuft es ohne Patches. Ich hab dir mal die Patches die ich mit Gen2Vdr verwende angehängt...mit denen funktioniert es.


    Ciao Louis

  • In der "displaymenudetailrecording.xml" wird hier:


    Code
    1. <tab name="Info" x="2%" y="11%" width="48%" height="78%" layer="3" scrollheight="{areaheight}/4">
    2. <drawtext x="0" y="0" font="{semibold}" fontsize="6%" color="{clrWhite}" text="{date} {time} ({duration} mins)" />
    3. <drawtext x="0" y="6%" font="{semibold}" fontsize="9%" color="{clrWhite}" text="{name}" />
    4. <drawtext x="0" y="14%" font="{regular}" fontsize="7%" color="{clrWhite}" text="{shorttext}" />
    5. <drawtextbox condition="not{isseries}++not{ismovie}" x="0" y="22%" width="96%" font="{regular}" fontsize="5%" color="{clrWhite}" text="{description}" />
    6. <drawimage condition="{isseries}" name="seriesposter" imagetype="image" path="{seriesposter1path}" x="{areawidth}*0.7" y="17%" width="{areawidth}*0.3" height="{areawidth} * 0.38 * {seriesposter1height} / {seriesposter1width}"/>
    7. <drawimage condition="{ismovie}" name="movieposter" imagetype="image" path="{posterpath}" x="{areawidth}*0.7" y="17%" width="{areawidth}*0.3" height="{areawidth} * 0.38 * {posterheight} / {posterwidth}" />
    8. <drawtextbox condition="{isseries}" x="0" y="22%" width="96%" float="topright" floatwidth="{width(seriesposter)} + 10" floatheight="{height(seriesposter)} + 20" font="{regular}" fontsize="5%" color="{clrWhite}" text="{description}" />
    9. <drawtextbox condition="{ismovie}" x="0" y="22%" width="96%" float="topright" floatwidth="{width(movieposter)} + 10" floatheight="{height(movieposter)} + 20" font="{regular}" fontsize="5%" color="{clrWhite}" text="{description}" />
    10. </tab>


    der Bereich definiert wo das Poster und Text gezeichnet wird.


    Falls kein Poster vorhanden ist aber dafür ein "Cover-Enigma.jpg" wie bindet man dass dann optional ein?

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Du machst unter die zwei "<drawimage" ein weiteres mit

    Code
    1. condition="not{isseries}++not{ismovie}"

    mit deinem Bild

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-) *


    vectra --- glasslike ---

  • Im Tabelement gibt es aber den Token "{recimgpath}" nicht...


    Gruß utiltiy



    VDR Projekte VDR Projects

  • Ach, ich dachte dein Cover-Enigma.jpg wäre dann einfach als ein "Platzhalter" Cover gedacht.
    Dann kann dir da nur Louis helfen ;D

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-) *


    vectra --- glasslike ---

  • Das ist ein Bug, das muss ich noch fixen...


    Ist jetzt im Git gefixt, ich habe auch noch gleich die laufende Sendung mit hinzugenommen.


    Ciao Louis

  • @utility: aber es gibt die Tokens


    Code
    1. {recimg1avaialble} true if first recording image is available
    2. {recimg2avaialble} true if secondrecording image is available
    3. {recimg3avaialble} true if third recording image is available
    4. {recimg1path} path of first recording image
    5. {recimg2path} path of second recording image
    6. {recimg3path} path of third recording image


    Es werden die ersten drei Dateien aus dem Recording Folder genommen, die auf jpg enden...


    Ciao Louis

  • Danke, funktioniert :tup Hab dass dann noch im Detail EPG zusätzlich ergänzt :)


    Wie macht man das wenn der Text länger ist damit er gescrollt wird?

    Code
    1. <tab name="EPG Info" x="2%" y="11%" width="48%" height="78%" layer="3" scrollheight="{areaheight}/4">
    2. .....
    3. <drawtext x="0" y="6%" width="100%" font="{semibold}" fontsize="9%" color="{clrWhite}" text="{title}" />
    4. <drawtext x="0" y="14%" width="100%" font="{regular}" fontsize="7%" color="{clrWhite}" text="{shorttext}" />
    5. .....
    6. </tab>

    Gruß utiltiy



    VDR Projekte VDR Projects

    The post was edited 2 times, last by utiltiy ().

  • Kann auch nur sagen, klasse Skin, den du mit BlackHole gebastelt hast.


    Was bei mir nicht funktioniert, die Temperaturanzeige von CPU und Grafik. Beide auf 0.
    Bei der Wiedergabe von Aufzeichnungen ist die Anzeige der Symbole für Play
    Stop und Skipvor und Zurück nicht gut zu erkennen (dunkelblau und rot auf schwarz)


    Ich vermisse auch die Balken für die Sat-Anzeige, könnte man die rechts neben den Infos
    unten mit einbauen?
    An die grosse Schrift muss man sich erstmal gewöhnen, aber dann siehts alles super aus.


    Weiter so

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Was bei mir nicht funktioniert, die Temperaturanzeige von CPU und Grafik. Beide auf 0.


    Das muss ggfs. angepaßt werden.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Zitat von »dxwilli« Was bei mir nicht funktioniert, die Temperaturanzeige von CPU und Grafik. Beide auf 0.
    Das muss ggfs. angepaßt werden.



    Das muss ggfs. angepaßt werden.


    wenn ich wüsste, wie, gern. Leider sind dazu meine Kenntnisse nicht die besten X(

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • wenn ich wüsste, wie, gern. Leider sind dazu meine Kenntnisse nicht die besten


    Mach am besten einen neuen Thread dazu auf, mit den Infos ob du das Paket lm-sensors installiert hast und welches System du verwendest.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Ich vermisse auch die Balken für die Sat-Anzeige, könnte man die rechts neben den Infos


    unten mit einbauen?


    An die grosse Schrift muss man sich erstmal gewöhnen, aber dann siehts alles super aus.

    Das Schöne am SkinDesigner ist ja, das man sich ohne durch den C++ Code zu wühlen helfen kann.


    Hier ist die XML mit Anzeige der Signalstärke in Prozent,für ein Balkenanzeige war ich bisher zu faul.
    Es gibt wohl einen anderen Skin wo man dies klauen kann, also ohne selbst nachdenken zu müssen.


    Wegen der großen Schrift vermute ich fehlende Schrifarten in deinem System. Der Log würde Auskunft geben.
    Aber wie schon gesagt, mach einen eigenen Thread auf.

    Files

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • danke, Prozentanzeige gefunden :-)

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Ich finde den Skin auch super. Was mich jedoch noch stört ist der zu geringe Kontrast der Progress Balken bei der epg Ansicht und beim abspielen einer Aufnahme. Zwischen abgelaufen und Gesamtanzeige ist kaum ein Unterschied zu erkenne. Wie kann man das ändern ? Geht das überhaupt über xml?

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D