Kanal der X10 Fernbedienung im YaVDR umschalten

  • Hallo Ihr listigen,


    offensichtlich bin ich zu doof die Anleitungen zu verstehen.
    Der VDR läuft super, aber das mit der Kanalumschaltung verstehe ich nicht.


    Die Fernbedienung umzuschalten ist ja leicht.


    Was mir nicht gelingt, ist die Stelle zu finden, wo ich die neue Maske eintragen kann.


    In der Anleitung steht:

    Code
    1. Dazu ist z.B. ein Eintrag in der /etc/modules.conf notwendig:
    2. options lirc_atiusb mask=0xffff


    ... aber die modules.conf gibt es nicht.
    Wo soll ich also die entsprechnde Maske eintragen?
    Aktuell reagiert der VDR auf jeden Kanal den ich eingeschaltet habe.


    Diese Anleitung funktioniert bei mir nicht:
    Link

    Einen schönen Gruß aus dem Bergischen Land
    Der Watz
    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, twinlux dvb s2, X10 und Lenovo N5901 Bilder
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, DVBSKy S952 Dual , Medion X10
    – MediaPortal QDI SF-FF DVB-S/ NOVA-T – g2v 1.4, 1 GHz P3; 256 MB RAM; 160 GB HD
    [/size]– 3 x Gbit Switch; DSL-16000 kbit mit AVM-7490

  • Das Modul heißt ati_remote und die Option dafür kommt am besten in eine Datei wie /etc/modprobe.d/ati_remote.conf (siehe auch http://wiki.ubuntuusers.de/Ker…Module-mit-Optionen-laden ):

    Code
    1. options ati_remote channel_mask=65533

    - da gibt es auch einen alten Thread dazu, wo erklärt wurde, wie man die channel_mask errechnet: 0.4.0pre1 Pollin X10 und Funkkanäle

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk1986,
    Endlich habe auch ich es, dank Deiner Hilfe geschafft.
    Vielen Dank dafür.
    Hätte ich niemals alleine hin-bekommen.


    Für Kanal 4 habe ich jetzt auf dem ersten VDR:

    Code
    1. echo "options ati_remote channel_mask=65519" | sudo tee /etc/modprobe.d/ati_remote.conf


    in die Konsole eingegeben.


    Dieser Befehl legt im Verzeichnis:

    Code
    1. /etc/modprobe.d/


    die Datei:

    Code
    1. ati_remote.conf


    mit dem Inhalt

    Code
    1. options ati_remote channel_mask=65519


    an.


    Nach einem Neustart wird die Datei ausgeführt und
    es steht nur noch der gewählte Kanal zur Verfügung.
    Die Einstellung der FB ist an vielen Stellen ausreichend gut beschrieben.


    -S Setup-Taste gedrückt halten bis die LED leuchtet.
    -Taste loslassen und Kanal über die Ziffern auswählen.
    -Danach wieder die Setup-Taste drücken.
    -Die Kanalnummer wird von der LED danach angezeigt.


    Viele werden das Problem wohl nicht haben,
    doch spätestens beim nächsten Update, werde ich diese Zeilen wieder benötigen.


    Für Kanal 6:

    Code
    1. echo "options ati_remote channel_mask=65471" | sudo tee /etc/modprobe.d/ati_remote.conf


    Und jetzt reagiert jeder VDR nur noch auf einen (anderen) Kanal.
    Das klappt zumindest bei meinem aktuellen YaVDR 0.5 ohne Probleme.


    Aus den bestehenden Beschreibungen wurde ich nämlich nicht schlau.

    Einen schönen Gruß aus dem Bergischen Land
    Der Watz
    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, twinlux dvb s2, X10 und Lenovo N5901 Bilder
    – yaVDR 0.5, Gehäuse C581, 330N DualCore IONITX Zotac, DVBSKy S952 Dual , Medion X10
    – MediaPortal QDI SF-FF DVB-S/ NOVA-T – g2v 1.4, 1 GHz P3; 256 MB RAM; 160 GB HD
    [/size]– 3 x Gbit Switch; DSL-16000 kbit mit AVM-7490

    The post was edited 1 time, last by Watz ().