remoteosd konfigurieren: Remote menu not available - Connection failed

  • Hallo Zusammen,


    kann mir vielleicht jemand weiterhelfen. Ich habe auch meinem Raspberry folgendes installiert:


    Der Server ist ein Debian-linux mit

    Code
    1. vdr (1.7.28/1.7.28) - The Video Disk Recorder
    2. svdrposd (0.1.1) - Publish OSD menu via SVDRP
    3. xineliboutput (1.0.90-cvs) - X11/xine-lib output plugin
    4. streamdev-server (0.6.0) - VDR Streaming Server


    Beim Versuch, das Osd des Servers aufzurufen, bekomme ich obige Fehlermeldung: Remote menu not available - Connection failed


    syslog vom raspi sagt folgendes:
    rpihddevice: set video codec to MPEG2

    Code
    1. Aug 24 18:05:10 raspberrypi vdr: [2562] rpihddevice: decoding video 720x576i, enabling deinterlacer
    2. Aug 24 18:05:16 raspberrypi vdr: [2552] loading /var/lib/vdr/themes/lcars-default.theme
    3. Aug 24 18:05:16 raspberrypi vdr: [2552] svdrpservice: Error connecting to 192.168.0.39:2001: Connection refused
    4. Aug 24 18:05:16 raspberrypi vdr: [2552] loading /var/lib/vdr/themes/lcars-default.theme


    während auf dem Server ein
    tail -n 150 /var/log/syslog | grep -i 6419

    Code
    1. Aug 24 18:04:11 vdr4 vdr: [3549] SVDRP listening on port 6419


    ergibt.


    In der Setup.conf auf dem raspi ist aber folgendes eingetragen:

    Code
    1. svdrpservice.ConnectTimeout = 5
    2. svdrpservice.ReadTimeout = 6
    3. svdrpservice.ServerIp = 192.168.0.39
    4. svdrpservice.ServerPort = 6419


    Sollte svdr auf dem Raspi nicht versuchen, eine Verbindung auf 6419 herzustellen? Aus dem Syslog des Raspis sehe ich jedoch: Aug 24 18:05:16 raspberrypi vdr: [2552] svdrpservice: Error connecting to 192.168.0.39:2001: Connection refused, also versucht er es unter port 2001?


    Was ist hier falsch?


    Ich wäre für jede Hilfe dankbar.

  • In den settings des remoteosd plugins server IP und server Port jeweils auf 0 stellen, dann übernimmt das Plugin auch die Parameter vom svdrpservice Plugin.

  • Schau mal in die /var/lib/vdr/svdrphosts.conf des Servers - da muss der Zugriff für die IP bzw. das Subnetz in dem der Client sitzt freigegeben sein - siehe auch http://www.vdr-wiki.de/wiki/index.php/Svdrphosts.conf

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Code
    1. Aug 24 18:05:16 raspberrypi vdr: [2552] svdrpservice: Error connecting to 192.168.0.39:2001: Connection refused


    Es hätte schon gereicht im Plugin den Port richtig zu setzen, statt 2001 die 6419!


    Aber klar mit der 0 in beiden Feldern hat man nur eine Stelle zum schrauben - ist einfacher.


    btw.: mir ist schleierhaft warum immer noch der 2001 als default Port gesetzt wird - hat wohl noch niemand für fixenswert gehalten ;D


    Grüße


    Magicdragon67