PC wacht nicht für Aufnahmetimer auf

  • Guten Morgen zusammen,

    ich bin mittlerweile ein wenig ratlos, habe alles was ich hier im Forum und an anderen Stellen lesen konnte schon ausprobiert.


    Folgendes Problem:
    Jeglicher Aufnahme-Timer wird von PC völlig verschlafen und ich kann mir nicht erklären wieso. Timer-Vorlauf steht auf 5 Minuten.


    Vom Verständnis her würde ich ja behaupten dass der VDR einen Alarm für die entsprechende Uhrzeit anlegt der dann mit der Systemzeit abgeglichen wird und dann ein Aufwachsignal sendet.


    Kann ich irgendwas posten was zur Ursachenforschung beitragen kann?


    Ausgeschaltet wird per Fernbedienung. Eingestellt ist "Suspend to RAM". Das aufwachen per "Wake On Lan" und per Fernbedienung (USB) funktioniert einwandfrei. Ich hoffe zum Setup steht genug in meiner Signatur.


    Danke schonmal

    Software: yavdr 0.5.0a
    Gehäuse: Techsolo TC-400 HTPC
    Mainboard: ASUS E45M1-PRO (AMD APU E-450 Dual-Core, AMD FCH A50M (Hudson M1))
    Ram: 8 GB DDR3 Dual-Channel
    Grafik: Zotac GeForce GT 630 ZONE Edition 2GB
    TV-Karte: Hauppauge WinTV Nova-HD-S2
    Remote: Hama MCE

    The post was edited 1 time, last by phil1983 ().

  • Vom Verständnis her würde ich ja behaupten dass der VDR einen Alarm für die entsprechende Uhrzeit anlegt der dann mit der Systemzeit abgeglichen wird und dann ein Aufwachsignal sendet.


    Kann ich irgendwas posten was zur Ursachenforschung beitragen kann?

    Das setzen der Zeit kannst du normalerweise direkt im Syslog beobachten - wenn das vdr-addon-acpiwakeup die Aufwachzeit setzt, sieht das z.B. so aus:

    Code
    1. Aug 19 20:58:47 VDR vdr-addon-acpiwakeup: Setting ACPI alarm time to: 2014-08-20 02:38:00
    2. Aug 19 20:58:47 VDR vdr-addon-acpiwakeup: Writing to /sys/class/rtc/rtc0/wakealarm
    3. Aug 19 20:58:47 VDR vdr-addon-acpiwakeup: Writing to /sys/class/rtc/rtc0/wakealarm


    Die Empfehlung bei AMD-Mainboards hpet=disable als Boot-Parameter zu nutzen hast du schon ausprobiert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986... Der Name hat sich lustigerweise schon eingeprägt bei den Recherchen :-)


    Davon hatte ich im VDR Wiki über das Thema ACPI-Wakeup gelesen.


    Quote

    ACPI Wakeup
    Das kann einfach in der Datei /etc/vdr/vdr-addon-acpiwakeup.conf aktiviert werden, mit etwas Glück funktioniert es dann schon. Man sollte die Rechnerzeit unbedingt auf UTC stehen haben (siehe /etc/default/rcS), damit die yaVDR Skripte funktionieren. Häufig ist es noch notwendig, die Funktion HPET (high precision event timer) im BIOS abzustellen, auch die Emulation dem Kernel per GRUB_CMDLINE_LINUX_DEFAULT="hpet=disabled" in /etc/default/grub (danach aufrufen: update-grub) zu verbieten sowie das Setzen der hwclock beim shutdown zu unterbinden (/etc/init/hwclock-save.conf). Allgemeine Informationen sind im Artikel ACPI Wakeup zu finden.


    Aber ich sehe gerade ich habe glaube ich das "update-grub" vergessen. Das werde ich heute Abend nochmal testen. Das wäre ja der Hammer wenn das jetzt das Problem war =(

    Software: yavdr 0.5.0a
    Gehäuse: Techsolo TC-400 HTPC
    Mainboard: ASUS E45M1-PRO (AMD APU E-450 Dual-Core, AMD FCH A50M (Hudson M1))
    Ram: 8 GB DDR3 Dual-Channel
    Grafik: Zotac GeForce GT 630 ZONE Edition 2GB
    TV-Karte: Hauppauge WinTV Nova-HD-S2
    Remote: Hama MCE

  • Habe mir beim Basteln den Rechner zerlegt und jetzt nochmal von vorne angefangen. Da ich meist nur am Wochenende Zeit habe kann ich das frühstens nachher testen. Nicht denken ich hätte das gelesen und mich nicht mal bedankt wenn es das Problem war =)

    Software: yavdr 0.5.0a
    Gehäuse: Techsolo TC-400 HTPC
    Mainboard: ASUS E45M1-PRO (AMD APU E-450 Dual-Core, AMD FCH A50M (Hudson M1))
    Ram: 8 GB DDR3 Dual-Channel
    Grafik: Zotac GeForce GT 630 ZONE Edition 2GB
    TV-Karte: Hauppauge WinTV Nova-HD-S2
    Remote: Hama MCE