[GELÖST] Ubuntu Server 14.04 - Netzwerk nachträglich einrichten

  • Hallo,


    folgendes Problem.
    Bei der Installation von Ubuntu Server 14.04 hatte ich noch kein Netzwerkkabel dran weswegen zu dem Zeitpunkt auch kein Netzwerk konfiguriert wurde.
    Nach der Installation habe ich für eth0 eine entsprechende udev-rule erstellt (/etc/udev/rules.d/70-presistent-net.rules) und die interface config wie üblich eingerichtet. Doch leider wird nach einem reboot weiterhin kein Netzwerk/Interface eingerichtet.


    ifconfig -a zeigt nur ein device namens "p6p1" mit der mac der NIC.


    Hat jemand einen Tipp wie man das eingerichtet bekommt?



    Gruss
    tec

    The post was edited 1 time, last by tecfreak ().

  • Code
    1. GRUB_CMDLINE_LINUX=”biosdevname=0″


    ...und schon wird aus dem "p6p1" ein "eth0" device wie es auch in den udev-rules definiert ist.


    Was haben die sich nur dabei gedacht ... :wand


  • Nach der Installation habe ich für eth0 eine entsprechende udev-rule erstellt (/etc/udev/rules.d/70-presistent-net.rules) und die interface config wie üblich eingerichtet. Doch leider wird nach einem reboot weiterhin kein Netzwerk/Interface eingerichtet.


    Gruss
    tec


    Entferne doch mal deinen selbst erstellten Eintrag. Dieser sollte doch Automatisch erzeugt werden!


    vdr-box

  • Der Eintrag wurde nicht automatisch erstellt als ich das System zum ersten mal hochgefahren habe, daher habe ich die udev-rule selber angelegt. Da hat sich wohl bei Ubuntu auch was geändert. Wahrscheinlich greift da irgendeine Regel aus /lib/udev/rules.d/ .
    Nun ist aber wieder alles so wie ich es gewohnt bin.

  • Der Eintrag wurde nicht automatisch erstellt als ich das System zum ersten mal hochgefahren habe, daher habe ich die udev-rule selber angelegt. Da hat sich wohl bei Ubuntu auch was geändert. Wahrscheinlich greift da irgendeine Regel aus /lib/udev/rules.d/ .
    Nun ist aber wieder alles so wie ich es gewohnt bin.


    Nun gut, sehe ich zwar anders, da

    Code
    1. # This file was automatically generated by the /lib/udev/write_net_rules
    2. # program, run by the persistent-net-generator.rules rules file.
    3. #
    4. # You can modify it, as long as you keep each rule on a single
    5. # line, and change only the value of the NAME= key.

    diese nun mal nicht umsonst in der

    Code
    1. /etc/udev/rules.d/70-persistent-net.rules

    steht.


    vdr-box

  • Auf meiner Desktop Installation der 14.04 ist es auch so wie du es schreibst, aber mit der 14.04 Server Installation wurde diese Datei nicht angelegt. Könnte ja auch daran liegen, dass ich bei der Installation die Netzwerkkonfig übersprungen habe weil da noch das LAN Kabel nicht dran war.