TBS 6981 / Ubuntu 14.04 / Treiber / Aktiv ? Inaktiv ? im Kernel ?

  • Namt,


    ich stelle grad mein xbmc/vdr Server von Ubuntu 12.04 und XBMC eden auf Ubuntu 14.04 gotham (13) um. lt. Infos im Netz ist die TBS 6891 DVB-S2 Karte treiberseitig im System vorhanden wenn die Datei /dev/dvb/adapter(0und1) vorhanden sind. Das bedeutet, dass der Treiber im 3.13ner Kernel integriert ist. Der VDR läuft auch zeigt im VDR-live Plugin auch Sender an. Scanne ich allerdings per w-scan die Transponer findet der w-scan nichts. der VDR kann keine lock auf ein Sender vollziehen. Hat jmd ähnliche Probleme oder sogar vllt schon ne Lösung dafür ? Gibt es eine andere Möglichkeit außer mit w-scan zu prüfen ob der Treiber richtig geladen ist oder dir Firmware vorhanden ist ( wobei allerdings wie oben gesagt die beiden Sat Receiver im System registriert sind ?( )


    Das sieht eigentlich soweit gut aus :


    Code
    1. dmesg | grep DVB
    2. [ 15.283129] DVB: registering new adapter (cx23885[0])
    3. [ 15.283133] cx23885 0000:03:00.0: DVB: registering adapter 0 frontend 0 (Conexant CX24117/CX24132)...
    4. [ 15.283450] DVB: registering new adapter (cx23885[0])
    5. [ 15.283453] cx23885 0000:03:00.0: DVB: registering adapter 1 frontend 0 (Conexant CX24117/CX24132)...


    PS : müsste der 2te Adapter nicht ein ein frontend 1 haben ?



    EDIT :

    Code
    1. [ 1175.316292] cx23885 0000:03:00.0: Direct firmware load failed with error -2
    2. [ 1175.316297] cx23885 0000:03:00.0: Falling back to user helper
    3. [ 1175.317528] i2c i2c-13: cx24117_firmware_ondemand: No firmware uploaded (timeout or file not found?)
    4. [ 1175.675045] i2c i2c-13: cx24117: demod0 LNB not ready
    5. [ 1175.677591] cx23885 0000:03:00.0: Direct firmware load failed with error -2
    6. [ 1175.677597] cx23885 0000:03:00.0: Falling back to user helper
    7. [ 1175.678312] i2c i2c-13: cx24117_firmware_ondemand: No firmware uploaded (timeout or file not found?)


    das sieht schon aussagekräftiger aus.


    was mich wundert : wiso sind die adapter unter /dev/dvb/adapter0-1 gelistet OBWOHL das laden lt. dmesg eindeutig fehlschlägt ?


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von speefak ()

  • Und die benötigte Firmware hast Du auch installiert?


    Die gehört sicher nicht zum Kernel Paket ... vmtl. eher "linux-firmware-nonfree" ...

    HowTo: APT pinning

  • jepp firwarepakete sind intalliert. ich probiere grad firmware aus den treiberpaketes des herstellers aus ...


    EDIT :



    das sieht schon mal gut aus ;)


    firmware ist aus dem treiberpaket 140425 von


    http://www.tbsdtv.com/download/


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • Ja, wäre nicht das erste Mal das eine alte nicht zum Treiber gehörende FW im Paket enthalten ist. Mein Case wegen der 18er FW der DD Karten hat damals 1 Jahr gedauert bis diese Upstream war ...


    Evtl. meldest Du das bei Ubuntu, das das Kernel-Modul nicht mit der FW aus dem Ubuntu Repo arbeiten kann.

    HowTo: APT pinning

  • es läuft noch nicht wirklich. karte wird erkannt firmware auch, ich ach grad nen dd backup vom system bevor ich den treiber komplett baue und installiere. make install mit dem 130ger hat mir gestern mein system zerschossen ...


    lt. http://www.linuxtv.org/wiki/index.php/Conexant_CX23885/7/8 sollte die karte aber wohl nativ laufen, naja versuch macht kluch :)


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • lt. http://www.linuxtv.org/wiki/index.php/Conexant_CX23885/7/8 sollte die karte aber wohl nativ laufen, naja versuch macht kluch :)

    Ja, schon, nur wie viele andere Karten braucht es halt eine Firmware, die Karte läuft ja mal grundsätzlich mit dem Kernel-Modul ...


    Regards
    fnu

    HowTo: APT pinning

  • ich blick da nicht mehr durch :
    dmesg sagt :

    Code
    1. dmesg | grep TBS
    2. [ 12.096044] CORE cx23885[0]: subsystem: 6981:8888, board: TurboSight TBS 6981 [card=40,autodetected]


    syslog sagt :

    Code
    1. May 7 23:08:23 blackbox vdr: [2054] ERROR (dvbdevice.c,787): Die Wartezeit für die Verbindung ist abgelaufen
    2. May 7 23:08:23 blackbox kernel: [ 109.276916] i2c i2c-1: cx24117: demod0 LNB not ready
    3. May 7 23:08:23 blackbox kernel: [ 109.279489] cx23885 0000:03:00.0: Direct firmware load failed with error -2
    4. May 7 23:08:23 blackbox kernel: [ 109.279493] cx23885 0000:03:00.0: Falling back to user helper
    5. May 7 23:08:23 blackbox kernel: [ 109.280187] i2c i2c-1: cx24117_firmware_ondemand: No firmware uploaded (timeout or file not found?)


    und der vdr mecker immer mit

    Code
    1. sudo vdr -vv
    2. vdr: can't access video directory v


    dabei sind alle verzeichenisse rechte teschnisch passend selbst vollkommen offen mit 777 meckert der scheiss vdr :wand:wand:wand


    ich verzweifel hier langsam aber sicher ....


    http://www.vdr-wiki.de/wiki/index.php/YaVDR/Troubleshooting
    selbst die anleitung funktioneiert nicht, es wird alles richtig angezeigt aber der dreckkasten spuckt nicht ein scheiss bild aus :wand:wand:wand:wand:wand:wand:wand


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • sudo vdr -vv
    vdr: can't access video directory v


    Das Video-Verzeichnis heißt v bei dir? Na ja, wenn es gefällt, aber ich würde nie relative Pfade nehmen, gib lieber einen absoluten Pfad an.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • so grad das blanko image wieder aufgespielt und alles von vorn.


    vdr läuft wieder ( wie vorher auch, default verzeichnisse ) ABER


    bevor ich den treiber des TBS herstellers von der seite installierte :



    nachdem ich den treiber installierte der gleiche fehler im log


    ich versteh das einfach nicht mehr. unter 12.04 läuft alles super aber 14.04 ist seit 3 Tagen der absolute horror X(X(


    nach den log zur urteilen MUSS es doch an der Firmware liegen. der VDR läuft soweit und über das liveplugin kann ich auch drauf zugreifen nur kommt kein EPG kein bild nichts. im XBMC aufm server kann ich auch die kanäöe auswählen, es läuft alles wie es soll aber es kommt einfach weder bild noch ton von der karte. Woran kann das liegen ? die adapter sind unter /dev/dvb/adapterX gelistet.


    ich verstehs einfach nicht mehr :§$%


    EDIT :


    dmesg | grep firmware


    Code
    1. cx23885 0000:03:00.0: Direct firmware load failed with error -2
    2. [ 544.646135] i2c i2c-13: cx24117_firmware_ondemand: No firmware uploaded (timeout or file not found?)


    wie funktioniert das zusammenspiel denn zwischen firmware und treiber ? die firmware enthält harddware anweisungen wie register und den ganzen kram ?! Was macht der treiber denn bei einem zugriff auf die karte und welche rolle spielt die firmware da genau ?


    EDIT :


    Firmware aus der 12.04er installation gibt den gleichen obrigen fehler - woran liegt das ? ist die firmware kernelabhängig ?


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von speefak ()

  • "error -2" heißt ja "No such file or directory". Vielleicht muss das Firmware-File für 14.04 in einem anderen Verzeichnis liegen als bei 12.04? Oder der neue Treiber erwartet einen anderen Namen?

    VDR 1: (in Rente) EPIA ME6000, Nexus-S 2.1, Skystar2 2.6d, VDR-1.4.7 auf SuSE 9.3 (Kernel 2.6.21.7)
    VDR 2: (work in progress) MSI C847MS-E33, Cine S2 6.0, Zotac GT630 (GK208), yaVDR 0.6

  • Moin,
    nur zur Info, von mir aus Zeitmangel bisher nicht getestet:


    https://github.com/ljalves/linux_media/wiki


    (über TBS braucht auch glaub ich nix mehr geschrieben werden ...)


    Gruß
    Delaney

  • Delaney you made my day :D


    wget http://www.tbsdtv.com/download…linux-drivers_v130901.zip
    unzip -p tbs-linux-drivers_v130901.zip linux-tbs-drivers.tar.bz2 | tar jxOf - linux-tbs-drivers/v4l/tbs6981fe_driver.o.x86_64 | dd bs=1 skip=10144 count=55486 of=dvb-fe-cx24117.fw


    das wars.


    die info wär gestern abend super gewesen hätte mir ne ganze nacht stress erspart ;D


    ich kann verstehn das die FW nicht im linux kernel oder den quellen enthalten ist, was ich aber nicht verstehe, ist das TBS die fehlenden frimware im eignene treiber nicht gefixed hat. gestern hab 4 versionen durch probiert und gebaut, keine hat die firmware installiert


    in dem sinne : DANKE FÜR DIE INFO !!! :]


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |

  • Info Update : DVB S2 Karte grad umgebaut in ein HP Gen8 Server mit Debian 8


    infosource : https://github.com/ljalves/linux_media/wiki/CX24117-firmware


    status : WORKS ;)


    Server : Debian 8 + VDR 2.0.3 + VNSI Server 1.3.1 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 8 + Kodi 16 ( TeamXBMC Quellen ) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Ubuntu 16.04 + Kodi 16 (TeamXBMC Quellen ) on | Asus Z87 Pro | I5 4600 | 8 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 240 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 9 + Kodi 16 (TeamXBMC Quellen ) on | Lenovo T500
    |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info |