[gelöst] EPGSearch Plugin klässt sich mit VDR 2.1.6 nicht übersetzen?

  • Hi,


    jemand eine Idee dazu:


  • Das Plugin braucht einen Compatibilitäts-Patch für die VDR-Versionen >= 2.1.2
    https://github.com/VDR4Arch/vd…earch-vdr2.1.2compat.diff

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Das Plugin braucht einen Compatibilitäts-Patch für die VDR-Versionen >= 2.1.2
    https://github.com/VDR4Arch/vd…earch-vdr2.1.2compat.diff


    ah cool! Danke für die schnelle Hilfe.

  • Hi,


    nach dem Anwenden des Patches kommt das hier:



    Muss ich noch etwas machen?

  • Nein, aber da die Fehlermeldung sie gleiche ist, würde ich mal nachsehen, ob der Patch wirklich richtig angewendet wurde.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Muss ich noch etwas machen?


    Man sieht ganz deutlich dass der Patch wohl nicht angewendet wurde.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Nein, aber da die Fehlermeldung sie gleiche ist, würde ich mal nachsehen, ob der Patch wirklich richtig angewendet wurde.


    ich hatte den Patch so angewendet:


    Code
    1. cd /usr/local/src/vdr/PLUGINS/src/epgsearch/
    2. patch -p1 -i patch.diff


    War das falsch?

  • patch -p1 -i patch.diff


    Wenn dann so:
    patch -p1 <patch.diff

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Wenn dann so:
    patch -p1 <patch.diff


    Code
    1. cd /usr/local/src/vdr/PLUGINS/src/epgsearch/
    2. patch -p1 </data/installfiles/vdrplugins/epgsearch-vdr2.1.2compat.diff
    3. patching file uservars.h
    4. Hunk #1 FAILED at 538.
    5. 1 out of 1 hunk FAILED -- saving rejects to file uservars.h.rej


    In der Zeile 538 ist das hier:


    Code
    1. 536 class cVideodirVar : public cInternalVar {
    2. 537 public:
    3. 538 cVideodirVar() : cInternalVar("videodir") {}
    4. 539 string Evaluate(const cEvent*, bool escapeStrings = false)
    5. 540 {
    6. 541 return VideoDirectory;
    7. 542 }
    8. 543 };
  • Dann ersetz VideoDirectory einfach per Hand durch cVideoDirectory::Name()

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hier läuft das ohne Probleme durch:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Dann ersetz VideoDirectory einfach per Hand durch cVideoDirectory::Name()


    danke das ging.

  • Bis auf die Zeile 66 des Makefile (http://projects.vdr-developer.…rch.git/tree/Makefile#n66) gibt es da ja eigentlich nichts zu aktualisieren - den Patch kann man ja einfach erweitern, wenn man der mit dem VDR 2.1.3 eingeführten Konvention für PKGCFG entsprechen will:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo zusammen


    VORAB - Problem behoben - ich habe ein Paket direkt aus dem GIT runter geladen https://projects.vdr-developer…pgsearch.git/?h=vdr-2.2.x

    Das scheint zu compilieren


    CU

    GTR




    ich muss für eine VDR2.2 Installation (server) das epgsearch Plugin neu übersetzten dies schlägt hier fehl (wie im ausgangspost beschrieben)


    Der weiter oben gepostete Link zum Patch ist nicht mehr aktiv.


    Kann mir jemand helfen ein epgsearch unter VDR 2.2 zu kompilieren ?


    Ich habe alle Beta Versionen probiert die ich gefunden habe (obiger abbruch)

    Die aktuelle Version aus dem GIT benötigt zwingend mind VDR 2.3.6


    CU

    GTR