[Announce] epgd 0.2.0, scraper2vdr 0.1.0, Happy Easter Eggs


  • Teilweise stimmt die Zuordnung der Staffelfolge nicht (siehe Bild). Kann sein, dass der Sender da Schrott liefert.


    Gruß
    iNOB


    Das ist bei mir im EPG auch so. Wenn ich mir aber die Folgen von davor und danach ansehen und die Sendetermine auf fernsehserien.de, dann hat TVM hier einfach den falschen Episodenname verwendet.
    Denn am 17.05. kommt schon richtigerweise Folge 4 von Staffel 1. Aber die heisst nicht "Baelor", sondern "Krüppel, Dastarde und Zerbrochenes".
    Also Fehler auf Seite von TVM.


    Gruss.
    Markus

  • Wer legt denn die doppleten Timer an, der Meldung nach nicht das epg2vdr.


    Die doppelten Timer erscheinen nach einem Suchtimerupdate. Ich werde den betreffenden Suchtimer nochmal neu anlegen. Vielleicht klemmt da was.


    Gruß
    iNOB




  • Hilft das? In der DB ist jedenfalls mehr als im FS.

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Hi
    Ich habe auch das Problem das EPG Daten von z.b. Pro 7 fehlen. Zudem scheint er nur das EPG vom externen Provider zu nehmen, sieht man unter Quelle: TVM sonst war es Immer Quelle: DVB/TVM. Die Logmeldung "DVB pending, mergeepg done after" kommt auch nicht mehr.
    Im plugin epg2vdr bin ich in update.c auf folgendes gestoßen.

    Code
    1. + pending = epgdState == Es::esBusyMatch || epgdState == Es::esBusyEvents;
    2. +
    3. +// if (pending)
    4. + {
    5. + char buf[50+TB];
    6. + time_t updsp = vdrDb->getIntValue(cTableVdrs::fiUpdSp);


    if (pending) ist auskommentiert. Habs jetzt einkommentiert und jetzt micht er das EPG wieder. Ich bin kein Programmierer und kann das nicht alles nachvollziehen. Auf jeden Fall habe ich jetzt wieder aktuelles gemischtes EPG.
    Gruß
    gst

  • ...funktioniert hier leider nicht. Keine pending Meldungen im log. Kein Mischen. :(
    Wäre aber auch komisch, den ohne if (pending) muss epg2vdr ja immer durch den folgenden Code...

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Jungs,
    ich glaube hier ist (ohne dass ich Vorsatz unsterstelle!) der Name zum Programm geworden... SCNR


    Wenn es irgendetwas gibt, was ich testen oder kontrollieren kann, gebt laut - auch per EMail. Heute habe ich frei, ab morgennhabe ich wieder weniger Zeit.


    Gruß, Ingo

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Ich hab momentan auf einem meiner PCs den unangenehmen Effekt daß mein VDR beim Booten abstürzt
    VDR Version 2.0.6
    epgd und epgd-Plugin aus aktuellem GIT



    Code
    1. 2014-05-12T17:55:49.455501+02:00 Coruscant vdr: [1450] starting plugin: epg2vdr
    2. 2014-05-12T17:55:49.455529+02:00 Coruscant vdr: epg2vdr: Set locale to 'de_DE@UTF-8'
    3. 2014-05-12T17:55:49.455636+02:00 Coruscant vdr: epg2vdr: detected UTF-8
    4. 2014-05-12T17:55:49.455642+02:00 Coruscant vdr: epg2vdr: Error, connecting to database at 'localhost' on port (3306) failed
    5. 2014-05-12T17:55:49.455644+02:00 Coruscant vdr: epg2vdr: Could not access database 'localhost:3306' (tried to open vdrs)
    6. 2014-05-12T17:55:49.456398+02:00 Coruscant kernel: [ 11.207817] traps: vdr[1450] general protection ip:7fc89a17e2d9 sp:7fff809e4950 error:0 in libvdr-epg2vdr.so.2.0.6[7fc89a166000+36000]


    Sieht für mich so aus als ob der epgd noch beschäftigt wäre, bzw. erst nach dem VDR verfügbar ist. Denn wenn ich den VDR danach noch mal per Hand starte dann geht es einwandfrei.
    Am Startup hatte ich nichts geändert, das lief vorher schon mal einwandfrei so.

  • Für mich siehts so aus, als ob mysql noch nicht läuft. Abstürzen sollte es aber trotzdem nicht. Eventuell gibts da auch noch einen Bug.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hm...was steht denn im epgd Log? Und was steht beim Start vom VDR vom scraper2vdr im Log?


    Ciao Louis


    epgd:


    Code
    1. May 12 19:35:59 yavdr05 epgd: found new recording "How I Met Your Mother"
    2. May 12 19:35:59 yavdr05 epgd: searching "How I Met Your Mother" as series in db
    3. May 12 19:35:59 yavdr05 epgd: found "How I Met Your Mother" in Database
    4. May 12 19:35:59 yavdr05 epgd: successfully scraped recording "How I Met Your Mother"
    5. May 12 19:35:59 yavdr05 epgd: --------------------------------------------------


    scraper2vdr:


    Code
    1. May 12 19:40:32 yavdr05 vdr: scraper2vdr: Loaded 132 new Recordings from Database, 132 series, 0 movies

    RPI3, DVB-Sky S960, VDR 2.4.4, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Asta : da wird doch gescrapt. Was meinst Du mit es "werden keine Serien mehr gescrapt"? Leere Bildergalerie?

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • TheChief
    Ich glaub ich hab es gefixt. Hab ein bisschen am Startverhalten von MySQL rumgespielt und jetzt scheint es OK zu sein.




    Leider heute morgen wieder der selbe Effekt:



    Nur um das nochmal klar zu machen: Der VDR und der epgd laufen auf dem selben PC, es ist hier also kein extra Server der 24h läuft
    Also anscheinend wenn epgd etwas länger braucht um ein Update zu fahren stürzt VDR beim Starten ab wenn er kein Connect zur DB bekommt. Oder seh ich das falsch

  • Asta : willkommen in meiner Welt. ;)


    Gescrapt wird - aber die Bildergalerie ist leer. Hast Du Besetzungsnilder? Und Bilder im Info Tab? Dann hast Du den gleichen Fehler.

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Ich habe heute Abend mal beobachtet ob epg2vdr was macht und epgd merged, da kommt hier nichts mehr im Logfile vor.


    Hier z.B. epgd und das VDR Log von scraper und epg2vdr mit Stand: vdr-plugin-epg2vdr 0.1.8.git20140510.0812-0yavdr0~precise. Jetzt habe ich den GIT Stand von 20:57 installiert, konnte nur nicht neu starten da eine Aufnahme läuft...


    NACHTRAG
    Soeben aus neugierde den 2 VDR mit dem Stand von 20.57 getestet. Es scheint als ob ep2vdr eingefroren wurde... siehe hier Das Log macht nichts, am Server tut sich auch nichts seit 15 min. im Logfile mehr

    Gruß utiltiy



    VDR Projekte VDR Projects

    The post was edited 3 times, last by utiltiy ().

  • Das Problem ist bekannt und wir wissen auch schon an welcher Stelle. Mit dem git fix wollte es bei mir nicht. Weiss aber nicht, ob es am fix liegt oder daran, dass ich meinen Client noch nicht aktualisiert hatte (nur den Server).


    Hab jetzt auf beiden ohne den Workaround aus dem git in handler.h von epg2vdr die beiden Zeilen aukommentiert.


    if (!handlerMutex.tryLock())
    return true;


    Momentan läufts erstmal wieder, aber morgen schaut Horchi nochmal, wo es klemmt.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Ich habe den GIT Stand, dort wurde mehr auskommentiert als die beiden Zeilen...


    NACHTRAG
    Ich habe die Sachen wieder einkommentiert, bis auf die beiden Zeilen, nun tut sich wieder was:

    Code
    1. root@uti-srv02:~# tail -f /var/log/syslog | grep epgd
    2. May 12 23:48:29 uti-srv02 epgd: 843 DVB pending, mergeepg done after 32.267 seconds
    3. May 12 23:50:22 uti-srv02 epgd: 852 DVB pending, mergeepg done after 38.965 seconds

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Quote

    Asta : willkommen in meiner Welt. ;)


    Gescrapt wird - aber die Bildergalerie ist leer. Hast Du Besetzungsnilder? Und Bilder im Info Tab? Dann hast Du den gleichen Fehler.


    Nein, gar keine Bilder kommen hier an.


    Gesendet von meinem GT-I9100 mit Tapatalk 2

    RPI3, DVB-Sky S960, VDR 2.4.4, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Moin asta,


    Ich hatte vor zwei Tagen ein ähnliches Problem.
    yaVDR nimmt für die Bilder /var/cache/vdr/epgimages/series bzw movies
    Bei mir lagen die vom selbst kompilieren aber noch unter /var/cache/vdr/plugins/scraper2vdr/...
    Nach verschieben meiner alten Bilder in das neue Verzeichnis wurde wieder alles angezeigt.
    Eventuell ist es bei dir ja das gleiche...

  • Ich habe den GIT Stand, dort wurde mehr auskommentiert als die beiden Zeilen...


    NACHTRAG
    Ich habe die Sachen wieder einkommentiert, bis auf die beiden Zeilen, nun tut sich wieder was:

    Code
    1. root@uti-srv02:~# tail -f /var/log/syslog | grep epgd
    2. May 12 23:48:29 uti-srv02 epgd: 843 DVB pending, mergeepg done after 32.267 seconds
    3. May 12 23:50:22 uti-srv02 epgd: 852 DVB pending, mergeepg done after 38.965 seconds


    Bei mir funktioniert

    Code
    1. ca52975 - (vor 11 Stunden) fixed handler buf (workaround) horchi (origin/master, master)


    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • @ nvertigo


    bei mir geht es damit nicht. Ich habe 2 VDR parallel getestet. Der mit dem GIT Stand von 20:57 tat nichts, der mit "nur" den zwei Zeilen TheChief hat funktioniert....

    Gruß utiltiy



    VDR Projekte VDR Projects