Asrock H87m Pro4: SATA hotplugfähig?

  • Hallo, einige haben dieses Board ja im Einsatz. Funktioniert es bei Euch, wenn ihr im laufenden Betrieb eine SATA-Platte (z.B. per eSATA-Slotkarte) dazusteckt? Bei meinem alten Board wurde die Platte dann in dmesg aufgelistet. Beim neuen Asrock kriegt der Kernel nichts mit, die Platte muss bereits beim Booten dranstecken.
    Laut Handbuch müsste der Controller es können.

    Code
    1. 6 x SATA3 6.0 Gb/s connectors, support RAID (RAID 0,
    2. RAID 1, RAID 5, RAID 10, Intel Rapid Storage Technology
    3. 12 and Intel Smart Response Technology), NCQ, AHCI and
    4. “Hot Plug”


    Im BIOS ist als Modus AHCI ausgewählt. Eine separate Einstellung für "Hot plug" gibt es dort für die SATA-Controller nicht.


    Falls jemand das Board mit Windows betreibt, wäre es interessant, ob es dort funktioniert. Möglicherweile ist es ja ein Bug im Kerneltreiber für diesen Chipsatz.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 19.04 per SSD
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive Asus GT610, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 18.04 per SSD

  • Mal ins Blaue geraten: Hat das Board verschiedenfarbige SATA-Ports? Wenn ja, dann mal einen Port der Gruppe mit einer anderen Farbe testen. Oft hängen die farblich unterschiedenen Ports auf verschiedenen Chipsätzen die unterschiedliche Eigenschaften/Einschränkungen haben.

  • nee, die sind alle gleichfarbig.


    Das witzige ist: auf einmal geht es jetzt plötzlich.


    Dieses Board ist irgendwie komisch. Viele haben ja mit dem Runterfahren Probleme gehabt. Hatte ich zwischendurch auch mal. Lag an irgendwelchen UEFI-Einstellungen. Nächstes Problem:
    Wenn man im ausgeschalteten Zustand ein USB-Gerät anschließt (weil man es z.B. über den mit externem Strom versorgten HUB laden will), bootet der Rechner. Umgehen konnte ich dies, indem ich im UEFI die Einstellung "Keyboard/Remote Power On" aktiviert habe. :rolleyes:

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 19.04 per SSD
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive Asus GT610, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 18.04 per SSD

  • Dr. Seltsam


    Grundsätzlich hast Du Recht, SATA impliziert per Spec Hotplug. Aber der Port muß dann in der Regel entsprechend konfiguriert werden und im BIOS als eSATA Port definiert werden. Bei einigen Mainboards geht das nur für bestimmte Ports, bei anderen kann man das quasi wahlfrei auf alle anwenden ... bei RAID Controllern ist Hotplug i.d.R. auch default ...


    Regards
    fnu

    HowTo: APT pinning

  • Wie ist denn das Board sonst so? Würde das gerne als Nachfolger für mein altes Asus Board nehmen.

  • Quote

    Im BIOS ist als Modus AHCI ausgewählt. Eine separate Einstellung für "Hot plug" gibt es dort für die SATA-Controller nicht.


    Richtig so.


    Bei mir ist das nötig, damit Windows neue Hotplug-Sata-Festplatten erkennt:


    echo rescan | diskpart


    Gruß,
    Chris

  • Richtig so.


    Nicht ganz. Der richtige Weg ist, was fnu geschrieben hat. Falls möglich, den Port als eSATA deklarieren.


    Albert

  • man kann es tatsächlich für jeden Porto explizit im UEFI konfigurieren. Ich war gar nicht auf die Idee gekommen, dass da beim Anklicken des Ports noch ein Untermenü aufgeht...
    Es funktioniert jetzt jedenfalls.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 19.04 per SSD
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive Asus GT610, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 18.04 per SSD