Probleme mit Signalstärkeanzeige

  • Hallo Experten!


    Ich habe einen neuen VDR installiert, und habe das Problem, dass die Signalstärkeanzeige im Skin immer auf 0% steht, und die Qualitätsanzeige immer ganz unten im roten Bereich ist. Dabei ist das Bild gar nicht so übel, nur auf einigen Sendern gibt es Störungen.
    Wenn ich das femon-plugin aufrufe, wird das Bild jedoch so schlecht, dass es quasi nicht mehr zu gebrauchen ist, bzw. das Bild geht ganz weg. (Screenshot)


    Auf der Konsole bringt femon nur eine Fehlermeldung:


    Code
    1. [root@htpc ~]# femon
    2. FE: STV0367 DVB-C DVB-T (DVBC)
    3. Problem retrieving frontend information: Resource temporarily unavailable
    4. status | signal 0000 | snr 0000 | ber 00000000 | unc 00000001 |
    5. Problem retrieving frontend information: Resource temporarily unavailable
    6. status | signal 0000 | snr 0000 | ber 00000000 | unc 00000001 |


    Hardware ist übrigens eine Digital Devices Cine C/T V6, und das ganze läuft unter vdr4arch.


    Hat jemand Tipps für mich, wie ich zu einer sinnvollen Signalstärkeanzeige komme?


    Vielen Dank,
    Jörn.



    Nachtrag:
    Ich habe eben bemerkt, dass ich bei laufendem VDR mit femon auf der Konsole doch eine Ausgabe bekomme:

    Code
    1. [root@htpc ~]# femon
    2. FE: STV0367 DVB-C DVB-T (DVBC)
    3. status SCVYL | signal 0043 | snr 0151 | ber 0000ffff | unc 0000a45b | FE_HAS_LOCK
    4. status SCVYL | signal 0043 | snr 0142 | ber 0000ffff | unc 0000c6e6 | FE_HAS_LOCK
    5. status SCVYL | signal 0043 | snr 014e | ber 0000ffff | unc 0000e9cb | FE_HAS_LOCK
    6. status SCVYL | signal 0043 | snr 0147 | ber 0000ffff | unc 00000b21 | FE_HAS_LOCK
    7. status SCVYL | signal 0043 | snr 014e | ber 0000ffff | unc 00002d98 | FE_HAS_LOCK
    8. status SCVYL | signal 0043 | snr 014c | ber 0000ffff | unc 0000504b | FE_HAS_LOCK
    9. status SCVYL | signal 0043 | snr 0140 | ber 0000ffff | unc 0000742b | FE_HAS_LOCK
  • der Treiber liefert keine brauchbaren Daten für Signalstärke (STR) und Signalqualität (SNR). Die Bitfehlerrate (BER) wird m.E. richtig angezeigt und sollte konstant 0 sein.


    Zumindest unter yavdr habe ich das von Dir beschriebene Problem beim Aufruf von femon nicht.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Treiber habe ich die aus dem vdr4arch-repository installiert:


    Code
    1. [root@htpc ~]# pacman -sS dddvb
    2. vdr4arch/dddvb 0.9.10-8 [Installiert]
    3. Newest driver package for Digital Devices DVB cards


    VDR-Version ist 2.0.5 (vielleicht spielt das ja eine Rolle?)

  • ich habe nie ein update gemacht und sehe das zum ersten mal.


    Ich würde an Deiner Stelle erst mal versuchen, den Empfang so zu optimieren, dass Du auf allen Kanälen keine uNC hast und die BER bei 0 liegt. Das geht los beim Antennenverstärker und geht über Verteilkomponenten bis zur Dose und dem Anschlusskabel. Hinweise dazu gibt es viele hier im Forum.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • So: der erste Übeltäter war der T-Verteiler, der das Antennensignal zwischen Fernseher und VDR aufgeteilt hat. Jetzt kann man halt nur noch mit dem VDR fernsehen, auch nicht so schimm.


    Ohne das Ding sind die ber- und unc-Werte deutlich besser. Bei der Anzeige der Signalstärke und SNR hat sich jedoch überhaupt nichts getan. Das muss also noch eine andere Ursache haben. Habt Ihr eine Idee, wo ich da weiter suchen sollte?


    Code
    1. [root@htpc ~]# femon
    2. FE: STV0367 DVB-C DVB-T (DVBC)
    3. status SCVYL | signal 004a | snr 018c | ber 00000000 | unc 0000000b | FE_HAS_LOCK
    4. status SCVYL | signal 004a | snr 0186 | ber 00000000 | unc 0000000b | FE_HAS_LOCK
    5. status SCVYL | signal 004a | snr 0184 | ber 00000000 | unc 0000000b | FE_HAS_LOCK
    6. status SCVYL | signal 004a | snr 0185 | ber 00000000 | unc 0000000b | FE_HAS_LOCK
    7. status SCVYL | signal 004a | snr 0189 | ber 00000000 | unc 0000000b | FE_HAS_LOCK


    Gruß, Jörn.

  • Also ich habe das jetzt mal getestet mit meiner Cine S2 un dem dddvb Treiber. Auch bei mir wird keine Signalstärke angezeigt.
    Ich merke das normalerweise nicht, da meine Karte mit dem Kerneltreiber bestens funktioniert.


    Es muss also irgendwas im dddvb-Treiber defekt sein. Ich weiß aber im Moment wirklich nicht was.
    yaVDR nimmt soweit ich weiß den media-build-experimental Tree von Oliver Endriss. Vielleicht paketiere ich in Zukunft einfach auch diesen Tree und spare mir damit ein bisschen Ärger.


    Ich schaue mir das heute noch an und du bist dann der erste, der ein Testpaket bekommt.

  • Soo. Lade mal von hier das Paket: http://creimer.net/temp/media_…31127-1-x86_64.pkg.tar.xz
    Vor der Installation dddvb und v4l-dvb-saa716x deinstallieren.


    Achtung: Paket ist ungetestet. Sollte aber keine großartigen Probleme verursachen können.



    Wenn es damit gelöst ist, werde ich das PKGBUILD noch ein wenig aufräumen und diese Paket ersetzt dann die anderen beiden Treiberpakete.

  • Man kann hier nicht die S2 und die CT vergleichen.


    Der Treiber für die CT liefert weder STR noch SNR. Da ist nichts defekt. Punkt.


    Wenn es keine Artefakte gibt und die BER durchgehend auf 0 ist, ist alles in Ordnung. Bei der UNC wäre zu prüfen, ob die 0000000b konstant ist. Eigentlich sollte es 0 sein. Aber einige Treiber interpetieren das als fortgeschriebenen Zähler. Dann kommt der Wert größer 0 evtl. vom Moment des Umschaltens.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • BER muss nicht Null sein, nur klein genug.