[Announce] nOpacity 1.0.4

  • wo du gerade son Lauf hast und wo deine Frau ja eh mit testen beschäftigt ist...... magst du son ähnlichen Patch nicht für epgsearch machen? ;)


    Sicher ich weiß schon man kann eine abgekupferte epgsearch Ansicht in remotetimers aktivieren, die hat aber so viele Einschränkungen, insbesondere das fehlende Favoritenmenu und die fehlenden Graphtft Ansichten das es eher ein no-go ist ....


    Ansonsten teste ich deinen Patch später gern ;)


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5

  • Hi,


    Bei mir gibt es einen kleinen Bug zusammen mit dem DVD Plugin: In der Infoleiste (Progressbar) gibt es Grafikfehler, sie wird nicht sauber dargestellt. Auf Wunsch kann ich nen Screenshot posten.


    Gruß maz

    Meine VDRs:
    >>>Mac mini 2010 mit 2x Sundtek SkyTV Ultimate III, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>ZOTAC D2550 ITX-WIFI Supreme mit DD Cine S2, Gehäuse OrigenAE M10, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>Raspberry Pi
    2 mit Sundtek SkyTV Ultimate IV, raspbian, rpihddevice-Plugin, Logitech Harmony 200<<<

  • voila - ist etwas schwer zu erkennen. Es gibt Grafikfehler zwischen der oberen Schrift und der Progressbar, und die Buttons (Play, Pause etc) werden nicht richtig dargestellt.

    Images

    Meine VDRs:
    >>>Mac mini 2010 mit 2x Sundtek SkyTV Ultimate III, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>ZOTAC D2550 ITX-WIFI Supreme mit DD Cine S2, Gehäuse OrigenAE M10, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>Raspberry Pi
    2 mit Sundtek SkyTV Ultimate IV, raspbian, rpihddevice-Plugin, Logitech Harmony 200<<<

  • Ok, da werden die entsprechenden Pixmaps nicht transparent gefüllt...kann ich mal nachziehen. Machst du bitte einen Bugreport mit dem Link zu deinem Posting auf vdrdeveloper dafür auf?


    Alternativ könnte das DVD Plugin das "DisplayReplay" auch vollständig aufrufen ;) Kannst ja mal den Autor anfragen, ob er das nachziehen will...


    Ciao Louis

  • Ich habe nach wie vor noch das Problem, dass im ausführlichen EPG der Aufzeichnungen ab und zu nur gähnende Leere angezeigt wird, obwohl EPG-Daten laut Kurzinfo vorhanden ist.


    Gruß
    iNOB

  • Hatte folgendes jetzt drei mal. Zufällig, nicht reproduzierbar - wenn es vorkommt, dann nach dem Umschalten:


    Leider hatte ich den vdr ohne debuging übersetzt (jetzt läuft er mit debugging symbols - wenns wieder vorkommt, wirds ausführlicher: mit bt).


    Gruß, Ingo

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Wie voll ist der Speicher denn bei dir?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Code
    1. free
    2. total used free shared buffers cached
    3. Mem: 16391768 16126984 264784 0 1372952 9480780
    4. -/+ buffers/cache: 5273252 11118516
    5. Swap: 33554428 3099176 30455252


    Plus/minus ist das recht typisch. Zumindest zum Zeitpunkt des letzten Absturzes lief auch kein emerge oder android build, oder ähnliches, dass Speicher benötigt. Imagemagick ist 6.8.8.10, das verwende ich seit dem 10.4. Die drei Abstürze habe in den letzten beiden Tagen stattgefunden.


    Gruß, Ingo


    P.S.: natürlich tut mir der Fehler jetzt gerade (mit debug im vdr) nicht den Gefallen aufzutreten... :(

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Dass er bei 16GB trotzdem schon mal swapped finde ich irgendwie ziemlich heftig. Wer verbraucht denn da so viel?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ein "brunch manta" im cyanogenmod-Verzeichnis. Aber wie gesagt, das war nicht während des vdr-Absturzes. Und wenn Du Dir das bereinigte free ansiehst ist alles grün.

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Dass er bei 16GB trotzdem schon mal swapped finde ich irgendwie ziemlich heftig.


    Wie ist denn die swappiness eingestellt?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi Ingo,


    ich könnte mir ja vorstellen, dass die Imagemagick Jungs da mal wieder was verbockt haben. Zum Hintergrund: während des Kopierens der Bilder aus der DB in das lokale FS erzeuge ich ein Poster Thumbnail zur Darstellung z.B. in der Aufnahmeliste. Zum Skalieren verwende ich Imagemagick. Bei dir scheint IM dabei abzustürzen, aus welchem Grund auch immer. Vielleicht mache ich was falsch (wobei das so einfach ist, dass man da kaum was falsch machen kann), oder es steht bei denen mal wieder was schief. Vielleicht solltest du testweise mal auf eine ältere Version zurück bzw. Graphicsmagick benutzen?


    Ciao Louis

  • Sortiert nach virtueller Speichergröße:

    Code
    1. top - 14:16:28 up 19 days, 18:53, 10 users, load average: 0.62, 0.61, 0.65 Tasks: 381 total, 1 running, 380 sleeping, 0 stopped, 0 zombie %Cpu(s): 0.4 us, 0.6 sy, 0.1 ni, 98.7 id, 0.1 wa, 0.1 hi, 0.0 si, 0.0 st KiB Mem: 16391768 total, 15327416 used, 1064352 free, 1373708 buffers KiB Swap: 33554428 total, 3100220 used, 30454208 free, 9235840 cached
    2. PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3. 3254 root 20 0 4187172 5804 1992 S 0.0 0.0 0:03.02 console-kit-dae 23139 root 20 0 4181236 589596 44424 S 6.0 3.6 4:01.86 vdr
    4. 15481 mysql 20 0 892480 75892 5676 S 0.3 0.5 25:03.03 mysqld
    5. 3724 root 20 0 664196 1520 1164 S 0.0 0.0 0:59.39 nscd 3152 apache 20 0 640868 396 280 S 0.0 0.0 0:00.00 apache2
    6. 3154 apache 20 0 640868 400 280 S 0.0 0.0 0:00.01 apache2
    7. 3325 polkitd 20 0 547928 3408 1956 S 0.0 0.0 0:02.64 polkitd 15466 root 20 0 462724 8664 1912 S 0.0 0.1 15:16.47 udisksd 9924 root 20 0 268304 4428 1836 S 0.0 0.0 0:01.94 upowerd 3099 root 20 0 231164 1028 972 S 0.0 0.0 0:29.75 apache2 3101 apache 20 0 212604 408 396 S 0.0 0.0 0:00.00 apache2 10004 root 20 0 189976 3232 2132 S 0.0 0.0 2:08.26 udisks-daemon


    Sortiert nach residenter Speichergröße:

    Code
    1. top - 14:19:35 up 19 days, 18:56, 10 users, load average: 0.47, 0.57, 0.63 Tasks: 382 total, 2 running, 380 sleeping, 0 stopped, 0 zombie %Cpu(s): 0.4 us, 0.5 sy, 0.1 ni, 98.9 id, 0.0 wa, 0.1 hi, 0.0 si, 0.0 st
    2. KiB Mem: 16391768 total, 15328168 used, 1063600 free, 1373716 buffers KiB Swap: 33554428 total, 3100220 used, 30454208 free, 9236360 cached
    3. PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    4. 23139 root 20 0 4181236 589852 44424 S 5.3 3.6 4:14.29 vdr
    5. 15481 mysql 20 0 892480 75892 5676 S 0.0 0.5 25:04.09 mysqld 17866 root 19 -1 157832 52704 17512 S 0.0 0.3 0:10.06 X
    6. 17903 root 20 0 92956 25716 3776 S 0.0 0.2 0:00.53 gg_launcher.pl
    7. 27470 root 20 0 182628 25292 5476 S 0.0 0.2 1:19.20 epgd 15466 root 20 0 462724 8664 1912 S 0.0 0.1 15:16.47 udisksd 3254 root 20 0 4187172 5804 1992 S 0.0 0.0 0:03.02 console-kit-dae 16212 root 20 0 133680 4532 3352 S 0.0 0.0 0:00.39 sshd 9924 root 20 0 268304 4428 1836 S 0.0 0.0 0:01.94 upowerd 861 root 20 0 100376 4112 3208 S 0.0 0.0 0:00.02 sshd
    8. 23260 root 20 0 17944 4080 1624 S 0.0 0.0 0:01.43 bash
    9. 2444 root 20 0 61784 3772 1872 S 0.0 0.0 7:15.49 syslog-ng


    Um bei multi-core builds etwas mehr Dampf zu haben, habe ich das hier (seit ca. 18 Monaten):

    Code
    1. adler VDR # grep proc/sys/vm /etc/local.d/*
    2. echo 90 >/proc/sys/vm/dirty_ratio #= 90 (% per process, default = 10)
    3. echo 80 >/proc/sys/vm/dirty_background_ratio #= 80 (% system-wide, default = 5)
    4. echo 6000 >/proc/sys/vm/dirty_expire_centisecs #= 6000 (60s, default = 30s)
    5. echo 4000 >/proc/sys/vm/dirty_writeback_centisecs #= 4000 (40s, default = 5s)
    6. adler VDR # cat /proc/sys/vm/swappiness
    7. 60


    EDIT: sehe gerade, dass meine Sig nicht mehr stimmt. Ändere gleich

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • PS: in den makefiles von nopacity, tvguide und scraper2vdr gibt es einen Schalter, um von Imagemagick auf Graphicsmagick umzustellen.


    Wenn du übrigens schauen willst, ob die Bilder in der DB noch korrekt sind: Der Verzeichnisname der Bilder bei Serien entspricht der series_id. Die Tabelle, in der die Bilder für Serien gespeicher sind, heisst series_media. Wenn du ein


    Code
    1. select * from series_media where series_id = xxx


    Das Feld "media_type" bestimmt den Typ des Bildes (Banner, Poster, Fanart, ActorThumb, ...). Hier siehst du das genau.


    Aber obacht, da sind ja die Bilder drinn gespeichert, der Query kann ein bisschen dauern. Wenn du die mysql Workbench hast, kannst du dir mit dem Query Browser sogar die Bilder direkt ansehen.


    Ciao Louis

  • Wenn ich:

    Code
    1. mysql -D epg2vdr -e 'select * from series_media where series_id = 78817;'


    ausführe, bekomme ich seitenweise '-'-ZeiChen, gefolgt von '1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c'.
    Habe ich da etwas falsch verstanden?

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Das sind die Bilder als BLOB gespeichert :D Deshalb der Hinweis auf die MySQL Workbench. Damit kannst du dir die Bilder anschauen...


    Alternativ kannst du dir auch mit


    Code
    1. select media_width, media_height, media_url, media_type, length(media_content) from series_media where series_id = xxx


    die Größe der gespeicherten Bilder anzeigen lassen.


    Ciao Louis

  • Scheint wirklich ImageMagick zu sein:


    Full Backtrace anbei.


    Welche ImageMagick-Version empfiehlst Du? Oder lohnt es sich komplett auf GraphicsMagick umzustellen - ich kann nicht beide parallel installieren.

    Files

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB

  • Hi Ingo,


    hm, da ist wohl noch ein anderes Problem, da kann ImageMagick nix dafür, das bekommt unitialisierte Werte:


    Code
    1. #8 0x00007f1f1fd95190 in cImageLoader::LoadPoster (this=0x7fff203a0a20, poster=0x7f1e94c8cdf8 "/var/vdr/scraper2vdr-images/movies/18089/poster.jpg", width=-2147483648, height=-2147483648) at imageloader.c:124


    Kannst du mal testweise bitte die Zeile 592 in der displaychannelview.c von


    Code
    1. } else if (call.type == tMovie && call.poster.path.size() > 0) {


    zu


    Code
    1. } else if (call.type == tMovie && call.poster.path.size() > 0 && call.poster.width > 0 && call.poster.height > 0) {


    abändern? Wobei bei dir noch irgendetwas anderes schiefsteht, den Fall, dass es ein Bild in der DB gibt, dieses aber eine ungültige Größe hat, darf es eigentlich nicht geben...vielleicht werden durch deine langsame Internetverbindung die Bilder nicht ordentlich geladen?!


    Ciao Louis

  • Plugin baut gerade mit diese Änderung:


    Aber weshalb ich ImageMagick in verdacht habe: das Bild ist ok - beim nächsten mal funktioniert genau das gleiche Umschalten mit Bildanzeige ja...


    Gruß, Ingo

    gentoo (vdr-2.6.0 manuell installierg), Asus Sabertooth FX990, AMD FX8150, 16GB 1833, CineS2(kernel 5.15.x inkl. standard dvb Treiber), USB RC(inputevxd), Asus gt1030, vertex4 ssd (system), mdraid5 9TB