[gelöst] SoftHDDevice - Betriebssystemfenster und Popups kommen in den Vordergrund

  • Hallo,


    ich weiß jetzt nicht so recht ob das am SoftHDDevice Plugin zu regeln ist oder am Betriebssystem. Ich verwende Ubuntu und den Standarddesktop. Mein VDR startet automatisch in der grafischen Oberfläche und funktioniert auch. Sobald auf dem Ubuntudesktop etwas passiert zum Beispiel ein Popup bezüglich neuer Updates etc. kommt dieses Fenster in den Vordergrund ist ist im TV Bild zu sehen. Kann ich das unterbinden? Sprich kann ich das SoftHDDEvice Plugin so starten das dies immer im Vordergrund ist?

  • Ich verwende Ubuntu und den Standarddesktop.


    Warum das denn? Unity ist völlig ungeeignet, weil der Compositing-Managerdie CPU-Last unnötig in die Höhe treibt und es zu Mikrorucklern und anderen Problemem bei der Videoausgabe kommen kann. Du brauchst eigentlich nur einen nackten X-Server, wenn du einen Window Manager haben willst, nimm besser etwas schlankeres wie openbox, lxde oder i3wm...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)


  • Warum das denn? Unity ist völlig ungeeignet, weil der Compositing-Managerdie CPU-Last unnötig in die Höhe treibt und es zu Mikrorucklern und anderen Problemem bei der Videoausgabe kommen kann. Du brauchst eigentlich nur einen nackten X-Server, wenn du einen Window Manager haben willst, nimm besser etwas schlankeres wie openbox, lxde oder i3wm...


    Hi,


    das kommt daher das ich mein System auch als Desktop PC verwende. Bezüglich Mikroruckler etc. habe ich bisher nichts bemerkt bzw. noch keine Langzeiterfahrung. Gibt es mit dem Standarddesktop keine Möglichkeit?

  • Du kannst versuchen das Plugin auf einem eigenen X Server zustarten, dann sollte nichts in die Quere kommen.


    Ansonsten lege das Plugin auf die höchste Fensterebene (Layer). Name und Klasse sind hierfür "softhddevice".
    Das geht über den Windowmanager selber.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • sewn4


    Bin inzwischen auch dazu übergegangen den einfach normalen Ubuntu Desktop zu nutzen mit lightdm's gutem einfachen Autologin. Aber ich nehme nicht Unity als Session, sondern Openbox. Letzteres muß man bei einem ersten Login mal richtig einstellen, Ränder, Dekoration etc., später kann man sich "~/.config/openbox/rc.xml" kopieren.


    Vorteil für mich, wenn benötigt habe ich einen komplett nutzbaren Unity Desktop, aber im VDR Betrieb einfach einen schwarzen, randlosen openbox Desktop ohne Icons mit einer einfach Autostart Logik. Damit Openbox auch schwarz und nicht grau oder Fischgrät-Muster ist:


    Code
    1. #/home/vdr> cat .config/openbox/autostart.sh# Set the wallpaperxsetroot -solid "#000000" &


    lightdm merkt sich allerdings immer die Art der letzten Session, man kann das aber dann doch noch auf cmdline beeinflussen:


    Code
    1. #/home/vdr> cat .dmrc[Desktop]Session=openbox


    Dann solltest Du unbedingt das nervige "apport" deaktivieren, das schlägt bei jeder Zeile im syslog an, das das Wort "error" enthält und bei VDR bzw. den Plugins hat man das halt einfach mal ohne das es wirklich kritisch wäre:


    Code
    1. #/home/vdr> cat /etc/default/apport# set this to 0 to disable apport, or to 1 to enable it# you can temporarily override this with# sudo service apport start force_start=1enabled=0


    Was auch tierisch nervt ist der Update-Manager, also diese Prüfung auch deaktivieren, man prüft sowieso immer wieder selbst auf Aktualisierungen, die nötige Datei sollte so aussehen:


    Code
    1. /home/vdr> cat /etc/apt/apt.conf.d/10periodicAPT::Periodic::Update-Package-Lists "0";APT::Periodic::Download-Upgradeable-Packages "0";APT::Periodic::AutocleanInterval "0";


    Wobei man nur die Zeile "Update-Package-Lists" von "1" auf "0" ändern muß.


    Und wenn Du wieder ein HowTo irgendwo dazu anlegst, wäre es nur fair wenn Du erwähnst wo Du all die kleinen Tips und Tricks von allen Schreibern hier her hast ... 8o


    Regards
    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von fnu ()

  • Hi,


    fnu
    da bist Du mir etwas zuvor gekommen :). Die Danksagungen sind im Wiki hinterlegt.


    Ich kann auch gerne noch auf die einzelnen Threads verlinken?

  • Hi,


    ich bin jetzt vorerst mal auf openbox gewechselt. Das funktioniert auch soweit ganz gut. Was mir jetzt noch fehlt wo kann ich einstellen das openbox automatisch nach dem Systemstarte geladen wird inklsuive Autologin?


    EDIT:
    Es ist immer noch GNOME der Standarddesktop

  • Ich kann auch gerne noch auf die einzelnen Threads verlinken?

    Das mußt Du wissen wie es am besten wirkt. Ich fände es nur fair zu zeigen, nicht zu verstecken, woher die Hinweise kamen ...


    Was mich jetzt noch interessiert, sind Deine Popups mit o.a. Änderungen alle weg?


    Regards
    fnu

    HowTo: APT pinning

  • Was mir jetzt noch fehlt wo kann ich einstellen das openbox automatisch nach dem Systemstarte geladen wird inklsuive Autologin?


    => http://wiki.ubuntuusers.de/LightDM => Automatische Anmeldung


    Oder verwendest Du nicht Standard-Ubuntu, weil da ist der Default-Desktop Unity, eigentlich ... ?


    Die Default-Session hatte ich o.a. schon beschrieben "/home/[USER]/.dmrc" ...


    Regards
    fnu

    HowTo: APT pinning

  • Das mußt Du wissen wie es am besten wirkt. Ich fände es nur fair zu zeigen, nicht zu verstecken, woher die Hinweise kamen ...


    Was mich jetzt noch interessiert, sind Deine Popups mit o.a. Änderungen alle weg?


    Regards
    fnu


    Hi,


    also bisher habe ich einfach openbox installiert und dort meine runvdr in den Autostart gehängt:



    Wenn ich dann mein System neustarte wird automatisch der GNOME Desktop geladen. Wenn ich mich dann auslogge und openbox starte funktioniert alles schon mal soweit. Nur wie bekomme ich es hin das openbox anstatt GNOME als Standard gestartet wird?

  • Hi,


    also ich sehe bei mir nach der Installation von openbox folgende Arbeitsumgebungen:


    • Ubuntu (Standard)


    • Openbox


    • GNOME/Openbox


    Und der Ubuntu Standarddesktop der bei Ubuntu 13.10 dabei ist wird auch automatisch gestartet inklusive Autologin.


    Das mit der Defaultsession hat irgendwie nicht funktioniert sprich es bootet immer der Ubuntu (Standard) Desktop.

  • Das mit der Defaultsession hat irgendwie nicht funktioniert sprich es bootet immer der Ubuntu (Standard) Desktop.

    Hmm, hast Du noch Maus und Tastatur am VDR dran? Evtl. logst Du Dich einmal aus und wieder ein, aber hier dann vorher einmal manuell "openbox" wählen.


    Bei lightDM wird immer der letzte Session-Typ genutzt, funktioniert hier bei 12.04 wie auch 14.04 (trusty development) ... gibt es bei Dir im Home-Verzeichnis die Datei ".dmrc" ... ?


    Regards
    fnu

    HowTo: APT pinning

  • Hmm, hast Du noch Maus und Tastatur am VDR dran? Evtl. logst Du Dich einmal aus und wieder ein, aber hier dann vorher einmal manuell "openbox" wählen.


    Bei lightDM wird immer der letzte Session-Typ genutzt, funktioniert hier bei 12.04 wie auch 14.04 (trusty development) ... gibt es bei Dir im Home-Verzeichnis die Datei ".dmrc" ... ?


    Regards
    fnu


    Hi fnu,


    das mit dem aus und einloggen hat funktioniert. Jetzt startet der openbox Desktop. Mal schauen ob jetzt die Soundprobleme weg sind. Ich habe in meine Autostartdatei noch das hier eingetragen:



    Ist das darin richtig oder gehört das an andere Stelle?

  • Du kannst versuchen das Plugin auf einem eigenen X Server zustarten, dann sollte nichts in die Quere kommen.


    Ansonsten lege das Plugin auf die höchste Fensterebene (Layer). Name und Klasse sind hierfür "softhddevice".
    Das geht über den Windowmanager selber.


    Johns


    Hi Johns,


    ich hab dazu schon einiges gelesen allerdings nichts gefunden wo dies unter Ubuntu 13.10 einstellbar wäre. Hast Du eventuell noch einen Tipp?

  • In der normalen Desktop-Session, wenn pulseaudio läuft, könntest du auch softhddevice mit "-a pulse" starten, bzw. in /etc/asound.conf pulse als default eintragen.

    Code
    1. pcm.pulse {
    2. type pulse
    3. }
    4. ctl.pulse {
    5. type pulse
    6. }


    Schreibe das gerade aber aus dem Gedächtnis, muss nicht 100% richtig sein.
    Dann brauchst du softhddevice gar kein -a mitgeben.


    EDIT: so sieht die asound.conf bei mir aus und ich starte softhddevice ohne "-a" Parameter.


    Lars

    vdr2: yaVDR 0.5/softhddevice @ G540, Intel DH67BLB3, Asus GT610/2GB, DDBridge + 2x DuoFlex C/T
    hdvdr: yaVDR unstable/softhddevice @ E8400, Asus P5Q SE Plus, 1x L4M-TwinCI + Flex C/T, 1x Sundtek MediaTV Pro, GT520
    Plugins: | avahi4vdr | dbus2vdr | dynamite | epg2timer | noepg | pvrinput | sundtek |

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von mini73 () aus folgendem Grund: asound.conf korrigiert

  • sewn4


    Ich nutze keine runvdr, daher kann ich dazu nichts sagen. Bei mir startet der Desktop per lightdm Autologin in eine openbox Session, der VDR "trödelt" per gutem alten SysV Init-Script parallel hinterher.


    Bei dem VDR mit der SSD habe ich sogar "ureadahead" ausgeschaltet, es stellte sich raus das Start-Abhängigkeiten nicht stimmten und ohne ist der Start auch schneller ...


    Wichtig ist aber für Dich, hast Du den Desktop mit Unity gestoppt, kommt wieder Unity und vice versa bei openbox. Kontrollieren kannst Du das mit der Datei "~/.dmrc" ... s.o.


    Ton ist bei 12.04 hier alsa, ohne irgendwelche Probleme, bei Trusty mit Kernel 3.13 hab ich noch etwas Stress mit dem Ton. Daher werde ich mal mini73's guess mit pulse probieren, da hatte ich bisher noch gar nicht dran gedacht ...


    Regards
    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von fnu ()

  • Hi,


    also ganz funktioniert das noch nicht wie gewünscht. Egal ob ich openbox oder den Standarddesktop starte hab ich zwar TV Bild aber kein Ton. Ein Neustart vom VDR bringt dann Ton. Das Problem würde ich vorerst hinten anstellen.
    Was wichtiger wäre ist das Problem das Popups vom Betriebssystem das Fenster mit dem TV Bild stören. Egal auf welchem Desktop (openbox oder lightdm) ich den VDR starte springen Popups vom Betriebssystem in den Vodergrund und stören somit das TV Bild. Also irgendwie muss das VDR Fenster in den Vordergrund und darf durch nichts gestört werden.


    Ich kann leider erst nächste Woche weiter basteln...vorab schin mal danke für eure Hilfe.


  • Hi,


    das habe ich ebenfalls so gemacht allerdings bringt das bei mir keinen Unterschied?