[Announce] Plugin squeezebox

  • spar dir erst noch den BT, habe etwas gefunden. Versuche es bitte mit der aktuellen Version aus dem git nochmal.

  • Ich habe das Plugin noch mahl aus dem git aktualisiert.
    Da das Problem ja immer erst nach einer gewissen Zeit auftritt mal abwarten warten.


    Ich hatte übrigens zuvor noch ein dummy png als .png gespeichert. Und festgestellt das mit dieses anstelle des Play Symbols angezeigt wurde.

  • Hallo Jörg,


    vielen Dank für'n BugFix! Segfault ist bei mir weg!
    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV

  • Die Playliste wird bei mir erst beim zweiten Aufruf des Plugins angezeigt, auch mit der neusten Version.

    Gruß
    Frodo

  • Bei mir ist die immer beim ersten Aufruf da, schon komisch das sich das Plugin so unterschiedlich verhält...

    VDR: yavdr-ansible/18.04 LTS auf Intel NUC (BOXNUC6CAYH), 2x Kingston KVR16LS11/4, Harmony 700, yaUSBIR

    VDR-Server: yavdr-ansible/18.04 LTS in ESXi VM


  • Hallo zusammen,


    Die Playliste wird bei mir erst beim zweiten Aufruf des Plugins angezeigt, auch mit der neusten Version.


    um genauer zu sein, es fehlt der Play - Button, das Cover Art vom squeezebox - server und die playlist. Für mich sieht das wie ein Timeout beim ersten connect zum LMS aus. Wenn ich den VDR neu starte ist nämlich alles gut.


    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV

  • Kann es vieleicht daran liegen das squeezelite erst mit dem Start des Plugins gestartet wird?
    Wenn ich im LMS schaue gibt es erst nach dem Aufruf des Plugins den Player "VDR-squeeze". Beim erneuten Aufruf des Plugins kennt LMS den Player bereits und das Plugin findet die aktuelle Playliste.


    Da fällt mir noch ein ich verwende den LMS lokal auf meinem VDR d.h. der LMS wird immer beendet und kann sich somit auch nicht die Player merken.

    Gruß
    Frodo

  • Das wird dann wahrscheinlich die Ursache sein, bei mir läuft der LMS auf einem anderen Server und der ist 24/7 an. Das squeezelite auf dem Client wird bei mir auch nur bei Start des Plugins gestartet...

    VDR: yavdr-ansible/18.04 LTS auf Intel NUC (BOXNUC6CAYH), 2x Kingston KVR16LS11/4, Harmony 700, yaUSBIR

    VDR-Server: yavdr-ansible/18.04 LTS in ESXi VM


    The post was edited 1 time, last by urknall ().

  • Hmmm nein leider auch nicht, hab den Server mal gestoppt und danach wieder gestartet, geht trotzdem bei mir....

    VDR: yavdr-ansible/18.04 LTS auf Intel NUC (BOXNUC6CAYH), 2x Kingston KVR16LS11/4, Harmony 700, yaUSBIR

    VDR-Server: yavdr-ansible/18.04 LTS in ESXi VM


  • geht hier auch immer.
    Hast du in den Fehlermeldungen beim verbinden im log oder meldet er success ?

  • Fehlermeldungen gibt es keine. Der einzige Unterschied ist das ich beim ersten mal die Playliste erst auswählen muss, beim zweiten mal ist diese schon gewählt und die Musik wird sofort wieder gegeben. Anbei das Log mit dem ersten und zweiten Aufruf:

    Gruß
    Frodo

  • Hallo zusammen,


    ... ich habe mir auch gerade mal ein log gezogen. Aber auch zum LOG von Frodo:


    1. Anlauf Zeile 12: Feb 2 17:05:07 vdr4 vdr: squeezebox: Playlist updated, got 0 track


    also hat er nichts zum Anzeigen


    2. Anlauf Zeile 36: Feb 2 17:05:58 vdr4 vdr: squeezebox: Playlist updated, got 9 track


    jetzt gehts.


    Könnte es sein, daß squeezelite erst nach der Abfrage der Playlist gestartet wird, und damit die ID noch nicht bekannt ist?


    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV

  • Gute Idee, so etwas in der Art wird es sein. Als erstes wird der Player gestartet, dann die TCP Verbindung aufgebaut und im Anschluss die erste Abfrage gestartet. Die Verbindung bekommt er wenn der LMS läuft ja auf jeden Fall, kann aber gut sein das die erste Abfrage zu schnell danach erfolgt.


    Wobei, ich sehe gerade was der Player läuft in einem Thread, vermutlich überholt sich das, baue ich morgen um

  • Version 0.0.10:


    - Plugin wartet auf den Player (sollte oben genantes Problem beheben)
    - Lyrics hinzugefügt, werden wenn vorhanden unter dem Cover angezeigt


    Neue Version im git.


    Grüße
    Jörg

  • Habe die neue Version getestet mein Problem ist damit behoben, die zuletzt gespielte Playliste wird nun direkt geladen und abgespielt :]
    Ausserdem ist nach meinem empfinden die Bedienung spürbar schneller geworden.

    Gruß
    Frodo

  • Hallo Horchi,


    funktioniert nun bei mir.
    Vielen Dank!



    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV

  • Hallo Horchi,


    ein kleines Problem hab ich noch:


    Wenn man das Plugin startet und der VDR im Wiedergabe - Mode ist, geht er mit segfault durch 0.
    Der squeezelite - client schnappt sich dabei das ALSA - Device und der Ton ist weg :)


    ggf. solltest Du den Wiedergabe Mode abfangen oder halt vor Plugin - Start beenden.


    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV


  • siehe auch segfault bei softhddevice mit squeezeplug.patch


    eigentlich sollte das funktionieren - bei einer laufenden Wiedergabe sollte vdr bei Aufruf eines neuen Players den laufenden Player mit Playmode 0 beenden, das ist nicht Aufgabe des Plugins. Da ist noch irgendwo der Wurm drin, vermutlich in softhddevice und/oder dem squeezebox-Patch für softhddevice.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!