OpenMediaVault - avahi - Schreibrechte

  • Hi Leutz,


    da ich meinen vmware - Server auf neue Hardware umziehe, probier ich gerade Openmediavault als NAS aus. Darauf soll der vdr-Server aufzeichnen und die Clients (yaVDR) halt die Aufnahmen abspielen können.

    Konfiguration von OMV:

    1. Eine Gruppe "vdr" angelegt und die GID auf "666" verändert.
    2. Dann eine Freigabe "Daten" angelegt und in den ACLs der Gruppe vdr Schreib/Lese Rechte gegeben.
    3. NFS-Dienst konfiguriert und eine Freigabe "Daten" angelegt. Folgende Optionen hab ich vergeben: "sync,no_subtree_check,all_squash,anongid=666,anonuid=666"


    Der yaVDR Client mountet die Freigabe via avahi nun automatisch. Ich kann auch auf die Freigabe schreibend zugreifen. Ein Verzeichnis z.B. wird folgendermaßen angelegt:

    Code
    1. root@vdr-cl-w:~# ls /media/Sonstige/omv-nas/ -lah
    2. insgesamt 12K
    3. drwxrwsr-x+ 3 root users 17 Jan 4 16:45 .
    4. drwxr-xr-x 3 root root 4,0K Jan 4 16:42 ..
    5. drwxrwxr-x+ 2 vdr users 6 Jan 4 16:45 test


    Ich frag mich nun, ob das so passt bzw. ob mann das evtl. besser lösen könnte/sollte? Vielleicht kann mal einer der Exberden was dazu sagen.


    Ich möchte gern ein NAS verwenden um flexibler beim Wechsel des Servers zu sein. So kann ich halt mal eine neue virtuelle Maschine als vdr-Server installieren ohne immer das Problem mit den Aufnahmen zu haben.


    Markus

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner

  • Hey, hat keiner einen Kommentar dazu? Da könnte man ja fast meinen, das ist perfekt?!? Dann werd ich das mal so lassen und weiter machen :-)


    Markus

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner

  • Wie legst Du die Gruppe an? Bei mir habe ich sie zwar angelegt und in der Konsole die gid geändert, aber nun ist die gruppe im WebIF verschwunden, obwohl sie noch da ist. Ein avahi-browse findet zwar den omv aber keine Freigaben.
    Eine Idee?

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

    The post was edited 2 times, last by Torsten73 ().

  • Das passt schon so, wenn du die GID geändert hast, siehst du im WebIF unter Gruppe nichts mehr. Wenn du bei den Freigabe aber auf ACL klickst, kannst du deine Gruppe auswählen.
    Damit das mit den Mounten klappt, brauchst du natürlich eine /etc/exports. Die wird aber automatisch angelegt. Bei mir sieht sie so aus:



    Anschließend noch die services unter /etc/avahi/services definieren. Bei mir momentan z.B. nfs-vdr.service: (von den yaVDR-lern geklaut :gap )


    Das wars auch schon. Der VDR-Server mountet nun das Verzeichnis vom NAS und ich kann auch darauf aufnehmen.

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner

  • Aha, das hätte mich auch gewundert, wenn omv direkt passende avahi services hätte. Dummerweise habe ich kein ssh zugrif per telnet, dann hätte ich das direkt ergänzt.
    Damit ist die Einrichtung, dann ja wirklich flott geschafft.


    Aber es wäre ja langweilig, wenn alles mal auf Anhieb laufen würde, bei mir bricht der Kopiervorgang vom alten SBS2003 auf den OMV per Samba jedes mal nach 1h ab. Mit Netzlaufwerk nicht erreichbar. Mal sehen was das wieder ist. Vielleicht liegt es an der VM weil sowohl Raid als auch eth0 sind mit pci passtrough an omv durchgereicht.


    Edit: Ah fein im WebIF kann man SSH aktivieren :-), dann bin ich ja mal gespannt heute abend ob die VDR den finden.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

    The post was edited 1 time, last by Torsten73 ().

  • Ja, man bräuchte ein yaVDR-OMV, das wärs :D .


    Würde die ganze manuelle Arbeit ersparen...

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner