yavdr does not play recordings after update

  • Hi there,


    I just updated my yavdr and now the recordings won't play. I discovered that removing the index file helps for 1 time. If trying to re-play (after waiting the index file to be automatically re-created) it just crashes the vdr:



    Dec 9 12:32:53 tallennin vdr: [7072] [extrecmenu] starting replay of recording
    Dec 9 12:32:53 tallennin vdr: [7072] replay /srv/vdr/video.00/Top_Gear/2013-12-07.17.48.3-0.rec
    Dec 9 12:32:53 tallennin vdr: [7072] playing '/srv/vdr/video.00/Top_Gear/2013-12-07.17.48.3-0.rec/00001.ts'
    Dec 9 12:32:53 tallennin vdr: [7072] loading /srv/vdr/video.00/Top_Gear/2013-12-07.17.48.3-0.rec//marks
    Dec 9 12:32:53 tallennin vdr: [7072] loading /srv/vdr/video.00/Top_Gear/2013-12-07.17.48.3-0.rec//marks
    Dec 9 12:32:53 tallennin vdr: [7072] ERROR: attempt to open OSD while it is already open - using dummy OSD!
    Dec 9 12:32:53 tallennin vdr: [7736] Text2Skin: replayInfo display update thread started (pid=7072, tid=7736, prio=high)
    Dec 9 12:32:53 tallennin vdr: [7735] Text2Skin: menu display update thread ended (pid=7072, tid=7735)
    Dec 9 12:32:53 tallennin vdr: [7737] dvbplayer thread started (pid=7072, tid=7737, prio=high)
    Dec 9 12:32:53 tallennin vdr: [7737] resuming replay at index 2268 (0:01:30.19)
    Dec 9 12:32:53 tallennin vdr: [7738] non blocking file reader thread started (pid=7072, tid=7738, prio=high)
    Dec 9 12:32:53 tallennin kernel: [ 4262.211014] Text2Skin: repl[7736]: segfault at 78 ip 00007f48fa22485e sp 00007f48edb13a30 error 4 in libvdr-text2skin.so.
    2.0.0[7f48fa201000+52000]
    Dec 9 12:32:53 tallennin kernel: [ 4262.380061] init: vdr main process (7072) killed by SEGV signal
    Dec 9 12:32:54 tallennin kernel: [ 4262.716980] init: vdr-frontend main process (7200) terminated with status 1
    Dec 9 12:32:54 tallennin vdr-crash: vdr exit with signal SEGV . Restarting
    Dec 9 12:32:54 tallennin kernel: [ 4262.879004] init: vdr-exit-other main process (7739) terminated with status 1
    Dec 9 12:32:55 tallennin vdr: [7743] VDR version 2.0.3 started


    I'm using yavdr with the default settings as usual. This happens with all my hard disks no matter if it was usb or internal. I ran the check in my root hard disk where the most recent recordings are stored. The disk seems to be fine. If I "mv /usr/lib/vdr/plugins/libvdr-extrecmenu.so.2.0.0 /tmp/" and restart vdr I can play the recordings all over again but I loose (obviuously) the features of the extrecmenu.


    I've been using vdr for 10 years and yavdr for 3 years and never experienced this before. Is vdr really so fragile that updating it along with its plugins causes all the recordings fail to play?


    This complaint is mainly for the yavdr people who should have taken care of at least the basic testing before deploying the package out to the world. And sorry for pointing the finger here but I just had 2 sons pointing their finger at me for not being able show the recordings of their liking...


    I'll contact exctrectmenu people also to get this straight. In the mean time has anybody figured out some workaround here?


    BR,
    Sami

  • Hi,


    Did you do

    Code
    1. sudo apt-get update
    2. sudo apt-get dist-upgrade


    "apt-get update" will not work with yavdr.


    Do you have any other plugins installed which are not in the yavdr-PPAs?
    If so, have you rebuild them against the current vdr-dev?


    For some users there seem to be problems with text2skin, please deactivate it in /etc/vdr/plugins/order.conf (add a line "-text2skin") and try another skin.


    Lars.

  • Hi Lars,


    and thanks for the quick reply. Yes I did the update with the commands you said. Previously those commands have been working ok. I use templates to preserve my personal settings and those have been working ok also. Removing text2skin unfortunately caused the menu defaulting to old basic one with wrong scale. Switched it back. I guess I'll have to wait for the extrecmenu upgrade...


    BR,
    Sami

  • This complaint is mainly for the yavdr people who should have taken care of at least the basic testing before deploying the package out to the world. And sorry for pointing the finger here but I just had 2 sons pointing their finger at me for not being able show the recordings of their liking...


    What makes you believe that you have any rights to complain? You didn't pay for the software, neither have you paid us. Never ever has a yaVDR member promised that yavdr is error free, or fulfils your needs. It is no secret that yaVDR is made by the yaVDR team, for the yaVDR team. We only allow you to use it. If you don't like it then let it. This is the only right you have.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Hi Gerald,
    I'm sorry for making you feel bad. I'd be happy to join the testing group. yaVDR is by far the best alternative for those commercial tryouts. I have been enjoying it for several years now and I can't tell you how much I appreciate your work.


    Just wanted to share my experiences here to make it even better. Also sorry for being too straight forward - I have to work on that. It's just in my (Finnish) nature just to point the error.


    With all my regards,
    Sami

  • The segfault is most likely caused by text2skin, not extrecmenu. The Bug regarding "ERROR: attempt to open OSD while it is already open - using dummy OSD!" is known but it has been reported not to have any effects on replaying a recording: http://projects.vdr-developer.org/issues/1254

    This complaint is mainly for the yavdr people who should have taken care of at least the basic testing before deploying the package out to the world.

    We had those packages for several months in testing-vdr (every yaVDR user interested in testing new packages can change the package sources to testing-vdr, testing-yavdr and testing-xbmc) and as far as I know nobody created a bugreport regarding this issue with text2skin in our bugtracker.
    Can you provide a backtrace for the crash (see http://www.yavdr.org/documentation/0.5/en/ch03s08.html for details)


    Which text2skin theme do you use? Is it from a yaVDR package or do you use a custom one?

    Removing text2skin unfortunately caused the menu defaulting to old basic one with wrong scale.

    Is this an overscan issue which can't be fixed using proper settings for your TV? Then set an overscan compensation using the nVidia drivers in the webfrontend: http://www.yavdr.org/documenta…en/ch02s04.html#wfe-video

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • I am using the default yaVDR installation 0.5 with the latest updates (apt-get update & apt-get dist-upgrade). Original text2skin theme is in use I have not changed anything. And the recordings can be seen ok with the other clients (nfs share). I don't think it is an overscan issue since the recordings showed up properly before the update. Vdr behaviour was normal in the backtrace.


    BR,
    Sami