[Announce] epgd-0.1.4 / epg2vdr-0.1.3 - Advent, Advent...

  • Ich habe mir gerade einen PIN für epgdata gekauft (das geht jetzt endlich stressfrei via PayPal) und wollte Multi Merge aktivieren. Jetzt stellt sich mir die Frage: "Welcher Provider liefert bei welchem Kanal die besten Ergebnisse (was das EPG angeht)?". Gibt es da schon Erfahrungswerte?

  • ich hab überall den mit den vielen Bildern als Hauptprovider - kann dir aber sofort 5 Leute nennen die meinen das es andersrum besser ist, speziell bei ORF


    Am besten selber ne Meinung bilden...


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • [...] Gibt es da schon Erfahrungswerte?


    das Ganze ist eher eine Geschmacksache. Mir persönlich gefallen die Bewertungen von TVM besser, weshalb ich TVM fast überall als Hauptprovider habe.


    Leider aber sind die Österreicher bei TVM, vor allem an den Wochenenden, nicht sehr aktuell, weshalb ich da epgdata als Hauptprovider habe.


    Die EPG Daten als solches, also was die Beschreibung des Inhaltes der Sendungen angeht, würde ich bei beiden als gleichwertig bezeichnen.

  • Irgendwie blick ich es nicht, einige Sender sehe gut aus, andere wie RTL nicht, dort gibt es doppelte EPG Einträge. Meine channelmap.conf sieht (für RTL als Beispiel) so aus:



    Im README habe ich nichts weiter zu mergen gefunden und richtige Beispieldateien fehlen irgendwie auch.

  • Moin,
    Lass mal die vdr-Zeilen weg. Wenn du eine passende tvm hast, wird automatisch mit dem EPG vom DVB gemischt.


    Cheers,
    Ole


    Sent from my GT-I9001 using Tapatalk

  • ich vermute das Ding ist jetzt so strubbelig das es nen Neuanfang mit epgd-dropall bedarf...


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Hallo,

    ich vermute das Ding ist jetzt so strubbelig das es nen Neuanfang mit epgd-dropall bedarf...

    das habe ich vor jedem Test gemacht damit es da nicht zu Mischmasch kommt. Wenn jemand ein paar Ausschnitte aus einer funktionierenden Config hätte oder den passenden Thread (den ich schon versucht habe zu finden) ...

  • Ich meinte eine Zeile mit tvm in der Config. Wenn die vdr-Zeilen der letzte Versuch waren, würde ich mich Christian anschließen. Die channels.conf bereinigen, epgd-dropall und sauber starten.


    Cheers,
    Ole


    Sent from my GT-I9001 using Tapatalk

  • So, jetzt die gewünschten Änderungen wie vorgeschlagen durchgeführt. Für SAT.1 sieht die channelmap.conf jetzt so aus:


    Zuerst "service vdr stop", dann "service epgd stop" und danach ein rm /var/cache/vdr/epg.data und epgd-dropall.Dann wieder "service epgd start" und gewartet und dann ein "service vdr start". Trotzdem gibt es noch reichlich dopppelte EPG Einträge, als Beispiel zeige ich hier SAT.1 (siehe Bild). Ich nutze zur Zeit die Version "2014-01-03: version 0.1.10".

  • gibt 100 Gründe - welche VDR Version und welche Patche drin, welche anderen Plugins geladen?


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Ich nutze einen vdr 2.0.5 (ohne Patches, selbst compiliert). Folgende Plugins werden (via runvdr) geladen:


    Code
    1. AddPlugin live
    2. AddPlugin streamdev-server
    3. AddPlugin epgsearch
    4. AddPlugin dummydevice
    5. AddPlugin skincurses
    6. AddPlugin epg2vdr
    7. AddPlugin svdrposd
    8. AddPlugin remote -p tcp:3333
    9. AddPlugin markad
    10. AddPlugin xvdr
  • na und was hast du nun falsch gemacht, nicht das Readme gelesen? ;)


    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Jetzt habe ich das README nochmal komplett durchgelesen. Und ich habe übersehen, dass der wichtige Hinweis wohl im EPG2VDR Plugin war. Dort ist der Patch für den VDR erwähnt des es braucht wie es aussieht. Nach dem letzten epgd-dropall und Reload sieht es besser aus. Ich habe mich dummerweise beim epgd festgebissen ...


    Also ein klarer Fall von RTFM. Danke an die Geduld der beteiligten.

  • Hi - ich hatte heute :



    ein manueller telnet auf eplists lief aber "ganz normal" -


    nach etwas Such3e im Code habe ich dann hier:in svdrpclient.c:


    Code
    1. ...
    2. int cSvdrpClient::receive(cList<cLine>* list)
    3. {
    4. int timeoutMs = 20 * 1000;
    5. // #TODO iconv !!!
    6. ....


    aus der 20 eine 100 gemacht - dann gings wieder - vielleicht sollte man das als Parameter hinterlegen?

  • Code
    1. epgdata:765 // ProSieben Fun HD


    Christian

    Images

    • pro7fun.png

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Logo gibts auch als HD...


  • Aktuell gibts Probleme mit tvm-Plugin. Auf dem Server sind viele der XML-Dateien leer. Aussderm startet bei mir das Update alle paar Sekunden neu. Wie siehts bei euch aus?



    EDIT: Hat sich erstmal erledigt, nach einem Neustart des epgd läufts wieder.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 1 time, last by TheChief ().

  • Was hab ich den da wieder angestellt


    Code
    1. Mar 05 20:30:35 [vdr] EPG2VDR: SQL-Error in 'execute(stmt_execute)' - Deadlock found when trying to get lock; try restarting transaction (1213) 'Deadlock found when trying to get lock; try restarting transaction' [update events set delflg = ?, updflg = ?, updsp = ? where channelid = ? and source = ? and starttime+duration > ? and starttime < ? and (tableid > ? or (tableid = ? and version <> ?));]
    2. - Last output repeated twice -


    seither findet auf dem vdr kein update mehr statt

    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO