[ANNOUNCE]Fritz!Box Anrufmonitor für XBMC/Kodi

  • dippes , moppi1988: Habe mal die 1.3.4 hochgeladen, die eine geänderte Authentifizierung benutzt. Wenn damit die Anzeige von Anruferbildern nicht klappt, bin ich raus...


    BJ1

  • Jetzt wird nix mehr angezeigt


  • Jetzt wird nix mehr angezeigt


    Hab's geändert. Nochmal rüber installieren. Danke für die Bereitschaft zum Testen.


    BJ1

  • Name mit Tel Nr wird angezeigt,aber leider ohne Bild.

  • Hallo BJ1,


    Alles OK mit die letzte Version (requests-module).


    Nochmals vielen Dank für dieses Addon.


    Freundlichen Gruss,


    Steven

    VDRserver : Asrock n3700 + 8 GB ram + HDD Toshiba 3 TB (video) + 2 x 500 Gb (home) + Sandisk SSD 64 GB (OS) + Digital Devices Octopus Cine S2 + DD DVB T/T2-Operating System : Ubuntu Server (headless) 14.04 64 bit mit stable yavdr ppa


    VDRclient : Wetek Hub mit Libreelec (8.2 community build von kszaq)

  • Hab's geändert. Nochmal rüber installieren. Danke für die Bereitschaft zum Testen.

    Tja, leider geht auch das nicht. Kein Anrufbild. Ich habe zwischenzeitlich schon mal das Passwort ganz aus der FB rausgenommen, aber das hat auch nicht geholfen.


    ICE: service.fritzbox.callmonitor: trying to resolve name from incoming number 01520xxxxxxx
    07:58:03 T:3652 NOTICE: service.fritzbox.callmonitor: Match an entry in database for 01520xxxxxxx
    07:58:03 T:3652 NOTICE: service.fritzbox.callmonitor: There's a picture in database, getting it from https://fritz.box:49443/download.lua?path=/var/InternerSpeicher/FRITZ/fonpix/1403986217-0.jpg&sid=0b2239a02a2393b1
    07:58:03 T:3652 NOTICE: service.fritzbox.callmonitor: Force login to prevent possible timeouts, need to download some data
    07:58:04 T:3652 NOTICE: service.fritzbox.callmonitor: Getting 80 entries from fritz.box
    07:58:04 T:3652 NOTICE: service.fritzbox.callmonitor: Incoming call from Uwe Handy (01520xxxxxxx)


    Ein wenig komisch ist: Wenn XBMC im Hintergrund noch läuft (also das addon aktiv ist und auf die FB lauscht), dann kann ich im Webbrowser o.a. Bild-URL öffnen und sehe das Bild.
    Wenn ich das gleiche mache, wenn XBMC nicht läuft, oder auf einem anderen Computer, dann sehe ich im Browser:


    <s:Envelope s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError><errorCode>606</errorCode><errorDescription>Action Not Authorized</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>


    Außerdem sehe ich eine Fehlermeldung in der Ereignisübersicht der FB, die in der Hilfe hier beschrieben wird.

  • Einige kleinere Verbesserungen im Handling beim Trennen einer Verbindung. Niederländische Sprachdatei hinzugefügt. Vielen Dank an Ruud Bakker.
    Download wie gehabt (Post #1).


    BJ1

  • Muss mich jetzt melden....


    Seit ich auf Kodi umgestiegen bin und alles neu gemacht habe funktioniert es mit dem Bildchen.


    Hat wohl was mit der Konfiguration allgemein zu tun gehabt.


    Danke.

  • Ich habe die 1.3.6 mit yavdr 0.5 (alles stable bis auf Kodi von seahawk) und dort wird das Abspielen von Filmen bei einem Anruf
    nicht wie eingestellt angehalten. Pausiere per FB vor dem abnehmen, wird das Abspielen beim Abheben fortgesetzt.


    Hat jemand einen Tipp? Klappt es bei anderen mit Kodi 14.0, daß das Abspielen von Filmen bei einem Anruf korrekt pausiert wird?

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Pausiere per FB vor dem abnehmen, wird das Abspielen beim Abheben fortgesetzt.


    Das ist der API von XBMC/Kodi geschuldet. Der Befehl "Pause" toggelt jeweils je nach Zustand zwischen Pause und Play. Die Play-Funktion des internen Players selbst ist verbugt. Hier kann es passieren, das nach Aufruf von Player.Play() nicht etwa der angehaltene Videocontent weiter abgespielt wird, sondern stattdessen die Musikwiedergabe startet.


    Ist erstmal (leider) so...
    BJ1

  • Hallo,


    habe Dein Addon heute auf dem Mac installiert! Es funktioniert in den Grundfunktionen auch wie gewünscht! Allerdings klappt das mit dem Telefonbuch nicht. Kann es daran liegen, dass ich auf der Box ein Telefonbuch von Google eingerichtet habe?!

  • Externe Telefonbücher (auch Google) sollten eigentlich funktionieren. Kannst Du mal die Konsole anwerfen und die Ausgabe von (XBMC):

    Code
    1. more .xbmc/temp/xbmc.log | grep -i fritzbox


    bzw. Kodi:

    Code
    1. more .kodi/temp/kodi.log | grep -i fritzbox


    hier posten?

  • Code
    1. Error Type: <class 'resources.lib.PytzBox.PytzBox.BoxUnreachableException'>


    Das Skript (bzw. das Pytzbox-Modul) kommt nicht auf die Box. Bitte mal die Einstellungen zur Fritz im Plugin überprüfen (User, Passwort).

  • Das sind die selben, die ich auch für die (Fritzbox-)Oberfläche verwende. Identische Zugangsdaten. Der Nutzer hat auch vollen Zugriff auf die Box.
    Es hat auch nicht funktiuoniert, als ich den Zugang zur Fritzbox nur auf "Passwort" geändert hatte.


    Ich vermute, es liegt an der Box selbst. Kabel Deutschland sperrt ja einige Dinge auf den eigenen Fritzboxen. Wahrscheinlich funktionierts deswegen nicht. Ich habe es jetzt mal mit der Fritzbox meiner Schwiegereltern versucht, die ich per VPN im Netz habe. Dort wird kein Fehler gemeldet :-(

  • Kurzer Nachtrag zu dem Pause Problem:


    Nach dem Upgrade von Gotham auf Kodi habe ich inzwischen festgestellt, daß auch die Pause/Play Taste einer Hama MCE FB nicht mehr Videos pausiert. Bei der Hama FB ist die Play und Pause Taste identisch und es wird eigentlich nur PLAY an XBMC gesendet, nur daß dies bei Kodi Videos nicht mehr pausiert. Ich musste in remote.xml unter <FullscreenVideo> zusätzlich <play>Pause</play> eintragen, damit die Pause/Play Taste die Videos pausiert und damit klappt das Pausieren jetzt auch plötzlich mit dem Call Monitor. Irgendeine Idee wo ich den entsprechenden Eintrag beim Abspielen von Music in remote.xml einfügen muss? Bislang waren alle Versuche erfolglos....

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Versuche das mal unter <global> abzulegen:


    Code
    1. <keymap>
    2. <global>
    3. <remote>
    4. <play>Pause</play>
    5. </remote>
    6. </global>
    7. </keymap>
  • Hallo zusammen!


    Leider bekomme ich auch einen Fehler:

    Code
    1. ERROR: service.fritzbox.callmonitor: UnicodeEncodeError('ascii', u'\u202a+49[hierstandeineNummerdieichnichtkenne]\u202c', 0, 1, 'ordinal not in range(128)')


    War das nicht auf Umlaute zurückzuführen? Und war das Problem nicht eigentlich schon behoben?!?


    Danke für eure Hilfe!


    BK