/var/run/lirc/lircd: No such file or directory

  • Hallo zusammen,


    gestern kam ja das Update auf 2.0.3 in die Repos. Natürlich hab ich das gleich installiert ... ;-) Nun wird mein Syslog aber mit unten stehenden Meldungen überflutet.

    Code
    1. Oct 27 09:48:06 bruno vdr: [24434] ERROR (lirc.c,43): /var/run/lirc/lircd: No such file or directory


    Wie werde ich die Meldung denn los? Benötige auf dem Server kein LIRC. Hab ich Möglichkeit, den Start-Parameter vom vdr soweit anzupassen, das er ohne


    Code
    1. --lirc=/var/run/lirc/lircd



    started?

  • Versuch mal in der /etc/default/vdr so eine Zeile einzufügen:

    Code
    1. LIRC=""

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Auf einem normalen Ubuntu Server (steht zumindest in seiner Signatur) dürfte er keine Templates haben.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Versuch mal in der /etc/default/vdr so eine Zeile einzufügen:

    Code
    1. LIRC=""

    geht leider nicht. Jetzt läuft vdr zwar nur noch mit --lirc, ohne Parameter, aber im Logfile sind noch immer die Meldungen:


    Code
    1. Oct 27 10:06:30 bruno vdr: [32312] ERROR (lirc.c,43): /var/run/lirc/lircd: No such file or directory

  • Ok, wie startest du denn den vdr? Über Upstart oder /etc/init.d/vdr? Dann musst du dir das passende Startscript vornehmen und dafür sorgen, dass "--lirc" nicht an den vdr übergeben wird.


    Lars.

  • Wie startest du den VDR? Das aktuelle Upstart-Skript (liegt dem vdr-Paket aus stable/testing in /usr/share/doc/vdr/examples/vdr-upstart bei und sollte nach /etc/init/vdr.conf kopiert werden) setzt "--lirc" eigentlich nicht als Start-Argument, wenn LIRC nicht definiert oder leer ist.

    Code
    1. if [ -n "$LIRC" ]; then
    2. OPTIONS="--lirc=$LIRC $OPTIONS"
    3. fi

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ok, wie startest du denn den vdr? Über Upstart oder /etc/init.d/vdr? Dann musst du dir das passende Startscript vornehmen und dafür sorgen, dass "--lirc" nicht an den vdr übergeben wird.


    Lars.

    So, habs jetzt erstmal in /etc/init.d/vdr kommentiert. ;-) damit ist der Eintrag im Logfile erstmal weg, auch wenn's nicht sonderlich schick ist :) Damit ist es erstmal reboot-fest, vmtl. nicht Update-fähig.


    THXle

  • /etc/init.d/vdr fassen wir eigentlich nicht mehr an, das wird nur dann installiert, wenn man kein Upstart hat.
    Ist also nur für die Leute wichtig, die unser Paket nach Debian portieren. Aber die Debianer werden wohl eher Tobis Pakete benutzen. :)


    Hauptsache es läuft und du weißt jetzt, warum.


    Lars.