Start Problem vdr-frontend mit xineliboutput

  • Hallo mal wieder,


    habe aktuell noch das Problem mit xineliboutput und hdmi sound im WFE, dass beim Start des VDR, ein blinkender Cursor für ca. 2 Minuten anhält.
    Danach kommt kurz "No Signal", aber dann gehts. Allerdings muss doch nachvollziehen zu sein, welches Gerät/Einstellung das Problem verursacht.


    Kernel.log

    Quote

    [ 7.648128] init: vdr-frontend main process (1615) terminated with status 250
    [ 7.648153] init: vdr-frontend main process ended, respawning
    [ 11.191201] init: vdr-frontend main process (1697) terminated with status 250
    [ 11.191227] init: vdr-frontend main process ended, respawning
    [ 14.723514] init: vdr-frontend main process (1759) terminated with status 250
    [ 14.723538] init: vdr-frontend main process ended, respawning



    Habe schon rumgetestet mit verschiedenen Plugins in der order.conf.
    Text2Skin-plugin ist deinstalliert. Sleep im /etc/init/vdr-frontend.conf eingefügt.
    Verschiedene Anordnungen in der vdr-frontend.conf probiert.


    Wenn ich im WFE was anders wie xineliboutput nehme z.B. softhddevice kommt erstmal die Fehlermeldung "Fehler beim speichern der Daten" beim speichern und auch kein Bild/Ton.
    Sobald wieder zurückgewechselt wird auf xineliboutput -> blinkender cursor


    Kann das was mit der SSD zu tun haben?


    Alles ohne Erfolg.... vll. weiß jemand noch Rat?


    Danke mal wieder

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Hallo mini73 und danke für die schnelle Rückmeldung.
    Hier die gewünschten Infos. Allerdings bemängelt er Nvidia, hier ist aber nur Onboard Intel im System?
    /var/log/upstart/vdr-frontend.log


    vdr-frontend.conf


    Danke!

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

    The post was edited 1 time, last by mini73 ().

  • Allerdings bemängelt er Nvidia, hier ist aber nur Onboard Intel im System?

    Na dann weißt du ja wo es hängt. Wir unterstützen OOTB nur die Ausgabe über VDPAU mit nVidia-Grafikkartne, das steht auch auf yavdr.org

    HDTV and XBMC in your living room - based on Nvidia VDPAU, VDR and Ubuntu Linux

    sowie in der Dokumentation und im Wiki


    Also darfst du dir eigenverantwortlich das System so hinbasteln, dass es mit der Intel-Onboard Grafikkarte läuft (oder du kaufst dir eine passende Grafikkarte). Ich habe das bislang nur bei Virtuellen Maschinen gemacht, generell würde ich den nVidia-Treiber deinstallieren

    Code
    1. sudo apt-get remove ^nvidia

    falls nötig die /etc/X11/xorg.conf.yavdr anpassen und in den XINELIBOUTPUTOPTS (siehe https://github.com/yavdr/yavdr…tput-05-xineliboutputopts ) noch eine Möglichkeit zur Videoausgabe mitgeben, die die Intel-Grafikkarte unterstützt, z.B.

    Code
    1. XINELIBOUTPUTOPTS="--video xv --post tvtime:method=Linear,cheap_mode=1,pulldown=0,use_progressive_frame_flag=1 --reconnect --audio=alsa --syslog --silent --tcp"


    Ich weiß nicht aus dem Kopf, ob die xinelib bzw. xineliboutput in stable-vdr noch vaapi unterstützt, falls ja wäre das vermutlich die bessere Wahl.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Hallo,


    danke mal wieder seahawk.
    dann kann das mit meinem aktuellen Wissensstand wohl eher heiter werden :)


    Hab mal folgende Dateien abgeändert, bin nun auf diesem Stand. Hoffe ich hab richtig angepasst?
    Aber beim Start von VDR blinkt der Cursor ca. 2 Minuten lang, dann kommt erst ein Bild. Sonst noch eine Idee?


    /etc/init/vdr-frontend.conf

    /etc/X11/xorg.conf.yavdr

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Noch ein Hinweis. Ein stop vdr funktioniert. Aber ein vdr start bringt folgende Meldung:


    vdr: no primary device found - using first device!


    Dann hilft nur noch ein reboot.

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Noch ein Hinweis.

    Bevor das jetzt ein Agatha Christie-Roman wird, zeig doch bitte mal das Log von so einem fehlgeschlagenen Startversuch. Damit der Syslog-Daemon nichts wichtiges wegwirft (mit den Standard-Einstellungen von Ubuntu macht er das gerne mal, wenn der VDR crasht) füge bitte zuvor diese Zeilen in die /etc/rsyslog.conf ein:

    Code
    1. # Don't skip messages
    2. $IMUXSockRateLimitBurst 10000
    3. $SystemLogRateLimitInterval 10
    4. $SystemLogRateLimitBurst 10000


    Und dann bitte das Syslog posten (siehe http://www.yavdr.org/documentation/0.5/de/ch06s01.html ) und das aktuelle /var/log/upstart/vdr-frontend.log

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • :D Agatha Christie-Roman ist nun im Anhang. Sorry.
    Danke dir!

    Files

    • vdr-frontend.conf

      (2.67 kB, downloaded 58 times, last: )
    • syslog.txt

      (142.26 kB, downloaded 133 times, last: )

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Konnten die Logs helfen?

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Sieht so aus, als würde da der VDR beim Start gar nicht anlaufen, das vdr-frontend aber trotzdem gestartet werden.
    Hast du noch eine first-vdr-start.conf ? Falls ja lösch die mal.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Abermals danke. Hab aber unter /etc/init/ keine first-vdr-start.conf

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Wie sieht deine /var/lib/yavdrdb.hdf aus?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • siehe Anhang

    Files

    • yavdrdb.txt

      (928 Byte, downloaded 48 times, last: )

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Welcher Skin ist im VDR eingestellt?

    Code
    1. grep OSDSkin /var/lib/vdr/setup.conf


    Hast du einen der Skins skinnopacity, skinflat oder skinflatplus installiert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nein, text2skin plugin ist deaktiviert.


    Output
    grep OSDSkin /var/lib/vdr/setup.conf

    Quote

    OSDSkin = anthra_1920_FSE

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Nein, text2skin plugin ist deaktiviert.


    Das hat ja mit den anderen genannten Skins nichts zu tun, das sind eigenständige Plugins:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ok sorry. hier die ausgabe bei mir.


    Code
    1. media@media-pc:~$ dpkg -l 'vdr-plugin-*skin*'
    2. Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
    3. | Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
    4. Halb installiert/Trigger erWartet/Trigger anhängig
    5. |/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
    6. ||/ Name Version Beschreibung
    7. +++-==============-==============-============================================
    8. rc vdr-plugin-ski 0.0.1+git20120 Skin plugin for VDR
    9. un vdr-plugin-tex <keine> (keine Beschreibung vorhanden)

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • machts vll. noch Sinn die Logs vom Wechsel auf softhddevice oder xine zu posten? die zwei funktionieren ja beide nicht.

    Media-PC: Mystique SaTiX-S2 Sky Xpress :: Gigabyte GA-Z68MA-D2H-B3 :: Intel Core i3 2120T 2x 2.60GHz :: Intel 3000 onboard :: OCZ Vertex 60 GB SSD :: Antec VERIS EZ IR-RECEIVER + Logitech Harmony 300 :: yavdr 0.5a

  • Ja, probier da mal jeweils /var/log/syslog und /var/log/upstart/vdr-frontend.log zusammenzutragen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)