Hardware-wakeup die 4.

  • Ok,
    das werden wir schon hinkriegen :].
    Ich muß gleich weg. Aber überprüf doch mal folgendes:
    - ist die LED richtig angeschlossen oder der Transistor
    - oder hast du vielleicht ne kalte Lötstelle auf der Platine
    ansonsten:
    programmier den Controller mal mit dem "Wakeup_2313_auto_on.hex", mach den Programmer ab, nimm die Stromversorgung vom Controllerboard weg (so für 30Sek.) und schalt dann wieder ein. Jetzt muß die LED, wenn alles richtig verdrahtet ist, 2-3 mal aufleuchten und dann der Rechner einschalten.
    melde mich dann später noch mal
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Hallo asmodeus,
    ich glaub du hast da doch ein kleines Problem in der Schaltung. Ist ja leicht zu überprüfen. Sind nicht so viele Teile ;).
    Also das wird schon klappen. Ein gutes Dutzend haben das jetzt schon nachgebaut und es hat bei allen letztlich funktioniert. Aber es gab auch bei Anderen Probleme (ist für manche das erste "Lötprojekt" gewesen und das direkt mit nem µC :respekt). Bei dir wird das bestimmt auch funktionieren!!
    Vor allem ist der Gewinn halt sehr groß, so daß sich ein gewisser Aufwand lohnt :].
    Wenn alle Stricke reißen schickst du mir die Schaltung zu und ich check es mal durch. Aber wenn du den Controller schon programmiert bekommen hast, kann kein großes Problem vorliegen.
    Also bleib am Ball
    Bis dahin
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Hallo,


    einen schwerwiegenden Fahler habe ich gefunden. Ich Drops habe einen 47k Widerstand statt 4,7k eingelötet. Nun habe ich leider ein Problem. Zur Auswahlt steht nur noch ein 8k und ein 1k. Der 8k scheint wohl auch zu hoch zu sein, jedenfalls keine Besserung. Ich weiß nun nicht ob der 1k vielleicht zu niedrig ist?

  • Hi asmodeus,
    Ja gut, kann passieren. Das macht auch nichts, ist nicht schwerwiegend, weil nix kaputt geht ;). Bau zunächst mal den 8k Widerstand ein, kannst wenn's damit nicht klappt einen zweiten 8K parallel anlöten. Das betrifft aber nur die Kommunikation mit dem Controller.
    Aber das ändert nichts an der Tatsache, das die LED beim Einschalten der Stromversorgung und dem richtigen *.hex-File zweimal kurz aufleuchten muß. Ist die LED richtig herum angeschlossen? Man kann die ja auch mal verdrehen. Stimmen denn die anderen Widerstände? Die LED braucht z.B 470 Ohm, also Gelb-Lila-Schwarz. Nich das da auch ein 47k drin ist.
    Und schau mal ob du nicht irgendwo ne Brücke gelötet hast.
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Ich habe 2 LED´s parallel miteinander verbunden, jeweils anderst rum. Aber die leuchten nicht. Ich bin die Schaltung nochmals durchgegangen und mit einem Meßgerät überprüft. Leider keinen weiteren Fehler gefunden.
    Was mich absolut stutzig macht ist, wenn ich einmal die Spannung an verschiedenen Punkten messe ich fast überall knapp 5 V habe??? Entweder bin ich zu blöd zum messen und verdrahten oder der Chip hat einen weg.

  • Zitat

    Ich habe 2 LED´s parallel miteinander verbunden, jeweils anderst rum


    na du hast ja vielleicht Ideen ;D
    Wenn du da unsicher bist, nimmst du den 1k Vorwiderstand und schließt die LED damit an eine z.B. 9V Batterie an und schaust wann die leuchtet. Damit identifiziert man die Anode (also Plus). Die Anode muß in der Schaltung an 5V.
    Übrigens Die Farbringe für 470 Ohm sind entweder gelb-lila-schwarz-schwarz oder gelb-lila braun. Hab eben nicht aufgepasst.


    Zitat

    an verschiedenen Punkten messe ich fast überall knapp 5 V


    wo denn? Am Controller kann das sein, weil die Zustände der Ports meist so sind. Das ist aber im Betrieb nicht ganz ungefährlich, weil zwei der Ports als Ausgang beschaltet sind. Die solltest du nicht kurzschließen, wäre u.U. nich gut für den Chip.

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • So, kurzes Erfolgserlebnis. Habe nochmals beschrieben und Strom rein und raus. Siehe da die LED hat 3mal geblinkt.
    Werde das morgen am Multitainer austesten.


    Die 5V habe ich am Power Jumper gemessen, an den LED´s und am Transistor. Das irritiert mich, gearde am Power Jumper.

  • Na also, geht doch. Super!!
    Bevor du das am "Objekt" testest mach mal folgendes. Die 5V am Power-Jumper sind ok, der Controller zieht wenn die LED ausgeht diesen Pin für ne halbe Sek. auf Ground. Schau mal kurz ob das bei dir auch so ist. Dann wissen wir ob da alles richtig läuft. Ich wart mal so lange ;). Aber laß dir Zeit.

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Nur das wir uns richtig verstehen, der Power-Jumper im Schaltplan ist der, der über den 1k Widerstand an PIN 16 angeschlossen ist. Der sollte / müsste für die halbe Sekunde auf 0V gehen.

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Achso genau anderst rum. Beim einschalten auf 0V, sonst ständig.


    Wenn ich den Speicher lösche so liegen auch keine 5V mehr an. es scheint das der Controller korrekt schaltet.
    Werde morgen weiter testen.

  • Genau, 0V für eine halbe Sekunde. Du machst ja nix anderes wenn du den Power-Knopf am Rechner drückst. Den schließt du einfach nach GND kurz, solange der Knopf gedrückt ist. Also beachte bitte die Polung im Rechner!! Aber bau das Ding ruhig ein, nachdem du den 47k Widerstand ausgetauscht hast.
    Und

    Zitat

    Wenn ich den Speicher lösche so liegen auch keine 5V mehr an


    Den braucht du nicht vor jedem Gebrauch neu zu programmieren :D, das geht auch nur ca. 1000 mal ;D
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Hallo Steini!


    Wollte nächstes Wochenende meinen Multitainer-VDR derart umbauen, dass der LIRC-Empfänger entfällt und der TSOP über den J2-Connector mit dem VDR verbunden wird.


    Da ich meine Multitainer-FB nicht im Wohnzimmer liegen habe, wo der VDR steht, würde es mich interessieren, ob es eventuell möglich wäre, das 2313-WakeUp-Modul ebenfalls mit dem TSOP zu verbinden, so dass ich den VDR mit der FB einschalten kann, die ich auch zur Steuerung benutze.


    Das Modul muss ja nicht lernfähig sein. Der FB-Code zum einschalten kann ja auch im Quelltext festgelegt werden.


    Man müsste nur darauf achten, dass der AVR nicht den MT einschalten will, wenn dieser schon an ist.


    Hast Du da vielleicht eine Idee?


    Grüße


    Niel

    Client Wohnzimmer:
    RPi, VDR 2.1.6, rpihddevice, satip, remotetimers, osdteletext
    Client Schlafzimmer:
    zurzeit keiner
    VDR-Server:
    Epia 5000, 8 GB DOM, Skystar 2 HD, VDR 2.1.6, satip, svdrpservice
    (dient als Homeserver, macht auch noch andere Sachen, Zugriff auf 1TB NAS)
    Satip-Server:
    GSS.box DSI 400

  • Hi Niel,
    hmm, prinzipiell könnte das gehen. Da muß man aber etwas drüber nachdenken :idee
    Wenn ich dich richtig verstanden habe steht der Rechner im Wohnzimmer, du willst LIRC rausschmeißen und via Remote-Plugin über die Karte steuern.
    Wenn ich ja jetzt fies wäre wurde ich sagen "trag doch die FB ins Wohnzimmer" :P . Nee, is nur ein Scherz.
    Aber ich denke dein Hauptziel ist die Verwendung von nur einer FB.
    Ich persönlich halte die Sache mit dem Einschalten per FB nicht für so wichtig solange die Kiste im Wohnzimmer steht.
    Mögliche Ansätze:
    1. Versuch die Power-Taste der MT-FB mit einer lernbaren FB anzulernen. Wäre die einfachste Lösung, klappt aber nicht mit allen Geräten. Ist mir aber schon gelungen.
    2. Tatsächlich versuchen den AVR dazu zu überreden den Rechner bei einem festgelegten Code einzuschalten und dann natürlich wenn er läuft nicht auf den Code zu reagieren. Ist etwas aufwendiger, wobei ich jetzt noch nicht mal weiß, ob man den TSOP wirklich gleichzeitig an den AVR und die Karte anschließen kann. Könnte Probleme geben.
    Ich denk noch mal drüber nach
    bis dahin
    steini


    PS: Warum willst du eigentlich LIRC loswerden?

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Hi Steini!


    Da der MT im Wohnzimmerschranksteht und der MT nicht gerade klein ist, möchte ich soviel wie möglich Platz sparen.


    Daher möchte ich den zur Zeit noch frei "herumliegenden" TSOP in den MT verlegen (neben das Display). Da ich aber den Rest der LIRC-Schaltung immer noch hinten an der seriellen Schnittstelle hätte, müsste ich das Kabel wieder in den MT führen.


    Das ist zu umständlich. Und die Lösung mit dem Remote-Plugin ist da doch ganz gut brauchbar, oder?


    Leider habe ich keine anlernbare FB. Mit meiner (SM2416 oder so) bin ich aber ganz zufrieden. Habe noch keine bessere und billige Alternative gefunden.


    Der TSOP wurde auch in anderen Schaltungen zum Einschalten per FB doppelt genutzt. Da muss es doch wahrscheinlich eine Möglichkeit geben, dass hier zu realisieren.


    Notfalls wäre ein zusätzlicher TSOP auch noch möglich. Der lässt sich ja direkt an den AVR anschließen. Programmierst Du zufällig mit mit Bascom?


    Grüße


    Niel

    Client Wohnzimmer:
    RPi, VDR 2.1.6, rpihddevice, satip, remotetimers, osdteletext
    Client Schlafzimmer:
    zurzeit keiner
    VDR-Server:
    Epia 5000, 8 GB DOM, Skystar 2 HD, VDR 2.1.6, satip, svdrpservice
    (dient als Homeserver, macht auch noch andere Sachen, Zugriff auf 1TB NAS)
    Satip-Server:
    GSS.box DSI 400

  • Hallo,


    Den Multitainer mit einer anderen Ferbendienung einzuschalten geht. Ich habe die MD 4688, und auf lernfähig umgebaut. Mit dieser funktioniert das Anlernen der Power-Taste problemlos. Wie Steini schon erwähnt hat nimmt nicht jede Lernbare die Codes an.


    Per Funkübetragung wird das ganze dann übertragen. Funktioniert super.

  • Hi!


    Habe gerade noch etwas im MT-Forum von letzgo.de gesucht.


    Da wurde wohl der bereits eingebaute IR-Empfänger abgegriffen und mit der ser. Schnittstelle verbunden, und dieser dann per LIRC abgefragt. Es muss ja nicht das Remote-Plugin sein.


    Das wäre natürlich interessant, wenn sich diese Lösung an Com2 anschließen lässt, also intern. Dann bleibe ich bei LIRC.


    Das Einschalten per FB wäre wünschenswert, ist aber nicht unbedingt notwendig. Hatte ich nur so angedacht, bevor ich mich am kommenden Wochenende mal wieder ganz intensiv mit dem MT-VDR beschäftige.


    Wie schon geschrieben, würde ich auch eine neue FB nehmen. Aber ich finde halt keine, die mir so zusagt, ausser die meines DVD-Players. Aber die fällt ja logisch aus. Und anlernbar ist die ja leider auch nicht.
    Grüße


    Niel

    Client Wohnzimmer:
    RPi, VDR 2.1.6, rpihddevice, satip, remotetimers, osdteletext
    Client Schlafzimmer:
    zurzeit keiner
    VDR-Server:
    Epia 5000, 8 GB DOM, Skystar 2 HD, VDR 2.1.6, satip, svdrpservice
    (dient als Homeserver, macht auch noch andere Sachen, Zugriff auf 1TB NAS)
    Satip-Server:
    GSS.box DSI 400

  • Niel

    Zitat

    Habe gerade noch etwas im MT-Forum von letzgo.de gesucht


    kenn ich gar nicht, schau ich auch mal rein.
    Ob das wie du beschreibst funktioniert, kann ich nicht sagen. Aber eins ist klar:
    Das mit LIRC, AVR & LCD-Display an einem COM-Port kannst du vergessen. Das war natürlich mein erster Gedanke, den ich aber ganz schnell verworfen habe, nämlich LIRC blockiert softwaremäßig die COM-Schnittstelle, so daß weder LCD noch Kommunikation mit dem AVR zur Laufzeit möglich sind. Vor der Kom. mit dem AVR kann man LIRC ja beenden, aber das mit dem LCD ist ein KO-Kriterium.
    Was hälst du denn davon Com1 im Rechner abzugreifen. Ich möchte dich dazu jetzt aber nicht "anstiften" denn das ist schon ein netter Eingriff am Mainboard.
    asmodeus ,

    Zitat

    Ich habe die MD 4688, und auf lernfähig umgebaut


    Finde ich interessant, wie geht denn das. Hör mal, wenn du das geschafft hast, ist das hier doch wohl überhaupt kein Problem für dich :]
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5