yavdr 0.5 Installationsbericht zotac d2550 / cine s2 6.5

  • Hallo,
    nach einigen Jahren Ruhe (ein einmal installierter vdr kann schon recht lange durchhalten :D , ich konnte mich noch nicht einmal an meine alten login-Daten für das Portal erinnern ) wurde ich durch einen Hardwareausfall gezwungen, ein neues System aufzusetzen.
    Softwareseitig fiel meine Wahl auf yavdr. Dessen Entwicklern erst einmal ein Dankeschön für die gute Arbeit :tup .
    Da es ein kleines System werden sollte habe ich ein ZOTAC D2550-ITX WiFi Supreme B-series Mainboard mit externem 90W-Netzteil in ein altes DVD-Player-Gehäuse verfrachtet. Daneben ist noch genug Platz für eine Festplatte und ein Slim-DVD-Laufwerk. Als DVB-S-Karte habe ich eine Cine S2 6.5 verbaut. Die eigentliche Installation verlief ohne Probleme. Die DVB-Karte wurde jedoch erst erkannt, als ich das Entwickler-Paket nachinstalliert hatte. Soweit funktioniert das System prima, nach der einen oder anderen Anpassung kommt auch mein ungewöhnliches 1024x768-Panel damit zurecht.
    Die Umschaltzeiten sind bei allen Kanälen gewohnt kurz, auch wenn zwischen Sat-Positionen gewechselt wird (Astra 19.2 und 28.2). Die HD-Kanäle kommen ruckelfrei und ohne Artefakte. Audioausgabe funktioniert problemlos über Analog- und Optolink. Der Lüfter des Mainboards läuft ruhig und kaum hörbar bei ca. 20-30%, für mich also Wohnzimmer-tauglich.


    Zum Stromverbrauch:


    • Aus: 0.9W
    • S3-Standby 3W 1.5W nach BIOS-Einstellungsänderung
    • Betrieb 40W (inkl. DVB-S2 an 2 LNB)
    • DVD-Betrieb: 46W

    Derzeit bereiten mir noch zwei Dinge Probleme:
    - die cpufreq-utils funktionieren nicht. Die beiden CPU-Kerne laufen daher immer mit voller Taktrate. Das Problem ist den Kernel-Entwicklern bekannt, derzeit ungelöst (https://bugzilla.kernel.org/show_bug.cgi?id=50231); Hier erwarte ich noch Verbesserungen, die dann auch den Stromverbrauch senken sollten
    Update 20130529: unter MS Vista benötigt das System nur 28W

    - Timer-wakeup aus S3 klappt nicht. Startet man manuell, verbleibt das Frontend im detached-mode, die Aufnahme klappt natürlich nicht. Allerdings habe ich auch noch nicht alle Varianten des Wakeups ausprobiert, um eine passende zu finden (nvram, kompletter reboot ).
    Standby funktioniert nun problemlos über ACPI, auch das Aufwecken für Timer. Wichtig dafür waren einige Einstellungen im BIOS. NVRAM-wakeup führt nicht zu brauchbaren Resultaten.



    Soviel als kurzer Statusbericht ohne Anspruch auf Vollständigkeit oder Nutzbarkeit. Falls jemand Details, Logauszüge etc. haben möchte bitte melden.
    Jürgen

  • Hi,
    Ich hab das Board auch. Der D2550 bzw. die D-Serie kann gar kein Speedstep. Das wurde im verlinkten Bugtracker aber auch schon festgestellt.


    http://www.notebookcheck.com/I…ok-Prozessor.68263.0.html


    Gleich der erste Abschnitt.


    Gruß Viktor


    Gesendet von meinem GT-N8000 mit Tapatalk 2

  • Hallo Viktor,
    ich bin noch nicht sicher, ob das so stimmt. Wenn man im Datenblatt und der Intel-Seite nachliest wird dort zwischen "erweiterter" und "herkömmlicher" speed-step-Technologie unterschieden, und wie ich das verstehe ist letztere durchaus implementiert (auch das wurde im bugtrack schon diskutiert).
    Ich werde mal versuchen das Board unter einem Win-System zu betreiben, dann kommt evtl. etwas Licht in das Dunkel... Erst kürzlich hatte ich in einem ähnlich gelagerten Fall (cluster-blades) das Problem, dass ein Teil der Boards nur mit 1/3 des Maximaltaktes liefen (dummerweise gerade anders herum). Dort hat ein BIOS- und ein Ubuntu-Update geholfen, alles wieder richtig zu takten.
    Mal sehen, es ist nicht wirklich wichtig, da auch so der Lüfter nicht verrückt spielt, und so lange läuft das System nun auch wieder nicht. Hat dennn jemand zufällig vergleichbare Verbrauchwerte ähnlicher Systeme, bei denen Speedstep funktioniert? Intel gibt die CPU mit 10W an, dazu kommt der restliche Chipsatz und die DVB-Karte. So viel Sparpotential ist vermutlich gar nicht drin.
    Schönen Abend
    Jürgen

  • dc6jn, wie hattest Du das System denn installiert? Mit der Karte im Mainboard?


    Ich habe das gleich Board und ebenfalls die Cine S2, allerdings in der V2. Sobald die Karte im System steckt, hängt sich der Rechner direkt beim Start auf. Ich hatte hier angefragt, bevor ich Deinen Beitrag sah. Die Karte selbst funktioniert, habe ich auf meinem alten System gerade geprüft

  • Hallo,

    ...System denn installiert? Mit der Karte im Mainboard?

    die Karte steckt im PCIe Slot. Mit dem development-Treiber lief die dann auch problemlos.
    Soweit ich das verfolgt habe ist jedoch die Hardware im Detail unterschiedlich (was ja auch den anderen Treiber erfordert).
    Das einzige Problem was derzeit noch nervt ist der mehr oder regelmäßige Absturz des softhddevice-Frontends. Man kann zwar durch Umschalten auf einen anderen Kanal das System sofort wiederbeleben, aber ich habe den Eindruck, dass parallel dazu laufende Aufnahmen dadurch zerstört werden.
    Grüße Jürgen

  • - Timer-wakeup aus S3 klappt nicht. Startet man manuell, verbleibt das Frontend im detached-mode, die Aufnahme klappt natürlich nicht. Allerdings habe ich auch noch nicht alle Varianten des Wakeups ausprobiert, um eine passende zu finden (nvram, kompletter reboot ).
    Standby funktioniert nun problemlos über ACPI, auch das Aufwecken für Timer. Wichtig dafür waren einige Einstellungen im BIOS. NVRAM-wakeup führt nicht zu brauchbaren Resultaten.

    welche Einstellungen sind das denn genau?


    Danke und Gruß


    Dikilee

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • Hallo Dikilee,
    hier sind meine BIOS-Einstellungen:



    Grüße Jürgen

  • Supie, vielen Dank.


    Werde ich sofort ausprobieren.
    Das Board finde ich ansonsten total klasse.
    Habe mir noch ein passives Kühlsystem gebaut.


    Echte 0dB! ;D


    Gruß Dirk



    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • - Timer-wakeup aus S3 klappt nicht. Startet man manuell, verbleibt das Frontend im detached-mode, die Aufnahme klappt natürlich nicht. Allerdings habe ich auch noch nicht alle Varianten des Wakeups ausprobiert, um eine passende zu finden (nvram, kompletter reboot ).
    Standby funktioniert nun problemlos über ACPI, auch das Aufwecken für Timer. Wichtig dafür waren einige Einstellungen im BIOS. NVRAM-wakeup führt nicht zu brauchbaren Resultaten.


    Hallo Dikilee,
    hier sind meine BIOS-Einstellungen:



    Ich habe die Einstellungen wie oben kopiert und die BIOS Uhr auf UTC gestellt (das passiert eh' nach jedem Reboot). Dennoch wird der VDR nicht aufgeweckt, sobald die Vorlaufzeit von 5min zur Sendung erreicht ist.


    Zweite Frage: hat jemand das Board im Streacom Gehäuse mit der mitgelieferten FB in Betrieb und Einschalten aus S5 aktiv? Das soll ja funktionieren, tut es aber nicht.

  • Hallo EdgarWallace,


    ich habe genau diese Bios-Einstellungen. Habe auch ein Streacom-Gehäuse,
    allerdings habe ich ein Atric IR-Empfänger eingebaut. Alles läuft wie es muss.
    Timer, Fernbedienung und natürlich die rote und blaue Taste gehen, für den
    VDR sehr wichtig! Mit dem IR-Empfänger von Streacom gehen diese Tasten nicht. :wow


    Gruß


    Dirk

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • Dikilee,


    die FB wird eh bald durch meine Philips Pronto abgelöst, insofern stören mich die fehlenden Farbtasten nicht und die Lösung mit # und * als Ersatz for "Rot" und "Blau" (hier im Forum) läuft ja.


    Allerdings wollte ich das Gerät auch mit der FB einschalten (Abschalten funktioniert).


    Und die Timerprogrammierung ist ja auch noch offen. Zeigt Dein BIOS auch UTC an (=CET -2h)? Ich weiss nicht, wo ich noch suchen sollte...

  • Auch die Pronto wird die rote und blaue Taste nicht bedienen können, da der Streacom-Receiver diese nicht
    überträgt.
    An der Zeiteinstellung hab ich gar nicht erst schrauben müssen, schaue ich aber heute Abend mal nach.
    Hast Du das neueste Bios installiert?


    Gruß


    Dirk


    (Edit)


    Habe heute noch einmal geschaut. Bei der aktuellen Bios-Version kann man nur noch die eigentliche Uhrzeit einstellen.

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

    The post was edited 1 time, last by Dikilee ().

  • In einem Bericht von DaKilla wird beschrieben, wie "#" und "*" die Funktion der roten und der blauen Tasten übernehmen. Die werde ich auf die Pronto mappen, dann funktioniert es.


    Die letzte FW ist ja 2K120921 und die habe ich installiert. Was meinst Du mit "...kann man nur noch die eigentliche Uhrzeit einstellen" ?

  • Ich habe die Einstellungen wie oben kopiert und die BIOS Uhr auf UTC gestellt (das passiert eh' nach jedem Reboot). Dennoch wird der VDR nicht aufgeweckt, sobald die Vorlaufzeit von 5min zur Sendung erreicht ist.


    Das mit dem Mappen der Tasten ist mir auch bekannt. In diesem Falle könnte man natürlich auch die Streacom-Fernbedienung weiter
    verwenden. Das kam für mich allerdings nie in Frage, da ich die angesprochenen Tasten mit anderen Funktionen belegen werde.

    Was meinst Du mit "...kann man nur noch die eigentliche Uhrzeit einstellen" ?

    Da ich kein älteres Bios kenne, habe ich angenommen das man die Zeitzone bei einem älteren Bios ebenfalls einstellen konnte.
    Beim aktuellen Bios kann man da eben nix einstellen, dass meine ich;o)


    Gruß


    Dirk

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • Hallo Dirk, ich habe das BIOS einfach noch einmal aufgespielt, alles zurückgesetzt und was soll ich sagen....es funktioniert jetzt. Die Zeit steht auf UTC (d.h. derzeit -2h unserer CET Zeit).


    Klar ist mittlerweile, dass das Board "Power to USB" nicht unterstützt, daher kann die FB das Gerät nicht einschalten. Der Zotac Support hat mir das bestätigt. Ob das jemals implementiert wird und ob es überhaupt möglich sein wird, diese Funktionalität per FW Update zu bekommen steht in den Sternen. Schade.

  • Genau so ist es. Man kann aber von der Strom-Adapterplatine die Standby-Spannung abgreifen (löten) und
    dann auf die Streacom-Platine stecken. So hatte ich es damals. Dann kann man das Board auch mit der
    Fernbedienung aufwecken.


    Gruß


    Dirk

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • Das ist interessant, Du hast also den +5V Eingang der IRR Platine nicht an den USB Header angeschlossen, sondern an den 5V Ausgang des NTs. Richtig verstanden?


    Mein Problem ist jetzt nur, daß ich die B-Version habe, d.h. ein Laptop Netzteil versorgt das Mainboard direkt mit 12V. Da muß ich mal sehen, wo ich die 5V Standby Spannung angreifen kann. Das müsste ja gehen, denn die Standby LED auf dem MB muß ja auch irgendwie versorgt werden.

  • @ EdgarWallace


    bevor Du da ein großen Aufwand betreibst, solltest Du überlegen, ob man das Teil Überhaupt ausschaltet. Bei mir geht der YaVDR mit diesem Bord in suspend to RAM (S3). der Stromverbrauch des D2550 bei S3 ligt, glaube ich, mit ATX-NT weniger als 0,5 W höher als im Ausgeschalteten Zustand.
    Wenn ich wirklich Strom Sparen will, wird die vorgelagerte Steckerleite ausgeschaltet.


    pc-medusa

  • Jo, habe die Ohne-B-Version. Die Standby-Spannung kann man aber raus bekommen. Ich bin Techniker, daher ............
    Es leuchten ja LED's, also ist eine Spannung da. Da muss man mal mit einem Multimeter schauen. Gehen tut das ;o))


    Gruß


    Dirk

    Hardware VDR-1 und VDR-2: Zotac D2550 ITX WIFI Supreme, ATRIC IR-Empfänger, Streacom-Gehäuse, Logitech Harmony Touch, 6 x Sundtek
    MediaTV Pro, 4 x Sundtek SkyTV Ultimate auf Server mit
    Zotac D2550 ITX WIFI Supreme, NAS QNap 412, Software: yaVDR-0.6.1 - Kodi 16

  • Wenn es am Mainboard keine Steckverbindung gibt bekommt man am einfachsten am Spannungsstecker (20 oder 24 polig Pin 9) des Mainboards an die 5 VSB, in der Regel ist das Kabel lila. Details sind unter folgendem Link zu finden: http://www.elektronik-kompendium.de/sites/com/0601151.htm.


    Das ist bei der B-Series einfacher als bei der A-Series, vom Netzteil gibt bei der A-Serie nur 19 Volt. ;-)

    Gruß
    Frodo