Kennt sich hier jemand zufällig richtig mit samba aus?

  • Hallo,
    meine neue Fritz.Box (jetzt mit eingebauten samba) mag nicht zusammen mit meinem VDR samba. Der Zugriff von XP prof aus dauert manchmal lange (egal auf welche Freigabe) und die Fritz.Box Freigabe taucht nur manchmal auf. Ich habe das Gefühl die beiden kloppen sich darum wer Chef sein soll.


    Nun habe ich nicht die geringste Ahnung wie man Samba wirklich korrekt korrekt konfiguriert. Gibts hier jemdenden der sich damit auskennt?


    cu

  • Sind alle Rechner in einer Arbeitsgruppe?
    Bei WinXP kann man die Rechner in die host- Datei eintragen. Die sollte unter system oder system32 zu finden sein. Das würde zumindest das wiederfinden der Freigaben erleichtern. Die Datei wird eventuell durch Deinen Virenscanner geschützt und muss zum bearbeiten freigegeben werden.
    Gruß Jan

    1:Dell PoweEdge T20; Xeon E3-1225 v3; 32GB RAM; Proxmox 5.4; MLD 5.4 als VDR-Server; 2 x Cine S2;
    2:Intel NUC i3 Passiv; 4GB RAM; 120GB SSD; easyvdr 3.5 als client; Harmony Hub

    2:Intel NUC i5 Passiv; 4GB RAM; 120GB SSD; easyvdr 3.5 als client; Harmony Hub
    3:Raspberry Pi 3B; MLD

  • Sind alle Rechner in einer Arbeitsgruppe?
    Bei WinXP kann man die Rechner in die host- Datei eintragen. Die sollte unter system oder system32 zu finden sein. Das würde zumindest das wiederfinden der Freigaben erleichtern. Die Datei wird eventuell durch Deinen Virenscanner geschützt und muss zum bearbeiten freigegeben werden.


    Nene das hat ja auch vorher (ohne Zweitsamba) alles gut geklappt. Die Freigaben tauchen ja dann auch mal auf, aber wenn ich sie öffnen will dann gibts ne Fehlermeldung, aber hin und wieder gehts.


    Das muss irgendwas sein das sich VDR samba und Fritz.Box samba nicht mögen.


    cu

  • Das muss irgendwas sein das sich VDR samba und Fritz.Box samba nicht mögen.


    Wie z.B. WINS an beide Seiten ohne Abgleich!? Sollte nur einmal geben.


    Albert


  • Wie z.B. WINS an beide Seiten ohne Abgleich!? Sollte nur einmal geben.


    Möglich, ich habe keine Ahnung was WINS ist ;) Ich habe schon öfter mal im Samba Quellcode gewühlt um Antworten zu einigen seltsamen Verhaltensweisen zu finden, das reichte mir dann auch erstmal. Da mich jetzt auch noch in die Protokolle reinzuarbeiten... ;)


    Gibts da nicht irgendwie nen Defaultsetup für die smb.conf der für diesen Anwendungsfall (Fritz.Box läuft immer und dann gibts da noch Linux und diverse Win Versionen als Clients (ab und zu an aber haben selber auch Freigaben))? Das wird in dieser Form ja nicht so selten genutzt werden.


    Es gibt zwar haufenweise samba Seiten im Web, aber das Verhalten von Samba ändert sich ja auch ständig. Da helfen 3 Jahre alte Seiten auch nicht weiter.



    BTW: Gerade mal geschaut, am VDR ist "wins support" nicht gesetzt. Und bei meiner aktuellen samba Version (3.6.5) ist es vermutlich (ändert sich ja gerne mal ;) ) gerade mal default off.


    cu

  • Also was hast du da vor dir? Ein normales Samba3? Wie sieht deine Konfiguration aus?
    Als gut mit FritzBoxen koexistierendes Beispiel mal die smb.conf von yaVDR:
    http://paste.ubuntu.com/5619445/
    Und einer der Includes mit den Freigaben für das Video-Verzeichnis: /etc/samba/smb.conf.yavdr.recordings
    http://paste.ubuntu.com/5619450/

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Gibts da nicht irgendwie nen Defaultsetup für die smb.conf


    Du könntest mal deine Zeigen.


    WINS, sollte eine smb.conf Option dafür geben.


    Albert

  • Ich hatte auch immer Ärger mit dem Samba auf der FB. Seit ich die Freigabe als Netzlaufwerk in Windows eingebunden habe funktioniert es.


    Code
    1. \\fritz.box\FRITZ.NAS

  • Seit ich die Freigabe als Netzlaufwerk in Windows eingebunden habe funktioniert es.


    Ob Du Dich mit einer Freigabe verbindest oder sie browsen willst, das sind zwei Paar Schuhe. ;)


    Albert

  • Verstehe jetzt nicht was du meinst. In meiner smb.conf hat [FRITZ.NAS] als path /var/media/ftp

  • Hier ist meine smb.conf: http://pastebin.com/sV8weMfN


    Also was hast du da vor dir? Ein normales Samba3?


    Jup, halt so ganz normal das alle Rechner im Netz alle Freigaben sehen (entsprechend ihren Berechtigungen). Nix spezielles.


    Als gut mit FritzBoxen koexistierendes Beispiel mal die smb.conf von yaVDR:
    http://paste.ubuntu.com/5619445/
    Und einer der Includes mit den Freigaben für das Video-Verzeichnis: /etc/samba/smb.conf.yavdr.recordings
    http://paste.ubuntu.com/5619450/


    Ich werde das mal mit meinen Optionen vergleichen.


    Ich hatte auch immer Ärger mit dem Samba auf der FB. Seit ich die Freigabe als Netzlaufwerk in Windows eingebunden habe funktioniert es.

    Code
    1. \\fritz.box\FRITZ.NAS


    Kommt leider nicht in Frage. Es sollen auch Gäste ohne viel Gefummel darauf zugreifen können.


    Wobei mir gerade auffällt das der Fritz.Box ne Möglichkeit für nen Tauschverzeichnis (da wo halt jeder drauf kann) vermisst.


    cu

  • Verstehe jetzt nicht was du meinst.


    Das:


    Der Zugriff von XP prof aus dauert manchmal lange


    Das geht über NetBIOS mit Broadcast, wenn kein WINS vorhanden oder eingetragen ist. KA sollte prüfen ob in seinem XP IP-Konfiguration WINS auf die Fritze Box oder auf sein Linux zeigt, bzw. Port 137-139 müssen offen sein.


    Albert


  • Das:



    Das geht über NetBIOS mit Broadcast, wenn kein WINS vorhanden oder eingetragen ist. KA sollte prüfen ob in seinem XP IP-Konfiguration WINS auf die Fritze Box oder auf sein Linux zeigt, bzw. Port 137-139 müssen offen sein.


    Siehe Anhang, ich glaube ich habe überhaupt kein WINS ;)


    Die Ports werden wohl offen sein, sonst würde es ja generell nicht funktionieren. Eben (gerade VDR angeschaltet) gings auch wieder problemlos.


    cu

  • Hi..

    Quote

    Der Zugriff von XP prof aus dauert manchmal lange


    Versuche mal testweise auf dem XP den Dienst "WebClient" zu deaktivieren...
    könnte helfen...


    [size=10]nOpacity: Icons
    [size=10]skindesigner: tryoutsglassy

  • Hat jetzt wahrscheinlich nix zu sagen aber in deiner smb.conf steht bei path home/dirk


    Ansonsten hatte ich exakt die gleichen Probleme, mal ging es, dann hat Windows wieder nix gefunden, dann ging es nach ner halben Stunde oder 20 Versuchen... nerv...
    Hab dann irgendwo als Tipp das mit dem Netzlaufwerk gelesen und seit dem fahre ich den Rechner hoch, klicke auf das Laufwerk und zack, da isses..


    Aber bei mir muss auch nur der Arbeitsrechner (also ich) Zugriff haben.


    Meine smb.conf


    Edit: WINS ist bei mir auch leer aber NetBios über TCPIP ist aktiv.

  • Hallo,
    samba auf der FB is oft recht alt. Welche Firmware has Du drauf? (seit Fritz OS 05.50 sind die meisten Probleme weg.).

    Grüße, Dieter :-)

  • Hat jetzt wahrscheinlich nix zu sagen aber in deiner smb.conf steht bei path home/dirk


    Ups, stimmt. Werde es mal korregieren (obwohl da samba anscheinend selber so clever ist das zu fixen).


    samba auf der FB is oft recht alt. Welche Firmware has Du drauf? (seit Fritz OS 05.50 sind die meisten Probleme weg.).


    Ist frisch aufgebaut

    Code
    1. FRITZ!Box Fon WLAN 7390 (UI)
    2. FRITZ!OS 05.50
    3. Firmware-Version: 84.05.50


    Wobei Saman recht hatt, wenn man einmal \\fritz.nas direkt aufruft ist die Freigabe auch sofort in der Netzwerkumgebung. Die Freigabe ist ja anscheindend immer da, man sieht sie nur nicht allzu oft ;)


    In der yaVDR smb.conf habe ich noch "dns proxy = no" entdeckt, ich habs mal bei mir eingetragen udn habe das Gefühl es läuft etwas fluffiger. Bleibt nur das Problmen das sich die Fritz.Box freigabe gerne mal versteckt.


    Eidt: Kaum schreibt man es... gerade nochmal probiert, Fritz.Box Freigabe ist da aber der Zugriff ging nicht. Beim zweiten Versuch gings dann.


    cu

  • Die Freigabe ist ja anscheindend immer da


    Das ist nur normal.


    Bleibt nur das Problmen das sich die Fritz.Box freigabe gerne mal versteckt.


    Das glaube ich so nicht. Schau mal in die Ereignisanzeige von XP. Ich tippe, er versucht die Rolle des "Masterbrowser" los zu werden, der Fritze will sie aber nicht annehmen. Ich glaube das ließe sich ändern.


    Fritz.Box Freigabe ist da aber der Zugriff ging nicht.


    Das ist das, was ich nicht zuordnen kann. Wenn es nur ein einziges mal ging, dann ist bereits alles richtig konfiguriert.


    Was gibst Du mit dem Fritze frei? Ist das etwa eine USB Festplatte?


    Dirk, schau Dir das mal an.


    Albert

  • Dirk, das Link ist ein EDIT! :wow


    Albert