Brauche Hilfe, das pvrinput ans Laufen bekommen

  • Habe mich entschlossen nun doch noch ein paar alte VHS-Videos zu digitalisieren.
    Habe ein Siduction - Debian Sid-Vdr aus etobis Quellen installiert, vdr/xineliboutput und das pvrinputplugin.
    Die Kernelversion ist 3.8


    Läuft auch alles, habe den VDR am Start. Im Gehaeuse steckt eine pvr150 und eine TT/FF 1.5.
    Das Problem ist, dass das Videobild nicht gesehen wird über composite-eingang.


    Folgende Einträge habe ich jetzt in der channels.conf versucht



    es kommt immer die Meldung: "Kanal nicht verfuegbar"


    ein ls /dev/video* bringt>


    /dev/video0 /dev/video24 /dev/video32


    Was läuft noch falsch?

  • Was läuft noch falsch?


    Erstell den Kanal für Composite doch einfach über das VDR-OSD. Da gibt es ja nicht viel, was man durchprobieren muss.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ernst gemeinte Frage?
    Menü -> Kanäle -> Neuen Kanal anlegen (Grün) -> Richtigen Typ wählen und den entsprechenden Eingang (gibt ja nur 2 - 3 bei der PVR150 mit der Bezeichnung Composite)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ja klar, habe ich noch nie auf diesem Wege so grmacht.
    ich probiers morgen als erstes aus, wenn ich wacher bin :-)


    Falls das nicht geht, liegts vermutlich an der Karte. Brauch ich für die ne Firmware? ich denke nicht, oder?
    Der Treiber müsste ja im Kernel enthalten sein.

  • schalt mal temporär den LogLevel in den pvrinput-Einstellungen auf 3 und schaue ins Log, was da beim vdr-Start geloggt wird. Es werden alle gefundenen inputs aufgelistet.


    Code
    1. :AV-Eingaenge
    2. Composite (Cinch):1:C56:C:0:301:300:305:A1:65004:0:0:0
    3. Composite (Adapter):2:C0:C:0:301:300:305:A1:65005:0:0:0
    4. :weitere
    5. Composite 1;w_pvrscan:1:C23:C:0:301:300:305:A1:9002:0:0:0
    6. S-Video 2;w_pvrscan:1:C34:C:0:301:300:305:A1:9003:0:0:0
    7. Composite 2;w_pvrscan:1:C45:C:0:301:300:305:A1:9004:0:0:0
    8. Composite 3;w_pvrscan:1:C56:C:0:301:300:305:A1:9005:0:0:0


    falsche Syntax aus einem früheren Jahrhundert, rausschmeissen!


    Bei /dev/video0 brauchst Du jedenfalls Card0. Probier nochmal COMPOSITE4.
    Composite1 für CARD0 hast Du doppelt drin.



    Je nach Hardwarerevision gibt es separate Cinchbuchsen, Composite-Eingänge über die S-Videobuchse oder Eingänge über onboard-Buchsenleisten. Die werden unterschiedlich durchgezählt. Welchen verwendest Du?


    Wenn das noch nicht hilft, stell mal auf Loglevel 4 und poste das Log ab Starten vdr bis zum ersten Umschaltversuch auf einen Composite-Eingang mit Fehlermeldung.


    Den Loglevel unbedingt wieder auf 1 oder 2 zurückstellen, da bei 3 und 4 zuviel geloggt wird, was das Plugin langsamer macht.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 2 times, last by Dr. Seltsam ().

  • Danke Euch allen schonmal für die Tipps.


    Habe versucht den Kanal zuzufügen, ging auch, aber jedesmal wenn ich darauf schalte (alle Variationen von Composite 1-4 probiert), dann steht da "Kanal nicht verfügbar".
    Dann habe ich die vorgeschlagenen Kanäle in die channels.conf eingefügt - gleiches Ergebnis.


    Hier mal das Syslog mit loglevel 3 (pvrinput):



    Hier alles mit loglevel 4



    Es fällt die kernelmeldung auf: Failed to initialize on device video0


    Aber was kann ich tun?

  • das sind die entscheidenden Stellen:

    Code
    1. Apr 28 19:44:10 sid vdr: [14062] cPvrDevice::Initialize(): no PVR device found
    2. Apr 28 19:44:10 sid kernel: [ 2267.140555] ivtv0: Failed to initialize on device video0


    sieht aus, als wenn die PVR150 defekt wäre oder nicht vom ivtv-Treiber unterstützt wird. Poste mal die Revisionsnummer oder ein Foto. Und probiere sie mal in einem anderen Slot.


    was sagt dmesg?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Okay, wir nähern uns - das macht es zumindest nachvollziehbar.


    Danke erstmal, dass Du so hartnäckig dranbleibst und mir hilfst!
    Ich habe sie mal umgesteckt und es brachte keine Änderung.
    Ich weiß aber, dass sie mal ging - ist allerdings bei ctvdr 6 oder 7 gewesen, also vor ca. 2 Jahren. Ob sie noch intakt ist, ist schwer zu sagen.


    Ich poste mal dmesg (ganz, wusste nicht wonach ich grepeb sollte) und zwei Fotos in voller Auflösung als Link, dann kannst Du / könnt ihr auch reinzoomen.


    http://freie-software.info/dmesg-vdr.txt
    http://freie-software.info/pvr150-1.jpg
    http://freie-software.info/pvr150-2.jpg

  • Da feht die Firmware (und laut der Ausgabe für die FF Karte auch):

    Code
    1. [ 2.204461] dvb-ttpci: could not load firmware, file not found: dvb-ttpci-01.fw
    2. [ 2.204495] dvb-ttpci: usually this should be in /usr/lib/hotplug/firmware or /lib/firmware
    3. [ 2.204528] dvb-ttpci: and can be downloaded from http://www.linuxtv.org/download/dvb/firmware/
    4. [...]
    5. [ 3.115433] ivtv0: Unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ...und die Firmware für die PVR gibt es hier. Mit Ausnahme der beiden Textdateien gehören die in /lib/firmware. Danach sollte ivtv die Karte richtig initialisieren können, und dann klappt's auch mit pvrinput

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Also, hier erstmal mein Feedback:


    Dank Eurer Hilfe läufts! Es lag an der fehlenden Firmware!
    Den richtigen Channel musste ich zwar noch etwas suchen, was aufgrund der zeitverzögerung nicht ganz einfach war. Bei Bedarf kann ich den Channels.conf Eintrag auch nochmal posten. War Composite 1 als EIngang.


    Zum digitalisieren selbst muss ich jetzt erstmal Erfahrungen sammeln, aber so schlecht schauts garnicht aus!


    Noch zwei Fragen:
    1. Lohnt sich die Anschaffung eines besseren Composite Kabels? habe jetzt ein normales (mit gelben Steckern)
    Wenn ja, welches ist empfehlenswert?


    2. @Dr Seltsam: Du schreibst in diesem Thread, dass man die Rauschfilter behutsam aktivieren sollte. Wie? kannst Die Antwort auch in dem betreffenden Thread posten. Danke!



    Also bis hierhin herzlichen Dank an alle Helfer!!!

  • teurere Kabel sind rausgeworfenes Geld. Wenn der Rekorder einen S-Video-Ausgang hat (i.d.R. nur bei S-VHS-Modellen) würde ich die Verbindung zur PVBR150 darüber laufen lassen.


    Der Beitrag, den Du meinst, ist veraltet und bezieht sich auf die PVRUSB2, als der Treiber noch Bugs hatte.


    Für Deine PVR150 werden die Treiber-Standardsettings mit Sicherheit gesetzt. Der einzige Parameter, wo sich ein Nachjustieren lohnt, ist pvrinput.FilterTemporal. Müsste im Menü ähnlich heissen. Der Standardwert 8 ist m.E. etwas zu hoch, da sollte man mal 6 oder 4 oder auch 0 probieren, um Geisterbildeffekte zu vermeiden.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Cool. Das sind doch schon mal gute Erfahrungswerte. Vielen Dank!


    S-VHS habe ich leidernicht, nur nen normalen VHS-HifiRekorder.
    Mal sehen, wie lange der durchhält und wie viele meiner 300 Tapes ich überspielen werde :-)


    Danke!

  • VHS-HifiRekorder.
    Mal sehen, wie lange der durchhält und wie viele meiner 300 Tapes ich überspielen werde :-)


    welche Marke und welches Modell?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • gutes Gerät, hat noch ein K-Laufwerk mit Alu-Druckguss-Chassis.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • ja, denke ich auch.
    hatte iegentlich immer Panasonicgeräte. Habe in den 80ern und 90ern viele konzerte aus dem TV archiviert.


    Einziger Nachteil ist, dass ich den Compsiteausgang über ein 1,5m langes Adapterkabel aus dem Scartanschluss rausfischen muss. das ganze geht dann noch hinter dem Computerlang, wo jede menge anderer Kabel unter anderen "reinstreuen"...
    Ist halt die Frage, ob man das bei VHS-Qualität überhaupt sieht...

  • Ist halt die Frage, ob man das bei VHS-Qualität überhaupt sieht...


    Du mischt so ja einfach munter MPEG-Artefakte mit VHS-Rauschen und dem bisschen Rauschen über die Kabel :)
    IMHO muss man die Bitrate für die Hauppauge-Karten schon eher so in Richtung 9 - 12 Mbit/s bewegen, damit man eine gute Qualität bei analogen Quellen erreicht.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)