[gelöst] Kein MP2-Ton mehr

  • Hallo.


    Seit heute habe ich das Problem, auf Sendern, die keinen DolbyDigitalTon ausstrahlen nichts mehr hören zu können.
    Sobald ich von einem Sender mit DD auf z.B. rbb schalte, zeigt der Reciever nichts mehr an und bleibt stumm (Früher stand dann dort: PCM und Stereo)
    Schalte ich auf xbmc um, funktioniert alles, wie es soll. Ich bekomme Navigationssounds und die PCM-Anzeige. Außerdem spielt er auch Aufnahmen von den betroffenen Sendern mit Ton ab.


    Ich kann leider keine Probleme entdecken.


    Ich habe ein yavdr 0.5 über HDMI (NVIDIA GT610) an einen Reciever angeschlossen, der den Ton ausgibt und das Bild an den Fernseher weiterleitet. Ausgabedevice ist softhddevice.
    Im Webfrontend ist HDMI-Passthrough eingestellt. In der etc/asound.conf steht:

    Code
    1. pcm.!default {
    2. type hw
    3. card 1
    4. device 7
    5. }


    Unter System / Einstellungen / DVB / DD-Ton benutzen = ja
    in den Einstellungen von Softhddevice unter Audio:
    Pass-through default = ein
    PCM pass-through = ja
    AC-3 pass-through = ja
    AC-3 pass-through = ja (steht 2x dort)
    Enable (E)AC3 (decoder) downmix = nein
    Volume controll = Hardware


    Vielleicht fällt einem von Euch ja ein, wonach ich noch gucken kann.
    Vielen Dank


    Stubi

    VDR: easyVDR 3.0, Intel NUC6CAYH, 4GB, 3x TechnoTrend CT2-4400, Intel VAAPI

    The post was edited 1 time, last by stubi ().

  • Ich danke Dir herzlich.
    Die Anpassung der /etc/vdr/plugins/plugin.softhddevice.conf auf:

    Code
    1. -D
    2. -a hdmi:1,1
    3. -p hdmi:1,1


    brachte den gewünschten Erfolg.


    Leider scheine ich nicht besonders viel Geschick in der Wahl meiner Suchbegriffe bewiesen zu haben ;)
    Danke nochmal
    Stubi

  • Wobei deine Posts nicht zusammen passen.
    Einmal ist es 1,1 und im ersten 1,7.


    Bei Stereo ist der Parameter -a wichtig bzw. wenn nicht vorhanden wird "default" aus asound.conf genommen.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • naja, es ist card 1 und device 7 - ein aplay -L teilt mir mit, dass das 1. hdmi-device der Karte 1 ist.
    Es passt also schon zusammen.
    Warum das Problem allerdings jetzt auftaucht ist mir nicht klar. Meiner Meinung nach hat sich schon länger nichts dafür relevantes aktualisiert...


    MfG
    Stubi

  • Quote

    naja, es ist card 1 und device 7 - ein aplay -L teilt mir mit, dass das 1. hdmi-device der Karte 1 ist.
    Es passt also schon zusammen.


    nicht wirklich ;)


    bekommst du denn hdmi audio mit

    Code
    1. sudo speaker-test -Dhw:1,7 -c2


    oder mit

    Code
    1. sudo speaker-test -Dhw:1,1 -c2


    sollte es wirklich device 1 (nicht 7) auf card 1 sein musst du die asound.conf natürlich entsprechend auf 'device 1' anpassen, oder sitze ich jetzt auf der Leitung?

  • Also noch einen Versuch, mir wird alles auch immer unklarer ;)


    Es ist device 7 auf card 1. --> aplay -L-Auszug:


    'sudo speaker-test -Dhw:1,7 -c2' funktionierte bis vor kurzem (also zur Zeit meines Problems) nicht, jetzt gehts wieder...


    'sudo speaker-test -Dhw:1,1 -c2' meldet, dass es das device nicht öffnen kann.


    'sudo speaker-test -Dhdmi:1,1 -c2 bringt das gewünschte Rauschen.


    In Analogie zum verlinkten Thread habe ich statt plughw:0,7 und hdmi:0,1 eben plughw:1,7 und hdmi:1,1 versucht:
    erst änderte ich aus Verständnisgründen die plugin.softhddevice.conf auf:

    Code
    1. -D
    2. -a plughw:1,7
    3. -p plughw:1,7


    damit lief es nicht!


    erst die Anpassung auf:

    Code
    1. -D
    2. -a hdmi:1,1
    3. -p hdmi:1,1


    funktionierte.


    Heute habe ich es spassenshalber wieder auf:

    Code
    1. -D
    2. -a plughw:1,7
    3. -p plughw:1,7


    geändert. Damit funktioniert es heute auch. Ich verstehe es nicht. Selbst wenn ich die -a und -p-Parameter weglasse geht wieder alles. Es kann ja nur an einem Update liegen, welches zwischenzeitlich kam.


    es grüßt ein etwas ratloser
    Stubi

  • Na das Problem wird sein dass dein Board ja einen Onboard HDMI Anschluss hat.
    Je nach Lust und Laune ist einmal die GT610 und inmal die Onboard Soundkarte die Nummer 0 oder Nummer 1


    Als Workaround am besten die Onboard Soundkarte im Bios deaktivieren.
    Dann sollte es zuverlässig über die GT610 per HDMI funktionieren.


    lg,
    Joe

  • Deshalb schreibt man auch "hw:NVidia,7" da nimmt er immer die NVidia außer man hat ein NVidia Chipsatz.


    Und bitte kein "plughw", das macht nur Ärger.


    Kohns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch