Problem mit softhddevice/pvrinput-Kombination

  • Hallo,


    ich bin kürzlich auf vdr2.0.0 mit softhddevice umgestiegen (vorher 1.7.28 und xinelibouput).
    Läuft soweit sehr schön, ich habe aber ein Problem mit von pvrinput bereitgestellten Kanälen.
    Hier setzt alle paar Sekunden der Ton aus, das Bild bleibt stehen und im Log erscheint :


    Apr 6 02:00:53 mvdr2 vdr: [12757] [softhddev]Clear:
    Apr 6 02:00:53 mvdr2 vdr: [12757] ERROR: TS packet not accepted in Transfer Mode
    Apr 6 02:00:53 mvdr2 vdr: audio/alsa: using device 'hw:1,7'
    Apr 6 02:00:54 mvdr2 vdr: audio/alsa: start delay 336ms
    Apr 6 02:00:54 mvdr2 vdr: video: decoder buffer empty, duping frame (2917/184) 0 v-buf
    Apr 6 02:00:54 mvdr2 vdr: video: slow down video, duping frame
    Apr 6 02:00:54 mvdr2 vdr: video: 0:00:15.580 +111 382 240/\ms 125+7 v-buf


    Bis zum Umstieg lief das problemlos und ein kurzer Test zeigt, dass es mit xinelibouput
    weiterhin klappt - deshalb die Frage, ob jemand diese Kombination erfolgreich betreibt.


    Es läuft hier debian wheezy mit e-tobi/experimental, d.h. softhddevice 0.6.0 und
    pvrinput 2012-25-1+git20130319.


    Tschuess..
    Michael

  • Kannst mal testen ob ein Vergrößern des Audiopuffers dies verbessert.


    Menu -> Setup -> Plugins -> SoftHdDevice -> Audio (rechts) -> Audio Buffer Size (ms)


    Die default "0" entsprechen 366ms, also 1000 oder 2000 prüfen.


    Ansonsten stört mich der

    Code
    1. Apr 6 02:00:53 mvdr2 vdr: [12757] [softhddev]Clear:


    kommt der regelmässig? Den Clear schickt der VDR.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • zumindest bei vdr-1.7.27 funktioniert pvrinput mit softhddevice ohne Probleme (yavdr 0.5 stable)

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Hallo,


    ich bin endlich mal zum Testen gekommen.


    Größer als 1000 kann ich den AudioBuffer gar nicht einstellen.
    Ich habs also mal mit 500 und 1000 probiert -> klappt trotzdem nicht.


    Das Clear ist in dieser Logsequenz grundsätzlich enthalten.


    Was ich noch getestet habe :
    - alle Plugins ausser softhddevice und pvrinput deaktiviert -> kein Unterschied
    - neue Vdr-Version 2.0.1 kam heute morgen -> kein Unterschied
    - ich habe herausgefunden, dass ich Aufnahmen durchführen und diese auch problemlos abspielen kann.
    - auch Timeshift (selbst mit minimalem Versatz) funktioniert somit
    - dann sagt das Log direkt nach dem Clear noch ein Play (also kein Transfermode ?)


    Tschuess..
    Michael

  • es tritt also nur bei Live-Tv auf?


    wie sind die Einstellungen des pvrinput-Plugins? poste am besten mal den ganzen pvrinput-Abschnitt aus der setup.conf


    yavdr 0.5 testing mit vdr-2.0.1 läuft mit pvrinput einwandfrei, habe ich gerade getestet.


    Probier mal, ob eine Änderung des Stream Types auf "MPEG2 DVD" in den Experteneinstellungen von pvrinput eine Änderung bringt. (wirkt evtl. erst bei vdr-Neustart)


    Ferner könntest Du versuchen, einen dieser Parameter zu ändern:


    vdr stoppen, setup.conf editieren, vdr neu starten. Aber immer nur einen Parameter zur Zeit ändern!

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Ja, super ! Nach Umstellung auf MPEG2 DVD geht es jetzt - übrigens auch ohne Neustart des Vdr.
    Und ich war mir sicher, an allen Einstellparametern bereits geschraubt zu haben :-(
    Ich verzichte somit auf weitere Tests und bedanke mich vielmals für die Hilfe.


    Tschues..
    Michael

  • prima, dann war es ja doch zu etwas nütze, dass ich diesen stream type damals als Option ergänzt habe.


    Der Unterschied zu PS ist:


    Code
    1. mpeg2-PS: This is a mpeg2 Program stream with audio and video muxed in.
    2. Just like the .mpg format.
    3. mpeg2-DVD: This is a mpeg2 stream with audio and video muxed in. Just
    4. like the .vob format but without any NAV packs and SPU packs.
    5. The .vob format is basically the same as the Program stream format,
    6. except that the stream is muxed so as to pad out to fill 2048 byte
    7. blocks. E.g. If an audio pack is less than 2048 bytes, it will be padded
    8. with zeros to reach 2048 bytes before the next pack.


    eigentlich sollte es keinen Unterschied amchen (ich habe auch nie einen bemerkt), zumal pvrinput den gemuxten Stream intern wieder zerlegt und daraus einen Transport Stream für vdr macht.


    Zu MPEG2 DVD gab es aber schon vor 10 Jahren die Feststellung von Andreas Kool (Entwickler des analogtv-Plugins), dass mit diesem ein Stotter-Problem beseitigt wurde.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!