keine Schreibrechte bei NFS-mount

  • Hallo,


    ich versuche seit 3 Tagen das Video-Verzeichnis von meinem EasyVDR 1.0 auf meinem Mint 13 Desktop mit Schreibrechten gemountet zu bekommen. Und alle Versuche scheiterten bisher kläglich.


    In der /etc/exports steht der Eintrag:

    Code
    1. /media/easyvdr01/video0 192.168.1.0/255.255.255.0(rw,no_root_squash)

    ich mounte über die fstab mit der Zeile:

    Code
    1. 192.168.1.3:/media/easyvdr01/video0 /media/vdr nfs rw,hard,intr,auto,users,rsize=8192,wsize=8192 0 3

    Lesend mounten funktioniert aber eben nicht mit Schreibrechten.


    Ich habe auch schon versucht in der exports-Datei die UID vom Mint-User anzugeben mit:

    Code
    1. /media/easyvdr01/video0 192.168.1.0/255.255.255.0(rw,sync,anonuid=1000,anongid=1000)

    Hat aber auch nichts gebracht.


    Was ich überhaupt nicht verstehe ist das Folgende, und ich vermute auch dass da das Problem liegt:
    Wenn der NFS-share nicht gemountet ist hat das Verzeichnis /media/vdr folgenden Eigentümer: "beda:beda" Das ist der User auf dem Mintsystem.
    Aber sobald ich mounte ändert sich der Benutzer auf "nobody:nogroup". Und dieses Verhalten ist vollkommen unabhängig mit welchen der oben
    genannten Optionen ich das Verzeichnis exportiere.


    Disclaimer:
    1.) Nein ich will kein NIS oder LDAP zur zentralen Benutzerverwaltung aufsetzen. 8)
    2.) Mir sind die Sicherheitsprobleme von NFS bekannt und egal. 8)
    3.) Nein ich will stattdessen nicht auf Samba umsteigen.



    Schöne Grüße
    Beda


    ==================================================================
    Sehr zufriedener EasyVDR 1.0 - Nutzer

  • Hi,


    ich nehme an, dass du nfsv4 bekommst, weil du keine explizite Version angibst.
    nfsv4 braucht leider mehr als nfsv3, was Benutzermapping u.ä. anbelangt.


    Versuche mal, alles mit vers=3 zu mounten. "rw,auto,vers=3" sollte da reichen, den Rest kannst du weglassen.


    Wenn auch das nix hilft, schalte bei deinen nfs-Servern nfsv4 ganz ab. Wie das geht, hängt von deiner Distro ab.
    Beu openSuSE über /etc/sysconfig/nfs und dort "NFS4_SUPPORT="no"".


    Ciao.
    Michael.

  • Hallo,


    hat leider beides nicht funktioniert. Ich habe beide Varianten unabhängig voneinander probiert und ich habe weiterhin keinen Schreibzugriff.
    Könnte vielleicht mal jemand beispielhaft seine Einträge aus der /etc/exports und der fstab vom Client herzeigen, falls jemand eine ähnliche Konfguration hat.



    Schöne Grüße
    Beda


    ==================================================================
    Sehr zufriedener EasyVDR 1.0 - Nutzer

  • Hallo,


    hat leider beides nicht funktioniert. Ich habe beide Varianten unabhängig voneinander probiert und ich habe weiterhin keinen Schreibzugriff.
    Könnte vielleicht mal jemand beispielhaft seine Einträge aus der /etc/exports und der fstab vom Client herzeigen, falls jemand eine ähnliche Konfguration hat.


    Ich mache das im Prinzip auch so und ich denke, dass es jede Menge Leute mit so einem Setup gibt.


    Also:

    Code
    1. # /etc/exports am Server vdr.my.domain:
    2. /var/spool/video/video0 *.my.domain(rw,insecure,no_subtree_check,no_root_squash,async)


    my.domain ist in diesem Fall meine interne DNS-Domain.


    Code
    1. # /etc/fstab am Client:
    2. vdr.my.domain:/var/spool/video/video0 /var/spool/video/video0 nfs rw,auto,user,dev,suid,exec,nfsvers=3,wsize=16384,rsize=16384,timeo=14,hard,intr,tcp 0 0
    3. vdr.my.domain:/var/lib/epgsources /var/lib/epgsources nfs rw,auto,user,dev,suid,exec,nfsvers=3,wsize=16384,rsize=16384,timeo=14,hard,intr,tcp 0 0
    4. vdr.my.domain:/var/spool/video/epgimages /var/spool/video/epgimages nfs rw,auto,user,dev,suid,exec,nfsvers=3,wsize=16384,rsize=16384,timeo=14,hard,intr,tcp 0 0


    Wichtig ist, dass die Kennungen, auf die die Berechtigungen auf den Verzeichnissen am Server gesetzt sind, dieselben UIDs haben, wie die Kennungen am Client, die dann lesen und schreiben können sollen.


    Schöne Grüße
    Beda


    Ciao.
    Michael.

  • Wichtig ist, dass die Kennungen, auf die die Berechtigungen auf den Verzeichnissen am Server gesetzt sind, dieselben UIDs haben, wie die Kennungen am Client, die dann lesen und schreiben können sollen.


    Ich vermute dass das das Problem ist. Die UID meines users auf dem Desktop ist 1000 und die Videofiles werden von EasyVDR mit der UID 112 gespeichert. Und ich dachte ich kann das mit der export-option "anonuid=112" lösen.


    Schöne Grüße
    Peter


    ==================================================================
    Sehr zufriedener EasyVDR 1.0 - Nutzer

  • Ich vermute dass das das Problem ist. Die UID meines users auf dem Desktop ist 1000 und die Videofiles werden von EasyVDR mit der UID 112 gespeichert. Und ich dachte ich kann das mit der export-option "anonuid=112" lösen.


    Ich habe das so gelöst, dass ich der Gruppe video Schreib- und Leserecht auf den ganzen Baum gegeben, diese Gruppe dann am Client und am Server mit derselben GID versehen und mich dann am Client in die Gruppe gesteckt habe.


    Schöne Grüße
    Peter


    Ciao.
    Michael.

  • Hi !


    haste es schon mal mit der option all_squash probiert ? dabei werden ALLE Zugriffe auf die UID und GID umgebogen die du angegeben hast....


    also als erstes habe ich in der fstab das verzeichnis gemuonted

    Code
    1. /mnt/data/vdr_video /export/vdr none bind 0 0


    dann die /etc/exports


    Code
    1. /export/vdr *(rw,fsid=0,sync,no_subtree_check,all_squash,anonuid=666,anongid=666)


    Gruss Gerd

    vdr => p8b75-m lx / pentium g2020t / 8 GB Ram / zotac gt 630 / cine S2 V5.5 / 60 gb ocz ssd / 640 gb wd scorpio blue / display noritake 256x64-3900 / chenbro PC71023 gehaeuse / yavdr stable / softhddevice


    spielsystem => p8b75-m le / intel core i3 3220T / ubuntu lts 14.04 / 16 GB ram / zotac gt 630 / cine S2 V6.2 / yavdr stable pakete / softhddevice / pulseaudio+alsa


    spielwiese => Zotac Zbox ID45 / 120 GB mSATA / via Satip => Octopus Net / yavdr stable / softhddevice