Offiziell VDPAU mit AMD Grafikkarten

  • Und deshalb wird das nie etwas. Irgendwie sehen die die Welt nur in Vollbild- (progressive).


    Und denk mal an 2009 zurück, wie sich viele hier echauffierten, das die deutschen ÖR der EBU Empfehlung 720p folgten ...


    Wie läuft das bei den Windows basierten HTPCs? Nvidia macht das gleiche wie unter Linux (Cuda), Intel kann unter Win auch mehr, IIRC temporal, weiß jemand wie das bei AMD/ATi ist?


    Regards
    fnu

    HowTo: APT pinning

  • Nur bei Intel weiss ich nicht, ob die unter WIndows schon das Optimum an Qualität aus ihrer Hardware holen.


    Das weiß vmtl. keiner so genau, böse Zungen sagen selbst Intel nicht, :hat2 , was ich aber gelesen hatte, es sollen unter Win auch Advanced De-Intelacer zur Verfügung stehen ...


    Wenn die aber so komisch zu nutzen sind wie der HW-En-/Decoder ab Core i3 (QuickSync), haben diese vmtl. wenige genutzt ... ^^


    Ganz vergessen, danke für den Link zu AMD's Avivo ... :)

    HowTo: APT pinning

  • So hab es mal mit der ppa von oibaf getestet.
    Treiber läuft mit einer Radeon hd 4650 per vdpau .Videos abspielen geht per mplayer xbmc hat schwere grafikfehler ,schrift wird unlesbar tv gucken geht nicht stürzt ab.vdr tv gucken schwere grafikfehler.
    vieleicht testet es mal jemand mit ner 5000 oder 6000er serie.
    gruss claus


  • Woher hast du die Info?
    Man könnte bei Christian König auf der mesa Mailinglist mal anfragen, evtl. bekäme man ein wenig mehr Infos bzw. er Implementiert was.
    johns könntest das evtl. du übernehmen du hast von dem zeug auch Anhnung wenn`s um Details geht.


    mfg


  • @subzeroxr3i


    XBMC geht nicht. Schau mal ins Log, wenn Du was versuchst abzuspielen. Mplayer ist bis jetzt der einzige Player, bei mir, der es tut.


    Grüße

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Für gentoo


    ASUS C60M1-I C60 CPU: SoftHddevice klappt teilweise, aber es scheint kein v-sync zugehen,
    1080i geht auch nicht, kann sein das ich zuwenig RAM habe.


    Edit:
    So dual RAM ist nun drin und 8GB. Aber 1080i geht immer noch nicht.
    Ich vermute es liegt daran, daß ich nicht den Richtigen Chipsatz habe.

    Code
    [   365.075] (II) RADEON(0): [DRI2]   DRI driver: r600
    [   365.075] (II) RADEON(0): [DRI2]   VDPAU driver: r600


    Und BOB ist wirklich häßlich.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

    Edited once, last by johns ().

  • johns


    Danke, ich werde morgen mal ein Gentoo auf die Zbox spielen und das von Dir ausprobieren.


    Grüße

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Oh, dann kann ich mir ja vielleicht doch ne HD 7750 einbauen :]

    Server: MB-D510-MATX, 1GB RAM, DVBSKy S952 Dual, System: 8GB CF mit yavdr 0.5, Daten: 2x 1,5 TB Samsung HD154UI
    Client: SMT 7020s mit zen2mms 1.1 auf 80 GB Platte an Philips 32" LCD
    HD VDR 1: Asus M3N78-EM in Slimgehäuse, Athlon LE 1600, 2 GB RAM, 80GB HD, yavdr 0.5 an Samsung LE32A430
    HD VDR 2: ECS H55H-I in Slimgehäuse, i3 540, 4GB RAM, ATI 5570,
    512MB USB Stick mit OpenELEC PVR, 320 GB HD für sonstiges an Philips PFL 32-8404h


  • Also habs noch mit ner onboard 4200 auf nem alten m3a785D-M getestet.gleiche grafikfehler im log steht
    Apr 30 21:05:17 radeon kernel: [ 29.110997] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream ! Apr 30 21:05:17 radeon kernel: [ 29.116829] radeon 0000:01:05.0: texture bo too small (1024 810 5 0 -> 1671168 have 1658880) Apr 30 21:05:17 radeon kernel: [ 29.116838] radeon 0000:01:05.0: alignments 1024 128 8 256
    gruss claus

  • @all


    Für alle die mal testen wollen: ppa:fnu/vdpauvd-fnu, ich habe mir die "Oibaf" Pakete für Ubuntu 13.04 (Raring Ringtail) neu gebaut und ein Firmware-Paket geschnürt. Wie beim Original ist die Unterstützung für "radeonsi" noch abgeschaltet, weil dazu ein größerer Umbau auf "llvm-3.3" in "mesa" notwendig ist, das kommt aber noch ...


    Passenden Kernel von hier runterladen und installieren, wichtig: linux-headers, linux-headers-generic && linux-image-generic!



    Anschliessend findet man folgendes in Xorg.0.log:


    Code
    [    16.580] (II) RADEON(0): [DRI2] Setup complete
    [    16.580] (II) RADEON(0): [DRI2]   DRI driver: r600
    [    16.580] (II) RADEON(0): [DRI2]   VDPAU driver: r600


    "vdpauinfo" erspare ich mir, wurde ja schon zu Hauf hier gepostet ...


    Regards
    fnu

    HowTo: APT pinning

    Edited once, last by fnu ().

  • @all


    Leider doch noch ein Fehler entdeckt:


    Code
    Apr 30 21:36:15 vdr4 kernel: [    9.350743] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   10.363683] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   11.376617] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   12.389552] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   13.402488] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   14.415420] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   15.428353] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   16.441285] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   17.454217] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   18.467149] [drm:r600_uvd_init] *ERROR* UVD not responding, trying to reset the VCPU!!!Apr 30 21:36:15 vdr4 kernel: [   18.487013] [drm:r600_uvd_init] *ERROR* UVD not responding, giving up!!!Apr 30 21:36:15 vdr4 kernel: [   18.487018] [drm:rv770_startup] *ERROR* radeon: failed initializing UVD (-1).


    Es reicht nicht aus nur die "XXXX_uvd.bin" Datei nach "/lib/firmware/radeon" zu installieren. Leider kollidieren die anderen Nötigen mit dem Paket "linux-firmware", daher nehme ich meinen o.a. Ansatz wieder aus dem PPA, ihr müßte also die Dateien händisch hier runterladen und nach "/lib/firmware/radeon" kopieren, diese sollten IMHO ausreichen:


    Code
    CYPRESS_me.binCYPRESS_pfp.binCYPRESS_rlc.binCYPRESS_uvd.binCYPRESS_pfp.binCYPRESS_rlc.binCYPRESS_uvd.binR600_rlc.binR700_rlc.binRV710_uvd.binSUMO_me.binSUMO_pfp.binSUMO_rlc.binSUMO_uvd.binTAHITI_ce.binTAHITI_mc.binTAHITI_me.binTAHITI_pfp.binTAHITI_rlc.binTAHITI_uvd.bin


    Mit der korrekten FW-Paarung bei meiner Testkarte:


    Code
    [    10.692] (--) RADEON(0): Chipset: "ATI RV730 PRO [Radeon HD 4650]" (ChipID = 0x9498)...Apr 30 22:10:49 vdr4 kernel: [    6.313817] [drm] UVD initialized successfully


    Regards
    fnu

    HowTo: APT pinning

    Edited once, last by fnu ().

  • Das mit den "r600" scheint doch kein Fehler zusein, darunter laufen scheinbar alle Radeons unter mesa.


    Kann mal jemand softhddevice testen, da ja mein C60 sehr schwachbrüstig ist und es vielleicht ja nur daran liegt.
    Ansonsten muß ich doch mal schauen ob mplayer besser läuft, nur gibt der soweit ich weiss keine Framedrops
    aus (der meckert nur wenn es zuvielle sind IIRC).


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • johns


    Ich habe mal alles auf Gentoo nachgezogen, aber wieso wird hier vaapi genommen?



    Muß ich noch was beachten? Oder irgendwo ändern?


    Grüße

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Also habs noch mit ner onboard 4200 auf nem alten m3a785D-M getestet.gleiche grafikfehler im log steht


    [code] tags machen es lesbarer.


    http://en.wikipedia.org/wiki/Radeon_HD_4000_Series


    Ich würde sagen die ist zualt.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • johns


    Ich habe mal alles auf Gentoo nachgezogen, aber wieso wird hier vaapi genommen?


    Muß ich noch was beachten? Oder irgendwo ändern?


    Code
    Apr 30 22:57:08 [vdr] video/vdpau: Can't create vdp device on display ':0'_


    Das ist der Fehler, dann wird der nächste Treiber versucht. Mit -v vdpau erzwingen.
    Dann kein Video bis es funktioniert.


    Keine Rechte? Ist vdr in der Gruppe video?


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Ich würde sagen die ist zualt.


    Naja, "zu alt", sie gehört nicht zu den unterstützen Karten, da hatten wir weiter oben schon drüber diskutiert, RV710-bis-SI, auch wenn der Marketing Name Radeon HD 4200 ist und AMD recht großspurig von "ab HD 4000" spricht ... leider ...


    Was ich mit dem mplayer noch nicht hinbekomme ist MPEG2/SD Streams abzuspielen.


    Code
    mplayer -vo vdpau -vc ffh264vdpau,ffmpeg12vdpau -ao null -fs http://vdr1:3000/TS/9
    ...
    VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration  [fs]
    ...
    VO: [vdpau] 1280x720 => 1280x720 H.264 VDPAU acceleration  [fs]


    Aber die CPU Last liegt mit meiner alten, ;) ,Radeon HD 4650 in einem DH77EB mit Celeron G540 bei etwa 15-20% pro Kern (auf Taktstufe 1,6GHz) mit HD, Bildqualität ist IMHO sehr gut, De-Interlacing augenscheinlich direkt aktiv, habe natürlich leichtes Ruckeln mit dem 50Hz Material auf der 60Hz Desktopusgabe ...


    [Blocked Image: http://s14.directupload.net/images/130430/gpbyeeho.png]
    [Blocked Image: http://s14.directupload.net/images/130430/sugcipc6.png]
    [Blocked Image: http://s14.directupload.net/images/130430/he2mxydc.png]
    [Blocked Image: http://s1.directupload.net/images/130430/zk7xbkzx.png]


    Alle Bilder sind Screenshots von der 1920er Ausgabe, auch "arte HD", eben skaliert ...


    Regards
    fnu

    HowTo: APT pinning

    Edited 5 times, last by fnu ().

  • Hmm, ok die Rechte passen. Wenn ich per -v vdpau erzwinge will er nicht:


    Code
    video/vdpau: Can't create vdp device on display ':0'_
    Apr 30 23:25:39 [vdr] video: 'vdpau' output module isn't supported_


    Da hab ich doch irgendwo Mist gebaut :( . Sorry muß ich mir nochmal genauer ansehen.....

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Das mit den "r600" scheint doch kein Fehler zusein, darunter laufen scheinbar alle Radeons unter mesa.


    Eben erst gelesen, Du hast Recht, aber ist denoch ein Fehler in der Form, das die rlc, uvd, etc. FW-Dateien zussammenpassen/-gehören müssen, mit der "richtigen Paarung" waren die Fehler ja dann auch weg ....

    HowTo: APT pinning

    Edited 2 times, last by fnu ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!