GrafDroid V0.5

  • Hallo Gemuesepudding,

    Schön, dass das jemand weiter führt.

    Freut mich, dass du das so siehst.


    Quote

    Aber vielleicht hätte man einen fork machen sollen. Dann könnte man die Sachen per pull - request wieder konsolidieren.

    Ich würde mich nie als GIT-Profi bezeichnen. Ich habe mich bis zum Checkout an Mini73s Vorgehen gehalten. Im Prinzip könntest du doch von mir pullen und mergen, wenn du auch wieder mit einsteigen willst. Wir müssen uns dann nur einigen wessen GIT jeweils den aktuellen Stand enthält, wer also offizieller Maintainer ist.


    Quote

    Von einen Bug weiß ich noch, den ich Euch nicht vorenthalten möchte: das gTFT-Plugin kann aktuell nur eine Connection annehmen. Die weiteren Anfragen werden gequeued und nicht(!) verarbeitet. Vorbereitet für mehrere ist es aber schon, funktioniert nur nicht. Ich habe aber nicht die Zeit gehabt das zu fixen.

    Das hatte ich auch schon gemerkt, aber es einfach so hingenommen. Das reicht ja normal.


    Tschüß Frank

  • Ist mir letztlich egal. Ich kann auch mein repro löschen und dann deins forken.


    Solange ich in den Codes auch noch drin stehe... Was sicher aktuell nicht überall der Fall ist. Ein klein bissel "seele streicheln" muss sein.

    VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
    VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
    VDR3
    : Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
    Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

  • Solange ich in den Codes auch noch drin stehe... Was sicher aktuell nicht überall der Fall ist. Ein klein bissel "seele streicheln" muss sein.


    Wo wir schon mal dabei sind. Ein kleiner Hinweis im Changelog darauf, dass der eine Bugfix von mir war, würde meine Seele auch gut tun ;).


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ist mir letztlich egal. Ich kann auch mein repro löschen und dann deins forken.

    Wäre für mich natürlich einfacher. ;D


    Quote

    Solange ich in den Codes auch noch drin stehe... Was sicher aktuell nicht überall der Fall ist. Ein klein bissel "seele streicheln" muss sein.

    Ehre, wem Ehre gebührt. :D
    Wird gemacht.


    Wo wir schon mal dabei sind. Ein kleiner Hinweis im Changelog darauf, dass der eine Bugfix von mir war, würde meine Seele auch gut tun ;).


    Mann, das sind ja mehr Änderungen in den Kommentaren, als im Programm. ;D
    Ok, geht klar.



    Tschüß Frank

  • Hallo,


    ich habe GraphTFT via VGA mit dem YAVDR 0.5 laufen.
    Wenn ich Grafdroid auf meinem Handy starte kann ich über "Ansicht"
    die Darstellung auf dem VGA-LCD umschalten, Verbindung zum VDR ist also wohl vorhanden.


    Leider sehe ich auf dem Handy nur das rote Power Symbol.
    Geht das überhaupt mit zwei devices, und wenn ja, kann mir jemand auf die Sprünge helfen?


    Danke, auch alle anderen die hier und an vielen anderen Stellen einen super Support liefern.
    Peter


  • Der Thread ist wirklich noch nicht so lang. Ich finde es ist nicht unzumutbar ihn sich durchzulesen. Hättest du es getan, dann hätte dir in dem Zusammenhang der Post 20 auffallen müssen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Quote

    Von einen Bug weiß ich noch, den ich Euch nicht vorenthalten möchte: das
    gTFT-Plugin kann aktuell nur eine Connection annehmen. Die weiteren
    Anfragen werden gequeued und nicht(!) verarbeitet. Vorbereitet für
    mehrere ist es aber schon, funktioniert nur nicht. Ich habe aber nicht
    die Zeit gehabt das zu fixen.

    Also was soll ich zur Antwort von Gerald sagen.....
    Recht hat er!


    Das hatte ich zwar gelesen aber wohl nicht verstanden, wobei ich mich jetzt
    Frage warum?


    Wie dem auch sei, ich habe mir angewöhnt Probleme über einen längeren Zeitraum
    immer mal neu anzugehen, weil wirklich schnell müssen die VDR Probleme/Wünsche
    nicht gelöst werden. Das hat dazu geführt das ich sehr wenig Fragen gestellt
    habe da andere meisten vor mir schon in ähnliche Löcher gefallen sind, oder
    Funktionen genutzt haben.


    Dies habe ich diesmal wohl nicht getan, dass Ergebnis sieht man ja nun.


    Also auch von mir und auch an mich folgender Appell: lesen, denken,
    probieren und wenn mal was nicht sofort klappt nach einigen Tagen noch einmal
    neu angehen.
    Peter

    Edited 2 times, last by Peter_Juergens ().

  • guten Tag allerseits,


    wollte meinem 7" Tablet einer neuen Verwendung als VDR Display zuführen,


    aber leider kompiliert das graphtft plugin auf meinem Ubuntu 12.10 Testsystem mit vdr 1.7.40 nicht.


    logfiles kann ich im Moment nicht liefen, da ich noch keinen Zugang zum VDR habe.


    Pluginabhängigkeiten hab ich alle in der INSTALL Datei angegebenen installiert.


    Muss ich hierzu den vdr zuerst patchen? bzw. wenn ja, von wo bekomme ich das patchfile?


    Habt bitte nachsicht wenn es sich um eine banale Frage handelt, es hat mich auch schon so sehr viele Nerven und Zeit gekostet


    damit der VDR und ein paar essenzielle Plugins laufen.


    mfg


    haidi

  • Das liegt dem Plugin bei im Verzeichnis patches, ist zwar für 1.7.31, aber funktioniert auch mit .41: http://www.jwendel.de/vdr/vdr-graphtft-0.3.7.tar.bz2

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • hi,


    habs mit dem patch 1.7.31 probiert, aber
    make läuft nicht durch

    :wand


    hat vielleicht jemand eine Idee?


    lg

  • Hi,


    In der dspitems.c (Zeile etwa 472) die Definition der Variable timermatch ändern.


    Code
    //  	int timerMatch = 0;
      	eTimerMatch timerMatch = tmNone;

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • vielen dank,


    hat aber leider nicht geholfen

  • Code
    Fehler: »timerMatch« hat eine vorherige Deklaration als »int timerMatch«


    Du must natürlich die alte Deklaration entfernen.
    Aber du hat oberhalb schon nen anderen Error. Hast du make clean-plugins gemacht ?

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • hi,


    make clean-plugins gemacht
    fehler

    Code
    dspitems.c:424:81: Fehler: »const class cRecordingInfo« hat kein Element namens »EventID«
    In file included from ./theme.h:28:0,
                     from dspitems.c:17:
    ./scan.h: In Konstruktor »Scan::Scan(const char*)«:
    ./scan.h:29:65: Warnung: Der Rückgabewert von »int asprintf(char**, const char*, ...)«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert [-Wunused-result]
    make[1]: *** [dspitems.o] Fehler 1
    
    
    *** plugins with old Makefile: graphtft
  • besagte zeilen in der dspitems



    kenn mich aber zu wenig aus bzw. gar nicht um den fehler zu erkennen


    mfg

  • HI, ich könnte dir meine Version der dspitems.c hochladen, aber warten wir erst ab was die Leute sagen die mehr Ahnung haben als ich.
    Davon gibt es hier mehr als genug - leider ;D ;D


    Was für eine Version von graphtft hast du ?

    VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
    VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

  • Was ist denn mit der Zeile passiert?


    Code
    return Str::toStr(!recording->Info() ? na : (int)recording->Info()-$


    Ich hab da


    Code
    return Str::toStr(!recording->Info() ? na : (int)recording->Info()->EventID())

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Und dazu braucht man doch das graphtft-Plugin, oder nicht?

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!