[solved] music-plugin mit softhddevice?

  • Hallo zusammen,
    kann mir jemand sagen ob und wenn ja, wie man das music-plugin mit softhddevice zum laufen bringt? Oder ist das nicht möglich (ich habe gelesen es kann "Probleme" verursachen, dass man nichts sieht, wie bei mir, hätte ich eigentlich nicht erwartet). MP3s werden bei mir abgespielt, aber ich seh' halt nix auf dem Fernseher. Wenn ich auf xine umstelle funktioniert es, da stört mich aber das sonst bei jedem Kanalwechsel die Bildgrösse neu angepasst wird.
    ... ach ja ... und ich benutze xbmc nicht so gerne, weil man das explizit starten und nachher wieder beenden muss, ich hätte es gerne in den "normalen" Betriebsmodus integriert.
    Danke im Voraus für nützliche Infos, ich kann auch mit "spar die mühe, das läuft nicht" leben, wenn es wirklich nicht geht.
    cu,
    Bernd

    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

    The post was edited 2 times, last by befi ().

  • hi,


    es laeuft mit softhddevice und ist eigentlich recht einfach zu installieren ;)
    Ich kenne aber nicht die Eigenarten von der Distri und soweit kann ich nur
    raten.
    Schau halt mal ins Log ob da ein Hinweis erscheint.


    Normalerweise installiert/kompiliert man das Plugin , schiebt den mitgelieferten Ordner an die richtige Stelle und es laeuft.
    Mit xineliboutput und FF-HD "kann" es Probleme geben , was aber nur eine Einstellungssache ist.
    Ansonsten gitb es da auch noch Muggle-Plugin , MP3-Plugin und Play(-Plugin) .
    Was davon schon oder noch lauffaehig ist, kann ich zwecks Nichtbenutzung nicht schreiben.
    OK, MP3-Plugin wird schon laufen :D


    bye

  • Hallo Bernd,


    ... als Ergänzung: Im music-plugin Audio - Ausgabe auf DVB stellen.


    vG
    Wolfgang

    Clients
    VDR1: yaVDR 0.5 stable auf ZOTAC ION A 4Gbyte RAM / mit ATRIC - IR - Einschalter softhddevice per streamdev am Server
    VDR2 / VDR3: MLD 5.1 auf Raspberry pi3
    2 x VOMP 0.4 auf mediamvp
    Server
    Cubietruck, Lubuntu Trusty, vdr aus yaVDR - sourcen, 1 x TT S2-3600, 1 x TT S2-3650 CI, 1 x sundtek SkyTV III, 1 x sundtek SkyTV IV

  • Gundsätzlich läuft das plugin ja auch, ich kann Musik auswählen und wenn ich Play drücke dudelt es lustig vor sich hin. Nur auf dem TV sehe ich nichts als eine zuckende, fortlaufende Zeitanzeige links unten und einen ebenfalls zuckenden Fortschrittsbalken. Auf Tasten/Fernbedienung reagiert alles ganz wie es soll. Jede weitere Hilfe ist sehr willkommen :-)


    Das syslog sagt:


    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

  • O.K. ... das zucken ist weg, lag wohl an der Visualization, die habe ich ausgeschaltet. Nun habe ich direkt beim Start des plugins ein Bild, so wie es sein soll, dann wird's schwarz und ich seh' nur noch einen schwarzen Bildschirm mit Spieldauer und Fortschrittsbalken

    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

  • wenn auch niemand eine Idee hat, wäre es möglich das jemand der softhddev benutzt mal kurz das music-plugin in seiner umgebung ausprobiert und feedback gibt, ob ich hier ein persönliches Problem habe oder es wirklich nicht geht?
    Wäre ganz toll, besten Dank im Voraus!!!!

    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

  • Was stört dich? Scheint doch zu gehen oder sollte es nicht schwarz werden?


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Was stört dich? Scheint doch zu gehen oder sollte es nicht schwarz werden?

    Genau, schwarz sollte zwar der Hintergrund werden (also kein Live-Bild), aber das plugin sollte titel, cover, artist, etc anzeigen, aber nicht nur die Zeit die tickt

    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

  • Also fehlt das OSD, Bekommt man den mit Menu das VDR OSD zur Sicht?


    Ich kann leider nicht testen, da ich das Plugin nicht übersetzt bekomme:

    Code
    1. data-mp3.h:78:7: error: redefinition of 'class cImage'
    2. /usr/include/vdr/osd.h:415:7: error: previous definition of 'class cImage'


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Hi johns,



    Ich kann leider nicht testen, da ich das Plugin nicht übersetzt bekomme:


    guckst Du:
    kann PLUGIN "music" nicht erstellen
    gab auch einen Patch...finde den leider nicht!


    Gruss
    Wolfang

  • Ersetzen hat geklappt. Nur stürzt das Plugin schon beim Menuaufruf ab.



    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Letzte veröffentlichte Version des music-plugins ist AFAIK vdr-music-0.9.9-dev2


    läuft hier (kein yaVDR) mit VDR-1.7.38 und softhddevice (git) ohne Probleme.


    wie bei tomas (kein yaVDR) ..easyvdr - VDR-1.7.38 -> music-0.9.9-dev2 alles Ok.
    [IMG:http://image-upload.de/thumb/3KjB0a/ac4bc53e3f.jpg]


    Gruss
    Wolfgang

  • Danke,


    Da ist mal wieder einen neue Version steckt, dann mal schnell alle Distributionen aufwecken.


    Dann werde ich erstmal nicht weitersuchen, da ja mit der Version alles in Ordnung scheint.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Moin,


    es gibt keine neue Version , die Genannte ist ja auch schon ~ 1 Jahr alt
    und wie schon geschrieben , laeuft das Teil mit Softhddevice bis 1.7.38
    problemlos ( bis auf das 8 Sekunden -Problem ;))


    Wenn man nur den Titel und die Progressbar etc sieht , dann liegt es daran ,
    dass das Hintergrundbild nicht geladen wird/werden kann.
    Entweder es ist nicht da wo es erwartet wird oder keine Leserechte /etc.
    ( abgesehen von den 100 Trilliarden Einzelfaellen , welche bei Software auftreten "koennen")

  • Ich benutze die Version, die in der yavdr-paketliste ist. Wenn ich es starte, kann ich Musik auswählen, dann flackert kurz das UI vom plugin auf, danach sehe ich dann nen schworzen Bildschirm :-/. Musik wird abgespielt, ich kann das plugin bedienen, aber im play mode dann eben wieder nix ...



    Hab mal die settings vom softhddevice und music-plugin angehängt, vielleicht sieht jemand was.





    --
    yavdr 0.6.1, Case: Antec Veris Remote, Mainboard: ASUS M5A78L-M/USB3, DVB-S: 2 x TT S2-3200
    Graveyard: Asus pundit, M4N78-AM V2, TeVii S646

  • Hi,



    Hab mal die settings vom softhddevice und music-plugin angehängt, vielleicht sieht jemand was.


    Code
    1. music.WebstreamDat = /VDR/etc/plugins/moronsuite/music/language/german/data


    sollte der Pfad nicht

    Code
    1. music.WebstreamDat = /etc/plugins/moronsuite/music/language/german/data


    sein?

    Gruss
    Wolfgang

  • Bei den Settings vom Music-Plugin ist nichts verdaechtiges dabei.
    An Softhddevice duerfte es auch nicht liegen , ansonsten wuerdest du garnichts sehen.


    Ausser , hat aber jetzt nichts mit dem Problem zu tun, in den Einstellungen koennte man "Benutzerlevel" auf Superadmin stellen.


    Wenn du den Fehler eingrenzen moechtest , dann musst du folgendes sicherstellen :


    a . Welche Version ?
    Steht in den Einstellungen oder wird beim VDR Start im Systemlog hinterlegt (ensprechender loglevel ( -l 3 ) vorrausgesetzt)
    Sieht z.B so aus : " initializing plugin: music (0.9.4-testing): MP3-/Audioplayer"


    b. Wo erwartet das Plugin seinen Ordner ?
    Auf der Konsole folgendes eingeben :
    svdrpsend PLUG music CONFIG
    Sieht z.B so aus: "900 /home/stefan/VDR/etc/plugins/moronsuite/music"


    In diesem Ordner gibt es einen Unterordner namens "themes".
    In dem Ordner themes die Datei "current.colors" loeschen und VDR neu starten ( nicht den Rechner ;))


    Jetzt sollte im Systemlog folgendes erscheinen :


    Mar 2 16:01:39 slimline vdr: [6349] initializing plugin: music (0.9.4-testing): MP3-/Audioplayer
    Mar 2 16:01:39 slimline vdr: [6349] music: music: initial configdir set to '/home/stefan/VDR/etc/plugins/moronsuite/music'
    Mar 2 16:01:39 slimline vdr: [6349] music: skin: load themefile from '/home/stefan/VDR/etc/plugins/moronsuite/music/themes/current.colors'
    Mar 2 16:01:39 slimline vdr: [6349] music: WARNING: no themefile found ! Using default skin '/home/stefan/VDR/etc/plugins/moronsuite/music/themes/skins/DEFAULT/'
    Mar 2 16:01:39 slimline vdr: [6349] loading /home/stefan/VDR/etc/plugins/moronsuite/music/musicsources.conf
    Mar 2 16:01:39 slimline vdr: [6349] music: decoder: load current_user.dat from '/home/stefan/VDR/etc/plugins/moronsuite/music/data/current_user.dat'
    Mar 2 16:01:39 slimline vdr: [6349] music: loading id3 cache from /home/stefan/VDR/etc/plugins/moronsuite/music/data/admin/id3info.dat

  • Quote

    sollte der Pfad nicht


    Den Pfad kannst du im Setup vom Music-Plugin anpassen.
    Hast halt noch nicht gemacht , hat aber mit dem Anzeigeproblem nicht zu tun.
    Der Pfad sollte auf ein Verzeichnis zeigen , wo auch User Schreibrechte haben.
    Wie eigentlich auch der ganze Ordner vom Music-Plugin und all die anderen.
    "/etc/vdr.." fand ich noch nie eine gute Idee aber wenn yaVDR es dort verlangt,
    nun ja.. ;)