[ANNOUNCE] VDR developer version 1.7.38

  • Frisch aus der ML:



    Danke an Klaus für die neue Version!

    Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
    In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::


    "Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

  • skiller2k1


    Man, von Dir habe ich ja lange nix gelesen ... 8o


    kls


    :thumbsup:

    HowTo: APT pinning

  • Vielen Dank für die neue Version :thumbup:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Moin, Moin



    bin gerade am bauen, Streamdev ( git + newMakefile 1.7.36 ) läßt sich nicht bauen.....



    Grüße Frank

  • vdr4arch ist schon aktuell.


    Ja, das Build-System macht es einem da ja zum Glück auch sehr leicht :)


    ...vielleicht haben ja auch mal ein paar **vdr-unstable-nutzer was davon (pfeiff )


    Einfach beim Paketbauen mit dem neuen Makefile-System helfen (eigenes PPA aufmachen, yavdr/unstable-main yavdr/main und das verlinkte als Build-Depends setzen), dann geht es schneller - sobald alle Abhängigkeiten von yavdr-essential gebaut sind, kann es ja rein theoretisch unter yaVDR genutzt werden...
    https://launchpad.net/~seahawk…tmail/+archive/vdr-1.7.37

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • bin gerade am bauen, Streamdev ( git + newMakefile 1.7.36 ) läßt sich nicht bauen.....


    Hast du das DVBDIR richtig gesetzt (falls deine DVB-Treiber woanders liegen als die Kernelmodule)?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, das Build-System macht es einem da ja zum Glück auch sehr leicht

    Und trotzdem muss ich mich wundern, dass Distributionen deren Build-System das eben nicht tun, sich doch nicht bei den Usern disqualifizieren...

    8)


    Gentoo overlay mit VDR (und nicht nur) ebuilds, vdrcm, GLCDprocDriver

  • Solange die alles vorgekaut bekommen, ist es denen total egal...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vielen Dank fuer die neue Version


    Ich kann den Fehler von Gandalf bestaetigen. Gleiche Problem
    Ich habe kein spezielles DVB Dir. Nutze die Kernel Treiber


    OK sind
    - epgsearch
    - text2skin
    - vdrmanager-06
    - xvdr


    Ausser vdrmanager alle aktuelles Git
    softHDDevice auf den Clients hab ich nicht getestet

    Server PC leap42.1 ::: vdr-2.2.0 ::: 2xSatelco EasyWatch-C headless
    Client 2 x Raspberry 2 + libreElec 7.0.1

  • ...vielleicht haben ja auch mal ein paar **vdr-unstable-nutzer was davon (pfeiff ?( )


    Ich denke jetzt mal laut, an der 1.7.38 wird sicher intern gearbeitet, aber aufgrund der vielen, vielen Anpassungen an den Makefiles, wird Euch eher die 2.0 erreichen, was ja nimmer soweit hin ist, hoffentlich ... :)


    Die Nasen die sich hier über das Build-System eines Linux-Derivats echauffieren haben keine Ahnung was das für einen Aufwand bedeutet, welche Abhängigkeiten man beachten muß, das alles so zu paketieren, das Nutzer sich das nur noch ziehen müssen. Einen schlichten VDR wie in mancher Signatur hier, kann jeder Distributor in kurzer Zeit auch für sich aufbauen, aber das ist keine Kunst ...


    Nopacity sieht echt toll aus jenseits von v0.4@1.7.33...


    Ich breche hier mal eine Lanze für Klaus "LCARS", es ist mutig und das modernste aktuellste Design der neueren Skin-Angebote, gefällt mir gut.


    Regards
    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von fnu ()

  • Hi,
    ich baue VDR und die dazugehörigen Plugins mit make, alles ohne Probleme. Es wird auch das dvbhddevice gebaut, aber nicht nach PLUGINS/lib kopiert. EIne Make.config nutze ich nicht....
    Funktioniert es bei jemanden?

  • Wie genau machst du make?


    Wenn das Plugin im VDR Quellverzeichnis liegt und du im Pluginverzeichnis make machst, dann wird das *.so nicht kopiert. Das ist jetzt halt so.


    cu

  • softhdDevice ist auch OK


    Mein Streamdev Fehler beschraenkt sich nur auf das folgende ( die DVB Version 5.3 or higher hab ich nicht)


    Code
    1. In file included from streamdev-client.c:10:0:/vdr/services/vdr-devel/vdr-1.7.38/include/vdr/device.h:331:16:
    2. error: virtual bool cDevice::HasLock(int) const was hidden [-Werror=overloaded-virtual]../client/device.h:31:15:
    3. error: by virtual bool cStreamdevDevice::HasLock(int) [-Werror=overloaded-virtual]cc1plus: some warnings being treated as errors

    Server PC leap42.1 ::: vdr-2.2.0 ::: 2xSatelco EasyWatch-C headless
    Client 2 x Raspberry 2 + libreElec 7.0.1

  • softhdDevice ist auch OK


    Mein Streamdev Fehler beschraenkt sich nur auf das folgende ( die DVB Version 5.3 or higher hab ich nicht)


    Code
    1. In file included from streamdev-client.c:10:0:/vdr/services/vdr-devel/vdr-1.7.38/include/vdr/device.h:331:16:
    2. error: virtual bool cDevice::HasLock(int) const was hidden [-Werror=overloaded-virtual]../client/device.h:31:15:
    3. error: by virtual bool cStreamdevDevice::HasLock(int) [-Werror=overloaded-virtual]cc1plus: some warnings being treated as errors


    Die Funktion ist jetzt 'const'.
    Also einfach das 'const' hinten anfügen und gut is'.


    Sorry deswegen, ich wollte ja eigentlich keine Interfaces mehr ändern. Aber da ich cDevice::HasProgramme() in einem 'const'-Kontext brauchte und dabei sah, daß auch cDevice::HasLock() nicht 'const' war, obwohl es das eigentlich sinnvollerweise sein sollte, hab' ich das noch mitgenommen.


    Klaus

  • Wie genau machst du make?


    Wenn das Plugin im VDR Quellverzeichnis liegt und du im Pluginverzeichnis make machst, dann wird das *.so nicht kopiert. Das ist jetzt halt so.


    Ich habe make im VDR Verzeichnis gestartet. Neuerdings baut er auch damit die Plugins. DIe meisten Plugins landen auch im PLUGINS/lib Verzeichnis... aber die habe wohl noch das alte Makefile Format....


    Ok, ich sehe gerade das nach einem make install das Plugin entsprechend in den Ziel Ordner landet, nur nicht in PLUGINS/lib ... blöd. Ok muss man sich dran gewöhnen ... ;)


    EDIT: habe mir LIBDIR entsprechend angepasst! Nun wird es nach make install in diesen Ordner kopiert... :D


    Danke für den Tipp.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Uwe ()