diverse probleme nach kerne-update

  • hallo zusammen - ich hab meine Wohnzimmer-Maschine upgedated - für den WAF war das zunächst eine schlechte Idee....


    in diesem Thread:hatte ich schon über Probleme mit lirc berichtet -das ist jetzt zumindest mal soweit in Ordnung, als das die Module geladen sind (lirc_dev und lirc_serial) und irw sowie mms wieder sauber gehen.


    Meine Probleme mit xine-ui hatte ich hier geschildert - auch die sind gelöst


    Ich kann derzeit mit xine-ui fernsehen - aber ich habe noch 3 Probleme:


    1. xine-ui (0.99.7) connected zwar zum lircd - aber die Kommandos der FB kommen trotzdem nicht bei xine an- oder zumindest schert sich der vdr einen feuchten drum. Wohlgemerkt ich habe weder an der lircd.conf noch an dem Aufruf für xine-ui noch an der keymap für xine etwas geändert - auch die build-options für xine sind noch gleich.


    den vdr starte ich mit:

    Code
    1. /usr/local/bin/vdr --user=vdr /usr/local/bin/vdr --epgfile=/nas/Video/vdr0/mms1.data --config=/etc/vdr --log=3 --watchdog=0 --record=/usr/local/bin/noadcall.sh --shutdown=/etc/vdr/vdrshutdown --video=/nas/Video/vdr0 --grab=/nas/Video/vdr0/grab -Pstreamdev-server -Pdvbapi -Pxine -r -Pskinenigmang -Ptext2skin


    xine-ui läuft so:

    Code
    1. /usr/local/bin/xine --no-splash -A alsa -V vdpau --post vdr --post vdr_video --post vdr_audio --aspect-ratio=anamorphic --post tvtime:method=use_vo_driver --verbose=2 --no-logo --fullscreen --keymap=file:/home/mms/.xine/keymap-vdr vdr:/tmp/vdr-xine/stream#demux:mpeg_pes


    die lircd.conf sieht so aus (funktioniert wunderbar mit mms):


    2.alsa läuft nicht - ich habe zwar jede menge snd-treiber geladen - und xine spielt auch schön den Ton vom vdr ab - aber mms mosert über ein fehlendes alsa. alsaconf findet auch keine soundkarten. Ich habe schon alsa-drivers-1.25 gezogen - aber die bauen nicht unter 3.7er kernel



    und


    3. (aber das bekomme ich irgendwie dann auch noch hin - und wenn ich das plugin in mms anpacke:
    das epg-plugin von mms bringt den vdr zu der Meldung:

    Code
    1. Feb 9 11:36:57 mms1 vdr: [2922] ERROR (svdrp.c,423): Die Verbindung wurde vom Kommunikationspartner zurückgesetzt


    Da an dem Plugin nichts geändert wurde, muss die Ursache am Code in svdrp.c im vdr liegen - was ist dort generell anders als in den versionen vor 1.7.16?


    Prob #3 ist zwar derzeit lästig aber nicht kriegsentscheidend


    Hat Irgendwer gute Ideen für #1 und #2?


    .

    The post was edited 1 time, last by magicamun ().

  • Was ich grad noch festgestellt habe - Pause z.B. und Play kommt zumindest in xine an - löst dort aber nicht die entsprechenden vdr-keys aus - sondern ausschließlich die xine-Variante mit dem kleinen Play/Pause-Symbol in der linken oberen Ecke.

  • so - ich bin mittels einiger fprintfs weitergekommen.


    das xine-plugin bekommt die Key-Presses - soweit ist mal alles gut. in xineRemote.c


    so ungefähr ab Zeile 176 steht jetzt (bei mir folgendes - die fprintfs haben mir geholfen das Problem einzugrenzen:



    das Problem IST, dass m_remoteOn FALSE ist - wenn ich das "if" inkl. zugehöriger Klammern auskommentiere, flutschts 1A.


    m_remoteOn ist also nicht korrekt initialisiert - oder aber mein Argument "-r" wird nicht korrekt geparsed - ich suche weiter - aber es wird

  • shame on me.... Prob #1 ist hausgemacht und liegt an fehlender Maskierung des "-Pxine -r" beim start des vdr.