MLD 3.01 für das Raspberry Live TV

  • Nabend,


    Ich habe eine Alternative zu XBMC für Live TV am PI gesucht und mir wurde VOMP empfolen.
    Damit sollte der XVDR Client funktionieren und alles etwas schneller laufen.
    Stimmt das ?


    Jetzt habe ich mir MLD heruntergeladen und auf die SD geschoben. jetzt sehe ich leider nur einen Mauszeiger und weiß auch leider schon nichtmehr weiter.
    Ich finde leider auch kein Howto.


    Meine backend ist ein VDR Server mit XVDR

  • Lies mal in diesem Thema, damit geht live TV bei mir problemlos...


    Munter bleiben, Rossi

  • Hallo,


    Ich war jetzt längere zeit leider nicht im Thema.
    openelec habe ich natürlich alsm erstes versucht... TOP Distro....
    Leider stört es mich wirklich SEHR, das ich nichteinmal die Kanalliste öffnenkann, ohne das das Pi mir damit abschmirt nach einiger zeit.


    Daher suche ich noch immer eine Alternative zur doch extrem CPU Lastigebn XBMC Lösung.


    Ist es den wirklichso, das ich MLD als XVDR Client benutzen kann?

  • Hi,


    wie macht man denn mit MLD für RPI am besten ein Backup (*.tar.gz) von seinen Einstellungen mit dem gesamten Image
    um sich dann ein Ersatz-SD-Card zu erstellen?


    Backup über Webif kann man ja installieren ---> Hmm, aber nur wie jetzt weiter wenn man nur den VompClient hat.


    Grüße
    cinfo

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Hi,


    ob die Backup Funktionen der MLD auch beim RPI greifen weiß ich nicht. Hab das nie getestet. Ich hab bisher immer einfach ne Kopie der SD Karte erstellt, wenn ich nen Backup haben wollte, und das dann bei bedarf zurückgespielt. Das lässt sich ja problemlos im Dateimanager erledigen.


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT

  • Hi,


    Quote

    Das lässt sich ja problemlos im Dateimanager erledigen.


    danke, konnte ich so ohne Fehler durchführen. Ist eigentlich eine super Lösung, so konnte i
    ch eine kleinere SD-Karte als dar Org. wählen und alles wieder raufspielen. :D


    Grüße
    cinfo

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

    The post was edited 1 time, last by cinfo ().

  • Wollte nur auf die Schnelle 'mal meine Begeisterung loswerden:
    Habe in einem Anfall von, "das mache ich jetzt!" noch kurz vorm Tatort (19:30 Uh) meine yavdr.list auf vdr-testing umgestellt, kurzerhand den vdr inklusive meiner wenigen Pluguns und dem vompserver-plugin um den rPI per MLD vomp-client endlich an den Start zu kriegen) per apt-get install vdr auf den neuen Stand gebracht (auweia: VDR = Version 2.0.1), alle alten configs behalten und das neuestes vomp-dongle für die MVPs eingespielt


    ...und was soll ich sagen:


    alles läuft, alles wie gewünscht, HD mit vomp Oberfläche, ein identisches Bedienkonzept auf SD und HD clienten, UTF-8 patch auch gleich drin. Ich bin schlicht begeistert!


    DAS IST SUPER! Tausend Dank an die Entwickler! :D


    kein Vergleich zu den Problemen beim Dist-Upgrade auf precise, hier lief zum Tatort wieder alles.
    Mit dem zweiten HDMI-Kabel ging dann auch die Sony FB per CEC


    Der vomp auf dem rPI (512mb) tut was er soll, bei HD-Live gibt es manchmal kleine Ruckler, bei Aufnahmen habe ich das bisher nicht gesehen.
    Kann man da noch an der config des rPI drehen? (Takt etc. ich hatte bisher keine Zeit mich damit näher zu beschäftigen).
    SD-Kanäle werden mir auf dem rPI Vomp nicht angezeigt, möglicherweise weil ich bisher keine MPEG-Lizenz habe? oder warum?

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

    The post was edited 2 times, last by vdrjoe ().

  • Auf dem Pi brauchts die Lizenz für SD-Sender. Musst du in die config.txt packen. Ansonsten sollte man den Pi dynamisch Übertakten. Das ist sogar von Broadcom freigegeben. Evt. verschwinden damit die Probleme. Ich hab bei HD die wenigsten Probleme und das mit dem Schwergewicht XBMC im Hintergrund. Da Ruckelt bei mir eigentlich absolut nix..

  • Zu früh gefreut?

    Quote

    Mit dem zweiten HDMI-Kabel ging dann auch die Sony FB per CEC


    tja, nach einem VDR restart bei laufendem RPI-Vomp war es auf einmal aus mit der Fernbedienbarkeit über CEC.
    Auch ein erneutes Aufspielen der MLD-Vompclient-Distri auf die SD-Karte brachte keine Änderung.
    Der Sony KDL40W4500 findet einfach keine HDMI-Gerät mehr!
    Bin nun ziemlich ratlos, kann naürlich auch am Sony-TV liegen. (DLNA mag der auch nicht so richtig.)


    Mangels Bedienbarkeit kann ich den Vorschlag von MartenR leider nicht testen.
    Eine alternative Bedienung ist bisher scheinbar nicht vorgesehen (bzw. aktuell nicht in Entwicklung) ?

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Hallo,


    Das liegt bestimmt am Sony TV habe das baugleiche Modell KDL40W4710 und bei diesem funnktioniert auch sporadisch keine HDMI-Strg mehr.
    Fehler lässt sich mit "Einstellungen --> Grundeinstellungen --> Komplette Rücksetzung" beheben.


    MfG


    Joe

    YAVDR [0.6] :strike1 - CINE S2 V5.4- Technisat SKYSTAR HD2 + CI + AlphaCrypt - INTEL DH67BL - INTEL G630 - ASUS ENGT520 SILENT/DI/1GD3(LP) - LCD TV Sony KDL 40 W 4710
    MLD 5.0.0 - für Raspberry PI2

  • Quote

    Eine alternative Bedienung ist bisher scheinbar nicht vorgesehen (bzw. aktuell nicht in Entwicklung) ?


    Tastatur sollte gehen, Fernbedienung auch wenn diese vom Kernel als input/event device unterstützt werden (ungetestet).


    Marten

    vdr experimental, Femon, vdr live, acpi-wakeup, vompserver, undelete, epgsearch, vdr-burn, Raspberry Pi und Vompserver Windows Client (build from git)

  • Danke das war's!


    Wie oft passiert das so bei Dir (ich hatte das Problem ja bereits nach 1 h!)
    Das Sony keine Firmware-Updates bietet ist auch echt schwach.
    Gut, die Kiste ist mittlerweile knapp 5 JAhre alt, aber hat auch etwa das fünffache des nueun Samsung meines Schwiegervaters gekostet, das Ding hätt' ich eigentlich auch gern.

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Danke das war's!


    Wie oft passiert das so bei Dir (ich hatte das Problem ja bereits nach 1 h!)
    Das Sony keine Firmware-Updates bietet ist auch echt schwach.
    Gut, die Kiste ist mittlerweile knapp 5 JAhre alt, aber hat auch etwa das fünffache des nueun Samsung meines Schwiegervaters gekostet, das Ding hätt' ich eigentlich auch gern.


    Seitdem ich auch mit einem Raspberry experimentiere habe ich das 1-2x täglich.
    Momentan teste ich wie ich den Fehler reproduzieren kann, aber leider passiert das anscheinend nicht nach einem bestimmten Muster.
    Wenn der Pi nicht mehr per HDMI-STRG funktioniert, dann funktionieren bei mir auch keine anderen Betriebsmittel nicht mehr per HDMI-STRG (PS3, Sat-Receiver, ...)


    MfG
    Joe

    YAVDR [0.6] :strike1 - CINE S2 V5.4- Technisat SKYSTAR HD2 + CI + AlphaCrypt - INTEL DH67BL - INTEL G630 - ASUS ENGT520 SILENT/DI/1GD3(LP) - LCD TV Sony KDL 40 W 4710
    MLD 5.0.0 - für Raspberry PI2

  • 1-2x täglich würde den hart erarbeiteten WAF ganz erheblich senken, dann werde ich mich mal um nach einer IR-Lösung umsehen.
    Funktioniert die Steuerung per CEC denn mit Deinen anderen Geräten problemlos an dem Sony-TV? Dann gäbe es ja noch Hoffung.
    Ich habe CEC bisher nie genutzt (bzw. gar nicht gekannt) und 'ne Harmony für alle Geräte genutzt.
    Nochmals Danke für den zielführenden Hinweis.

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • @ MartenR

    Quote

    Tastatur sollte gehen, Fernbedienung auch wenn diese vom Kernel als input/event device unterstützt werden (ungetestet).


    also meine USB-Tastatur scheint zwar zu funktionieren (NUM-Lock lässt sich toggeln) aber weder über die Pfeiltasten nochr über Ziffern-Anwahl erhalte ich eine Reaktion.
    aber ARD HD (Pokal) läuftr schion seit > 1h ohne Ruckeln oder sonstige Probleme, selbst die Kanalwechselzeiten sind besser als beim meiner Zbox über Streamdev!
    Bin immer noch begeistert!!

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Morgen,

    1-2x täglich würde den hart erarbeiteten WAF ganz erheblich senken, dann werde ich mich mal um nach einer IR-Lösung umsehen.
    Funktioniert die Steuerung per CEC denn mit Deinen anderen Geräten problemlos an dem Sony-TV? Dann gäbe es ja noch Hoffung.
    Ich habe CEC bisher nie genutzt (bzw. gar nicht gekannt) und 'ne Harmony für alle Geräte genutzt.
    Nochmals Danke für den zielführenden Hinweis.

    Bei meinen anderen Geräten (PS3, TT-Micro S815) funktioniert die Steuerung auch über Monaten ohne Probleme, bis wieder mal kein Gerät mehr per CEC anspricht.


    Da Sony kein Firmware-Update mehr liefert ist dieser Fehler natürlich ein wenig doof.


    MfG
    Joe

    YAVDR [0.6] :strike1 - CINE S2 V5.4- Technisat SKYSTAR HD2 + CI + AlphaCrypt - INTEL DH67BL - INTEL G630 - ASUS ENGT520 SILENT/DI/1GD3(LP) - LCD TV Sony KDL 40 W 4710
    MLD 5.0.0 - für Raspberry PI2

  • Hab bei meinem Pi mit Openelec auch auf eine IR-Diode gewechselt welche recht einfach an den GPIO angebunden wird. Kostenpunkt 1EUR und man hat die volle Funktionalität von LIRC. Hauptgrund war bei mir das der TV an sich schon eine lahme FB hat und das sich dann genauso aufs CEC auswirkt. Inwiefern natürlich bei MLD das ganze Backend voll Einstellbar ist weiß ich nicht. Mit CEC hats bei mir Problemlos funktioniert.

  • pepino :

    Quote

    Da Sony kein Firmware-Update mehr liefert ist dieser Fehler natürlich ein wenig doof.


    Gab es denn überhaupt einmal von Sony ein Update für den KDL40W4500/4750 ?
    Als ich vor zwei Jahren 'mal im Sony center nachgefragt hatte, haben die etwas sparsam geschaut.
    Bei einem damals schon 3 Jahre alten Gerät ein Update?


    Kaufen Sie doch ein neues haben sie allerdings nicht gesagt.
    Nett war noch das zufällig mitgehörte Verkaufsgespräch bzgl. Tablett <-> TV Interaktion:#
    "Ach, sie haben noch ein iPAD?" (Gibt offenbar noch mehr Hinterwäldler ;)

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Habe gerade die Lizenzkeys fürt MPEG2 und WVC1 erhalten und per putty und vi unter MLD in die /config.txt eingetragen.
    Doch weder "reboot" noch Hard-Reset per Netzteil ziehen führen nachfolgend zum Erfolg.
    vcgencmd codec_enabled MPG2
    oder
    vcgencmd codec_enabled WVC1
    sagen immer "disabled"
    was mache ich falsch?
    ist die /config.txt im root von MLD das richtige config file?
    Die Lizenzkeys habe ich wie gesagt per copy&paste per putty übertragen, die serialnumber stimmt auch.


    Im posditiven Fall sollten dann doch auch die SD-Kanäle unter rpi-vomp zu sehen sein, oder muss dazu etwas am server-plugin verändert/eingestellt werden?
    Bin wie immer für jeden Hinweis dankbar

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)